Issues opening desktop app even when allowing "App Store or identified developers'

Discussion in 'macOS Catalina (10.15)' started by cezinho, Jul 19, 2019.

Tags:
  1. cezinho macrumors newbie

    Joined:
    Dec 28, 2009
    #1
    I cannot open the WhatsApp desktop app on MacOS Catalina 10.15 beta 4 (19A512f).

    Not sure if this is related to the limited functionality of the beta, but the issue looks like this:
    1. Click on Applications > WhatsApp to open the app
    2. Error message shows up
    3. Open System Preferences > Security & Privacy > General
    4. Click on Allow apps downloaded from > App Store and identified developers > Open Anyway
    5. The Open Anyway button does not do anything
    Has anyone else experienced this issue?
     

    Attached Files:

  2. NecRosex macrumors newbie

    NecRosex

    Joined:
    Jul 16, 2019
    Location:
    babyLon
    #2
    Experienced it trying to open Firefox (when there is a Firefox update) it just won't open as it attempts to run its integrated software update and update Firefox to the newest version.
    I haven't been able to bypass this, but downloading the newest version and launching that one is okay and works as it eliminates the need for it to update.
    It's most likely either 3-rd party Apps not optimised for Catalina yet or macOS itself. It should be addressed at some point during the beta stage. File a report. The more the reports the more likely will Apple look into it.
     
  3. cezinho thread starter macrumors newbie

    Joined:
    Dec 28, 2009
    #3
    Thanks! Good to know. FYI I was able to resolve the issue by pulling down the WhatsApp dmg file directly from WhatsApp's website, vs using the MacOS App Store as I had it set up previously.
     
  4. SKStrategia06, Jul 19, 2019
    Last edited: Jul 20, 2019

    SKStrategia06 macrumors newbie

    SKStrategia06

    Joined:
    Mar 26, 2019
    Location:
    Chicagoland
    #4
    While this won't work for WhatsApp, on Firefox you can bypass the macOS security by running a few terminal commands.
    1. sudo spctl --master-disable in terminal emulator of choice
    2. Run app, update it
    3. Close app
    4. sudo spctl --master-enable in terminal
    5. Run app again
    Edit: If you don't run the spctl enable command, WhatsApp will also work, but I don't recommend doing that as it will shut off the Gatekeeper security completely.
     

Share This Page

3 July 19, 2019