Issues with Apple USB-C Digital AV Multiport Adapter

Discussion in 'MacBook Pro' started by ramen5677, Dec 13, 2016.

  1. ramen5677 macrumors newbie

    Joined:
    Oct 29, 2016
    #1
    Hello,

    I am on a 2016 nTB MBP, and I have problems with the Apple USB-C Digital AV Multiport Adapter:
    My iPhone does not connect, connection to external Harddrives does regularly fail, and when connected to an external display via HDMI at the same time I get unexpected hard shut downs.
    I already replaced the Adapter once. Is this a common issue? Is there a Problem with Apples Multiport Adapter or with my MBP?

    Thanks in advance
     
  2. Lou-X macrumors member

    Lou-X

    Joined:
    Oct 31, 2016
    #2
    Tomorrow I will get both ntb and av adapter and will try it. I have no iPhone but I'll check power + hdmi + something else on the usb
     
  3. Brookzy macrumors 601

    Brookzy

    Joined:
    May 30, 2010
    Location:
    UK
  4. wchigo macrumors 6502

    wchigo

    Joined:
    Apr 6, 2015
    #4
    I have the updated firmware as the above poster mentioned.

    I've yet to use the HDMI port but connecting the adapter and using the USB-C port to charge while connecting an external hard drive to the USB-A port at the same time has yielded no issues whatsoever.

    Base nTB 13" with upgraded SSD to 512 here.
     
  5. kb3tzt macrumors member

    kb3tzt

    Joined:
    Nov 1, 2016
    #5
    it seems to be an issue for me also. I've gone through 4 of these wonderful pieces of crap. I've had usb issues, as a keyboard connected to the usb portion will randomly fail to wake up the MacBook Pro. I have a hdmi monitor connected to it along with the charging cable. even opening up the macbook, the USB port will not function. monitor also displays wonky colors and noise. if I go the bluetooth route, all functions fine, so the issue resides possibly with the adapter. as a side note, I removed the keyboard from the adapter and connected via a usb to c plug directly and the issue is less frequent but still happens. I'm beginning to think its Sierra not playing nicely with usb-a type items. I have a usb-c gen 2 raid system set up, connected directly to a usb-c port and it wakes up and functions as it should with no issues. my son is having constant issues with usb and the adapter.

    2016 13 ntb base - will not play nicely with any usb items connected via adapters
    2016 13 tb - randomly drops all usb functions

    all the adapters have been updated.
     
  6. bab5139 macrumors newbie

    Joined:
    Nov 25, 2016
    #6
    In my experience that adapter is pretty worthless. It might be a bad driver installation since after installation my computer wouldn't reboot at all. I had to force shutdown at the command line. Then when it restarted it would take forever to sync the monitor and would not sync again if the computer monitor went to sleep. I would have to unplug and replug it back in. There is just something wrong with all the multiport adapters. The single port adapters work fine.
     
  7. ramen5677 thread starter macrumors newbie

    Joined:
    Oct 29, 2016
    #7
    Thanks for your replies.
    I had some issues with installing the driver. It took several times for the driver-notification not to prompt on every reconnection of the adapter. I then followed a guide on the internet on how to install that driver correctly and it all seemed fine (accepting that the new MBP would not feed to HDMI before login - Is this normal behaviour?).
    Now, after the hard shutdowns I experienced, the MBP will not even boot when connected to the adapter.
    Could this be a driver issue? I think that the hardware is fine; when not connected to the adapter everything works perfectly.
     
  8. Lou-X macrumors member

    Lou-X

    Joined:
    Oct 31, 2016
    #8
    Ntb arrived, I updated the drivers and I went straight into trying multi AV and vga adapter together . It worked well with two external display + power + keyboard + my old usb 2 hub with storage attached. No problems so far
     
  9. Clint_Barton macrumors 6502

    Joined:
    Oct 23, 2016
    #9
    My best guess would be that there is a problem with the adapter
     
  10. kb3tzt macrumors member

    kb3tzt

    Joined:
    Nov 1, 2016
    #10
    this sounds crazy, but coming from a windows machine I tried the following:

    1)attach everything your gonna connect to the machine
    2)do a clean install of Sierra
    3) if it not already done, update to the latest version

    I did this and my machine seems to be running ok for now. no issue, but the reinstall was a pain and took longer than it should have, but it all worked out in the end. AND NO, its not an adapter problem, as I have gone through 4 of them and still had issues. its more of a Sierra vs thunderbolt3 vs usb as my best guess. also from the hard resets I've gone through, what appears to be a crash is a very very very long Sierra pause. my machine even heated up to a very nice warm feeling through the lid when closed. support told me to hold down the power button and restart, and 2 attempts later all worked fine.
    good luck, as apple was no help to be honest, as I seem to be the only one to have issues according to them. my son has an engineering case open with similar issues, but they keep pushing it off. so time will tell. as another note, try to ditch the av adapter over time. I forget what model you have, but I have the tb version and have gone to 4 connections, with a usb-c to hdmi on order, a usb-c to usb-a, power cord to charge and my raid usb-c gen 2 to usb-c gen2. there is a 5 port powered usb-c 3.0 hub attached to the usb-c to usb-a cable. so, 4 cables is worse than 1 but better than my windows machine.
     
  11. ramen5677 thread starter macrumors newbie

    Joined:
    Oct 29, 2016
    #11
    Thanks again.
    Got a new adapter today and managed to install the driver correctly on first try. Still, my iPhone will not connect.
    Thanks kb3tzt, I will try a clean install of Sierra when I find some time - it seems a software issue to me, too.
     

Share This Page