iTunes killed Safari

Discussion in 'OS X Yosemite (10.10)' started by OldTimeOS, Dec 14, 2018.

Tags:
  1. OldTimeOS macrumors newbie

    OldTimeOS

    Joined:
    Dec 14, 2018
    Location:
    SJC
    #1
    I was notified that a new version of iTunes was available and downloaded it. Safari froze dead. Killed it. Relaunched. Instant error message that my version of Safari will not run on my OS. My OS is 10.10.5. on a 2,1 MacPro. Rebooted, fixed permissions. All the same, error message instantly on launch attempt.

    Is this a bizarre coincidence or what? Can I downgrade iTunes to fix this? If so how? I found some instructions, but the first step was to put iTunes into the trash, but that is forbidden.)

    I would appreciate any help (or k$ for a 6,1.)
     
  2. NoBoMac, Dec 14, 2018
    Last edited: Dec 14, 2018

    NoBoMac macrumors 68020

    NoBoMac

    Joined:
    Jul 1, 2014
    #2
    Ran into this on some other person's machine.

    Quick search turned up others having the issue as well and renaming the /System/Library/PrivateFrameworks/MobileDevice.framework folder to something else (aka. add a ".bad" to the end of the name) got Safari working. This person I know does not use iTunes, so, not concerned about that. Everything seems to be running ok.
     
  3. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
  4. OldTimeOS, Dec 15, 2018
    Last edited: Dec 15, 2018

    OldTimeOS thread starter macrumors newbie

    OldTimeOS

    Joined:
    Dec 14, 2018
    Location:
    SJC
    #4
    Can any version of Safari be downloaded from there and how do you find the .pkg name?

    Did that, nothihg changed. Until I renamed that moble file, but now I have Safari 10.
    --- Post Merged, Dec 15, 2018 ---
    That worked.

    I have to ask, how did he ever figure that out? Just going through all the items changed by the install?
     
  5. Rileyh macrumors newbie

    Rileyh

    Joined:
    Dec 17, 2018
    #5
    Yes this fix worked for me - Safari 10.1.2 back working, thanks! BUT - is there a fix to get iPhoto (old version) up and running please?
     
  6. edmoncu, Apr 27, 2019
    Last edited: Apr 27, 2019

    edmoncu macrumors newbie

    Joined:
    Sep 21, 2018
    #6
    I am on the following
    • Yosemite 10.10.5 (14F2511)
    • iTunes 12.1.8.3
    • posting this on Safari 10.1.2
    So far, nothing seems to be 'broken' as I can browse with Safari (typing using this) and can open iTunes as well and recognise my iPhoneSE. Can it be rule out that this issue is fixed?

    FYI: I have not deleted any file like this: /System/Library/PrivateFrameworks/MobileDevice.framework

    Although my setup is from a fresh install Yosemite 10.10.5, then ran update twice (first all got updated except iTunes, then second update only with iTunes).

    [​IMG]

    For my other apps (if you need details). All are working fine.
    • Adobe CS 5.5 Master Collection (fully updated)
    • Microsoft Office 2016 (fully updated)
    • Latest Chrome (74.0.3729.108)
    • Latest VLC (3.0.6)
    • Latest Avast Security (free) 13.12
    Specs were derived from here.
     

Share This Page

5 December 14, 2018