Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

webbymac

macrumors member
Original poster
Aug 23, 2009
34
1
So, I recently updated my 2011 iMac to 10.13.6 from 10.9....

Anyway, iTunes (12.6) now won't connect to my AirPort Express. I get "An error occurred while connecting to the AirPlay device “Back Room”. An unknown error occurred (10)." which is about as useful as a chocolate teapot.

Anyone know what might be going on here? I have a large music collection and stream to my stereo via the AE.

I can connect to it from my iPhone, and I can also connect to it from the volume icon in the menu bar. But that sends ALL sounds to my stereo and not just iTunes.

Thanks
 

mavots

macrumors regular
Feb 15, 2019
107
19
Seattle, WA
So, I recently updated my 2011 iMac to 10.13.6 from 10.9....

Anyway, iTunes (12.6) now won't connect to my AirPort Express. I get "An error occurred while connecting to the AirPlay device “Back Room”. An unknown error occurred (10)." which is about as useful as a chocolate teapot.

Anyone know what might be going on here? I have a large music collection and stream to my stereo via the AE.

I can connect to it from my iPhone, and I can also connect to it from the volume icon in the menu bar. But that sends ALL sounds to my stereo and not just iTunes.

Thanks

I have been having similar problems. See my thread under Mac Apps and Mac App Store.
Digital Audio may actually be a better place for the discussion.

Did you ever figure it out?

In my case, my 2018 Mac Mini is connected via ethernet to an Airport Extreme which is on the same network as the Airport Express.

I have decided it is an iTunes 12.9.5.5 issue as using Airplay with Airfoil works perfectly. Also my Macbook Pro via ethernet works fine as well when connected to the AExpress.

Another issue, when picking the AE "speaker" Airplay button, my internet often gets disconnected.
Again, no issues with my Macbook Pro with an identical ethernet connection.
 
Last edited:

goodfidelity

macrumors regular
Nov 15, 2015
132
16
Was there any solution to this problem?
error code 10: reads something like this:
"Error occurred while connection toAirplay-unti "name of unit". Unknown error (10)"

Also if i go to the system settings, and klick sound, and choose sound output. All the Airport stations are listed. However i cannot klick them. If i klick them it will become selected for 1/10 second and then jump straight back to built in speaker.

Recently (2020-november) my airport express 2 stations have started to drop out one by one.
There has been MONTHS between each one dropping out.

I have made NO software updates what so ever to the stations or to the computer. And one station dropped out first, now all of them are "unconnectable".

I am using MacBook 2009 with old iTunes (12.6.2.20) and old OSX (10.9.5) to run my music library to the three streaming boxes (airport express gen. 2, version 7.8.1)

This seems to be a common issue. I am thinking that apple is doing this to phase out the Airport Express II units so that ppl buy new stuff. Or maybe to phase out the old iPads and Macbooks so that they cannot be used to stream the music libraryr any more.

Does anyone have workaround on this, or find the solution?

My router has not changed either, all settings are same.

//GF
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.