Linux on my old PowerMac G4

Discussion in 'PowerPC Macs' started by gabe_lio, Apr 11, 2016.

  1. gabe_lio macrumors newbie

    gabe_lio

    Joined:
    Apr 11, 2016
    #1
    Hello,

    On my old powermac g4 I attempted to install Ubuntu Linux on it. Once the installation finish I rebooted the computer. everything seemed to be fine, it was booting properly. then the screen just went black and stayed that way.

    I did a little research and I figured out that it was probably my graphic card was incompatible with the operating system I installed.

    I have no idea what graphic card I current have installed in it, but I was wondering if anyone knew where I could get a graphic card that will be compatible with Linux operating system (for a decent price, I might add)?

    By the way, after the Linux installation didn't work, I reinstalled OS X and it worked perfectly fine so this is what led me to believe it was the graphic card.
     
  2. Dronecatcher macrumors 68000

    Dronecatcher

    Joined:
    Jun 17, 2014
    Location:
    Lincolnshire, UK
    #2
    Have you tried booting a live cd/dvd? You can try out various ISOs and change the boot parameter to usually get round the blank screen (often, "video=ofonly" helps).
    If you're not already aware, there is no easy way of getting Linux onto a PPC - the easier installations also tend to be the heaviest and least efficient on this old hardware. I'd recommend MintPPC for ease of installation and Debian for most efficient.
    You might have to address your needs for Linux - it will never run any better than OSX on a G4.
     
  3. Lastic macrumors 6502

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #3
    Which Ubuntu flavor did you install and which version ?

    I'm running Ubuntu Mate 16.04 Beta 1 on my Powerbook G4 which now works for the Nvidia card and even gives 3D acceleration .

    On my Powermac G5 which had a Radeon card , I had the same issue, booting to a black screen .

    Have a look here for the Beta 1 , somewhere on the next pages there is a guy with a PowerMac who finally succeeds in booting with no black screen , and the link to Beta 2 is on one of the next pages also .

    http://ubuntuforums.org/showthread.php?t=2301608&page=15&p=13446262#post13446262
     
  4. spf2, Apr 12, 2016
    Last edited: Apr 12, 2016

    spf2 macrumors regular

    spf2

    Joined:
    Mar 3, 2015
    Location:
    7exas
    #4
    Are you using a video card with ADC connector? I had an issue where I was used a monitor connected to the DVI port to install Linux ( I didn't have an ADC monitor). After reboot, it reverted to the ADC port as primary and the screen I used to install it went blank. Setting the video to the DVI interface in yaboot fixed it. It was on Linux mint.
     
  5. 556fmjoe macrumors 65816

    Joined:
    Apr 19, 2014
    #5
    If you have a Radeon GPU, I believe there was a bug with KMS at boot time. Try entering the text in italics when you get to yaboot. This will force framebuffer mode during boot and should avoid the issue.

    Replace 1280x854 with your screen resolution. If it works, after booting you can add it to the /etc/yaboot.conf like so

    Then run "sudo ybin -v" to set the changes.
    https://wiki.ubuntu.com/PowerPCFAQ#What_yaboot_parameters_should_I_use_for_graphics_problems.3F
    see here for more:
     
  6. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #6
    This is the phantom port issue that plagued ADC cards, Linux uses the primary connector to display video on install, and in every ADC card the primary port is the ADC port and not the DVI (I think). Therefore, the computer ignores the DVI connector. This happened to me, however, later on I realized that nVidia cards had issues with Linux so I just ended up giving in.
     
  7. spf2 macrumors regular

    spf2

    Joined:
    Mar 3, 2015
    Location:
    7exas
    #7
    I was lucky to get my G5 1.8 (PCI) working great with Linux which had a Nvidia 5200 AGP and wireless USB. After a harddisk failure, I reinstalled Tiger and Leopard dual boot.
     

Share This Page