Lion bugs... come and tell 'em!

Discussion in 'Mac OS X Lion (10.7)' started by sazivad, Jul 21, 2011.

  1. sazivad macrumors 6502

    Joined:
    Jul 21, 2011
    Location:
    New Jersey
    #1
    I realize that in Lion, the 'library' folder is hidden on default, and I don't really care, but c'mon Apple... a little less obvious?

    Yeah this is Icon View of my Home Folder, and I didn't move anything around, but there it is, a big white blank area where the Library folder should be. Crazy.
     

    Attached Files:

  2. Mrguidogenio macrumors regular

    Mrguidogenio

    Joined:
    Jun 4, 2011
    Location:
    Argentina
  3. Steve's Barber macrumors 6502a

    Joined:
    Jul 5, 2011
    #3
    You could always just move one into its place. :)

    Seriously, some of you guys crack me up. :D
     
  4. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #4
    I don't know if that's a bug so much as an oversight.

    One bug I've noticed is that logging out of my main user account and into the Guest Account causes my MBP to forget its brightness and Energy Saver settings. That's fine, but when I log back into my main user account, it fails to restore my brightness settings and I have to adjust it back manually.
     
  5. monaarts macrumors 65816

    Joined:
    Jan 16, 2010
    Location:
    Kennesaw, GA
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_4 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8K2 Safari/6533.18.5)

    iTunes seems to be making my iMac crash. I've had to hard restart 3 times now when playing movies. :-(
     
  6. sazivad thread starter macrumors 6502

    Joined:
    Jul 21, 2011
    Location:
    New Jersey
    #6
    Another one I just noticed today was that for some articles aren't recognized by Reader as articles unless you reload.

    Also I noticed the bug I mentioned earlier is no longer present, even w/o pressing Cmd-Ctrl-1 or whatever it was.
     
  7. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #7
    Nullriver MediaLink seems to bring Lion to its knees. After streaming a few movies on my PS3, I went back to my MacBook to find that the force quit dialog opened itself, complaining that no memory was available for applications. Interestingly, it "paused" the few apps I had running.

    Other than that, Mission Control seems sluggish. And I can't figure out if the dock is or is not supposed to show when you hold the mouse over it's position in a full-screen app. Sometimes it pops up, sometimes it doesn't.
     
  8. fattire357 macrumors regular

    Joined:
    May 18, 2011
    #8
    Moving files is really hit or miss for me.

    Often times rather than moving the file on a click-drag, it will just de-select it (grr). Other times, clicking and dragging a selection will cause another mode to be activated where it deselects all, and as your drag up it selects other files (grr). I have the best luck clicking outside the window, THEN clicking and dragging. At this, it works maybe 1/4 of the time. What gives? This is annoying as hell.
     
  9. nhoz macrumors newbie

    Joined:
    Jun 22, 2011
    #9
    Trackpad Preferences

    By default the gesture to switch desktops is 3-finger swipe left/right.

    If you change that from 3-finger, to 4-finger swipe, then back to 3-finger swipe, this doesn't disable 4-finger swipe. Now, both 3 and 4-finger swipe change desktops :-(
     
  10. seetheforest macrumors member

    Joined:
    Dec 24, 2010
    #10
    In Finder using Column View and arranging by 'Kind'.

    When you press the right arrow key to enter a subdirectory the topmost label is highlighted instead of the topmost file. Small bug, but annoying.
     
  11. MartiNZ macrumors 65816

    MartiNZ

    Joined:
    Apr 10, 2008
    Location:
    Auckland, New Zealand
    #11
    Okay this will be fun!

    Carried over from SL:
    • No nested sorting in folders in Dock. In Leopard, 'sort by kind' meant for all levels when browsing the folder structure from the Dock. SL broke that; Lion did not fix it.
    • 'Open Selected File in TextEdit' service - does NOTHING, plain does not work, never has, never will.
    • 'Text Only' view in Finder toolbar loses you the 'forward' from the 'back/forward' buttons. It has been this way since October 2003, so I don't think that's getting fixed. Preview.app got it right in SL, but it is wrong as well in Lion ><.

    Sure that last is not really a 'bug' but it is something that should be fixed IMO so I'm counting it.

    Fixed since SL:
    • Repeatable crash bugs in iTunes Dashboard widget. This was a 6-year-old bug!! The solution was ... to remove the widget altogether. Anticlimax much? I reported it at least 28 times in those 6 years :(.

    New and exciting in Lion (bugs, issues, oddities):
    • Open/save dialogs, while gaining much, have lost a lot of options as well, no more hold-clicking on the view types to change icon sizes, etc. However, try right-clicking on the 'arrange by' button that you get in cocoa apps - looks like someone was trying to make a context menu there hmmm :)?

    Other than that it's really just minor things that I assume will be fixed, so that we can one day actually enjoy using the new feature set!
     
  12. eifer macrumors regular

    Joined:
    Oct 17, 2008
    #12
    I keep getting a pop up saying something about can't connect to some server. Pretty sure it's related to time machine.
     
  13. seepel macrumors 6502

    seepel

    Joined:
    Dec 22, 2009
    #13
    Are you sure this wasn't the case before you changed to 4-finger swipe. I think that with 3-finger swipe from the beginning it also recognized 4-finger...
     
  14. Heisler98 macrumors member

    Joined:
    Oct 30, 2010
    #14
    Not really a bug....more like a BIG PROBLEM

    I'm sure this has come to everyone's attention, but a lot of users are having serious trouble with iWork on Lion. Even with update 6, and trying reinstallation then manual update, nothing seems to work. I've scoured the discussions on apple and this forum and nothing has turned up as an answer to my particular problem, which is this:

    Pages, Keynote and Numbers: when either one of them start up, they immediately crash with error EXC_BREAKPOINT. Any ideas of what could fix this?

    And theres also another bug: Launchpad won't display all the apps that I have. I think I'm going to have to manually add of all them. If I can find out a way how.

    Sorry this post was really long. :D
     
  15. richiekim macrumors newbie

    Joined:
    Feb 11, 2011
    #15
    The trackpad on my MBP stops recognizing the pinch zoom in/out gesture after awhile. When I restart/shut down I can pinch zoom again.
     
  16. MartiNZ macrumors 65816

    MartiNZ

    Joined:
    Apr 10, 2008
    Location:
    Auckland, New Zealand
    #16
    Are these apps in question 'deeper' in the file structure? I have found for all mine that didn't show up that just temporarily placing them in /Applications makes them show up, and then they stay in LaunchPad when you move them back, and they even follow the target. My only annoyance with LaunchPad is that it rearranges my icons randomly from time to time ><.
     
  17. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #17
    I have send many bug reports to the Apple Bugreporter. Here are some :

    - Some Universal Access preferences are not loaded on boot (scrolling without inertia etc..) - Confirmed
    - Keyboard illumination (turning off) doesn't work - not confirmed
    - Slow UI with Intel HD3000 - Confirmed
    - Several (hugh) memory leaks (some really bad in Safari) - partly confirmed
    - Randow crashes in Java - confirmed
    - Several bugs in Applescripts (mostly QT related) - confirmed
    - Window un-minimizing from dock -> sometimes results in brief flash before becoming active - confirmed

    Some other I forgotten..

    BTW If you need the case numbers .. send me PB
     
  18. laurentpompidou macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Tokyo
    #18
    quicklook

    For me quick look does not work most of the time. I've seen it work occasionally, but most of the time I just get a blank window frame..

    Where do you submit bug reports again?
     
  19. VTECaddict macrumors 6502

    Joined:
    Sep 15, 2008
    #19
    Use column view and any sort method with category headers. When renaming files, it kind of renames on top of the existing file, if that makes sense. Say you have a file named qwerty.pdf and you start to rename it, you will continue to see qwerty.pdf underneath as you start to type the new name.
    Screen Shot 2011-07-23 at 12.55.53 AM.png

    This one is pretty specific. It might also be triggered by other methods, but this is what I found will reproduce it 100% of the time...
    Open Finder to "[Username]'s MacBook Pro" (that's what I have set as default when I open a new Finder window). Use column view, sort any way that has the category headers. Use Cmd+Shift+G to go to ~/Library or /Library. Finder will crash. Also, the category headings and/or the folder name will look weird.
    Screen Shot 2011-07-23 at 12.54.41 AM.png
     
  20. TJMeier macrumors member

    Joined:
    Dec 28, 2008
    #20
    If my macbook is plugged in and I shut it, it will turn off the display, but will not go to sleep. EVER.
     
  21. Operafreak macrumors newbie

    Joined:
    Jul 24, 2010
    Location:
    The Netherlands
    #21
    I've found 2 so far:

    Before I could zoom in or out with a 2 finger up/down swipe or using scroll ball on mouse holding ˆControl. Doesn't work anymore. Option is selected in mouse settings.

    I use the 3 finger u/d swipe for select and drag. This automatically changes the options for Mission Control to a 4 finger up swipe. Only, it doesn't work.
    The 4 finger down swipe for Exposé works fine though.
     
  22. Operafreak macrumors newbie

    Joined:
    Jul 24, 2010
    Location:
    The Netherlands
    #22
    Or simply go to Finder Preferences, the Navigation pane and select 'iMac of...' and/or 'Hard Disks'.
     
  23. laurentpompidou macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Tokyo
    #23
    Quick Look

    To get back to the quick look issue;
    I tried a screenshot that wouldn't show with quick look in the finder.
    Then went into the terminal with this command

    $ qlmanage -p "filename.extension"

    and I got quick look from that file in the terminal.

    So quick look works for me in terminal but not in finder..
    How to fix...?
     
  24. nhoz macrumors newbie

    Joined:
    Jun 22, 2011
    #24
    yeah, im pretty sure.
     
  25. FrytheDestroyer macrumors newbie

    Joined:
    Jul 23, 2011
    #25
    OK well here are mine.

    Goodbye insomniax how I loved thee.

    Anyone not doing well with the merge folders thing? At least we used to get a skip button, now I’m forced to add hours to transferring data, I got merge to work one time, and it was a fluke, tried everything.

    I’m on a core 2 duo and lion is way slower and buggier in general

    redhanded, not working so good
    I cannot get FaceTime to work with my iPhone 4 to save my life, not available!

    Got to say I love the spaces thing when it works, sometimes the page is gone but when I click on the icon the page returns?

    Plex media manager, works, but crashes a lot.

    Yes I know a lot of these need plugs and are not made by apple just saying.
    It’s really the speed and the merge folders thats killing me right now.
     

Share This Page