Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

terry.mac

macrumors member
Original poster
May 19, 2008
36
12
I used Anker NVME enclosure (RTL9210B-CG USB 3.1 Gen2) w/ crucial 1TB P2 NVME drive for external storage.

After I backup 3 of my iOS devices (using symlink) to my M1 and eject the drive, the drive could no longer mount to both M1 and an Intel Mac. The mac sees the usb chipset, but it just does not mount. Disk utility shows nothing.

I then tried swapping the nvme drive on another Anker enclosure (same model) but it did not mount.

However, when I put the crucial nvme on the Asus nvme enclosure (ASUS USB 3.2 Gen2 ROG STRIX Arion Aluminum Alloy M.2), the drive shows up again with data. Interestingly, I put the crucial nvme drive back to Anker, and it worked on both the initial one and the next one.

While I am not sure how repeatable this is, I thought I would share so if someone else have the issue, they may try what I did to recover the data.
 
Last edited:

iandk

macrumors regular
Aug 10, 2019
159
64
Same issue, I've been using the drive on my windows workstation, but after I ejected it, it's no longer detected on my Macs and windows workstation.

Even after putting the P2 1TB in a different case it's not detected aymore.
Not even in the second case.

@terry.mac
Do you have an idea how to get it working again? And has it been reliable so far?
 
Last edited:

terry.mac

macrumors member
Original poster
May 19, 2008
36
12
I got the Asus ROG enclosure, put the M.2 nvme drive, plug it into my mac. And then drive showed up.

So somehow the Asus enclosure was able to fix issue. Given it looks to me an Anker software issue, I don't want to use the Anker enclosure anymore as I don't know how to update it.

And I have been using the Asus enclosure for a week. So far so good.

My suspect (no proof) is that somehow the enclosure messed up record in the NVME, and maybe Asus enclosure was able to fix the issue?

Keep me posted on what you will do, @iandk .

Ref: ASUS ROG STRIX Arion Aluminum Alloy M.2 NVMe SSD External Portable Enclosure Case Adapter
 
Last edited:

iandk

macrumors regular
Aug 10, 2019
159
64
Kind of, I plugged it directly into my M2 Slot and after that it worked even in the Anker case
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.