Mac makes me tired, it won't sleep!

Discussion in 'macOS' started by Joshoon, Dec 17, 2016.

  1. Joshoon macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #1
    Hi there,

    So I've been using my Macbook for years now, and I started to use my Macbook as a desktop more and more.
    So I decided to get a Mac Mini instead, it looks a bit cleaner on the desk, and it's works better as a desktop in my opinion.

    I was very happy with it at first, it's not the fastest, but it get things gone.
    I have built in an SSD, so it is very snappy now.
    My idea was to never shut it down, but to keep it in sleep mode since it's such a pleasure to just tap your keyboard, and the Mac would unlock itself by recognising your Apple Watch.
    Unfortunately this is not working all the time...

    Once I start up my Mac, and I want to make it sleep, I just go to the Apple menu and choose for it to go to sleep, this works fine at first.
    When I wake my Mac, and after a few hours I want to make it sleep again, it doesn't want to sleep at all.
    It keeps waking up each time I tell it to sleep.
    Even after waiting for an hour, it won't go to sleep at all.

    The energy monitor says there is no app that prevents sleep, and pmset -g assertions says there is nothing preventing sleep as well. (Except for some situations where it says Addressbook sync or something).
    I even bought Wimoweh to see what's going on, and when it wakes up immediately after I want it to sleep, it shows this:

    [​IMG]

    It seems like com.apple.powermanagement.darkwakelinger is the one who is causing it to keep it awake all the time.
    DisplayOff is not always showing in there though, it's mostly darkwakelinger.

    I even turned off 'Turn off sleep mode for network access' (Or something like that, I have it in Dutch) from the energy settings, and I thought this was such a handy feature.

    I hope someone can help me out with this, because this is really frustrating, and it's really taking away a great feature I loved.
    Some help would be really appreciated!
     
  2. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #2
    Have you already reset SMC and NVRAM?

    Do you utilize any external drives?

    Do you utilize an Apps/Programs that utilize a background daemon?(i.e. Security software, App Launch Managers etc..)
     
  3. Joshoon, Dec 17, 2016
    Last edited: Dec 17, 2016

    Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #3

    Thanks for replying.
    I did reset the SMC and NVRAM indeed, but it did not solve the issue, and I don't have any external drives.

    I am not sure what you mean with software that utulize a background daemon, how can I figure out what software uses a background daemon?
     
  4. blaichch macrumors member

    Joined:
    Jul 26, 2014
    Location:
    Augsburg, Germany
    #4
    Do you have any connected bluetooth devices that might wake your Mini? I experienced this with my PS-Controllers.
     
  5. Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #5
    Yes, an Apple Magic Keyboard, but this shouldn't be a problem right?
    Also, I resetted the SMC and NVRAM again, and the problem didn't occur again. It might be solved, but I will report back on that.
     
  6. Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #6
    It worked for a few days, but now it won't sleep again.
    Now BTLEAdvertisement is preventing sleep.

    Back to shutting it down again. Starts to be a sign to switch back to Windows again :(
     
  7. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #7
    BTLEAdvertisement has to do with Bluetooth, so it might well be the keyboard. Stuck key maybe?
     
  8. Joshoon, Dec 20, 2016
    Last edited: Dec 20, 2016

    Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #8
    This also happened when I had no Bluetooth keyboard yet.
    Plus this is a brand new Apple keyboard without stuck keys.

    Even if I turn off Bluetooth it still happens.
     
  9. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #9
    Do you utilize any internet accounts?(iCloud,Gmail etc)

    Do you sync contacts with any of them?
     
  10. Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #10
    Yes definitely.
    And the Syncing was preventing a sleep before as well, but I got this one solved earlier. So it probably isn't the syncing that's causing the issue right now.
     
  11. Kissmyne macrumors 6502

    Kissmyne

    Joined:
    Apr 21, 2015
    #11
    I was looking into issues specifically involving com.apple.powermanagement.darkwakelinger. It seems to be an iCloud process. Address book sync came up ALOT when referencing this process. I would suggest toggling your contacts sync... or even resorting to even logging out and back into iCloud.
     
  12. Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #12
    Thanks for your reply.
    It doesn't seems like that darkwakelinger was causing the issue last night, it was definitely BTLEAdvertisement this time.

    I did try to remove the sync files (I read about it somewhere) and logged out and logged back into iCloud and my other accounts.
    I would love to keep the contact syncing on though, since I use this feature pretty much, and I don't think that turning off features that came with the Mac is the right way to solve issues. Apple is the one who should adresss these issues.

    But as I said I don't think the syncing is the issue this time. It's really frustrating. :(
     
  13. Joshoon thread starter macrumors regular

    Joshoon

    Joined:
    Aug 18, 2014
    Location:
    Netherlands
    #13
    At this moment the Mac Mini doesn't go to sleep at all anymore.



    Darkwakelinger keeps preventing sleep with the reason: Proxy assertion to linger in darkwake.

    I think I will sell the system and stick with Windows. I actually bought the Mac Mini for all the ease it might bring, but since the only place I can put it away is on a platform below my desk makes me bang my head every morning when I try to reach the on/off button, and I keep troubleshooting this problem every single night when I actually want to go to sleep.



    The non-sleeping Mac literally makes me tired...

    Will try to give Apple a call tomorrow as a last hope, but I don't think they can solve this issue.
     

Share This Page