Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Does your Mac Mini M2 [Pro] with 10 GB ethernet adapter work at 10 GB speed?


  • Total voters
    3

minduch

macrumors newbie
Original poster
Jul 1, 2023
1
1
I'm writing this to all the poor souls out there that bought the Mac Mini M1 with the 10 GB adapter option:
Your Mac is probably not working at the correct network speed, and this is a hardware problem. It's not software (I think), as I have installed every possible patch, new macOS Ventura Beta's and even macOS Sonoma Developer Beta. All macOS versions shows the same problem for this ethernet adapter.

Since I bought my Mac Mini (2020) M1 with 10 GB ethernet adapter option, it never worked: it connected to the 10 GBE switch at 100 Mbps.

This could be seen using the ifconfig command or in the Network settings. Having a 1 GBE switch (NetGear) could sometimes make 1 GB speed to work. The initial connection to the switch would take between 30 seconds to over 2 minutes, if ever. As I also had Wi-Fi enabled (by default), I didn't notice this the first couple of weeks last year. When I turned off Wi-Fi, I immediately saw the problem. I brought in my Mac Mini to Apple Store, they reparied it by replacing the motherboard, but that board was had the same hardware version level, and of course, a 10 GB connection was not possible.

Apple Store did not have any hardware to test the 10 GB ethernet, and told me the Mac was functioning properly. After 7 months of relentless discussions with Apple Technicians (that could see the problem on my machine), I took my 10 GB switch with me to the Apple Store and showed them the problem. They could obviously see that it didn't work. The still insited that my Mac was working properly according to their tests.

After having sent tons of email, I then sent a letter by standard mail to Apple, Cork, Ireland, to their legal department. Their response, not written of course, only over the phone (so no written evidence whatsoever from Apple - they have been VERY careful), was that the legal department rules according to Apple Store, so my Mac Mini M1 10 GBE was fully functional.

I got frustrated and went back again to the Apple Store, this time with the 10 GB QNAP switch and the 1 GB Netgear switch to show them that it didn't work. This time, they acknowledged that itdidn't work properly and too the Mac in for repairs. After a week, they told me that the Apple support told Apple Store to replace the mother board. They did not do so, as the hardware level is still the same as the one in the machine.

The only thing I want, is a functional Mac Mini at 10 GB, so I want a refund of the Mac and its Apple Care+. Then I can buy a new Mac, this time an M2 (as the M1 is not available anymore), and hopefully that 10 GB adapter will work.
 
  • Like
Reactions: Paul Argoud

ml2014

macrumors newbie
Oct 28, 2014
20
7
I came here looking for anyone else with the same problem and lo and behold. Though mine has worked pretty well until the last month, and then finally today, nothing at all. Have to connect at Wifi. I bought the 10 GB option for a reason, and this is disappointing. I'm not sure what we can do now. I have the M1 2020 version as well.
 

Ethosik

Contributor
Oct 21, 2009
7,913
6,849
I just got done investigating an issue I have been having with my 10Gbe connection and my NAS. It would sometimes drop to 100Mbps speeds communicating with the NAS, but the experience was still 10Gbe, so probably a little different that your situation. What my situation was, whenever the connection to the NAS was established as an IPv6 address (note my network doesn't have IPv6 enabled or so I thought), it would transfer files as slow as 10MB/s. Killing the connection within DSM on the Synology and reconnecting on my Mac client would re-establish the connection with IPv4 and have 10Gb connection speeds back.

Now, what I JUST found out was, my ethernet setup is configured for Ubiquiti. However, for wireless I am using Eeros in Bridge mode. This is where the issue lies. I found out that my Mac would generate an IPv6 address when connected to ethernet. I do not have IPv6 enabled on the Synology. So I questioned this in another thread. Sure enough, stupid Eeros were giving out IPv6 addresses even though it is in bridge mode. I confirmed this by having the Eeros turned off and no IPv6 addresses on my Mac now. Funny thing is, the Eeros were not involved at all with the wireless connection. I went from Ubiquiti console to 10Gb switch to Mac. Eero was not involved in this chain. But the Eero was connected to the Ubiquiti console, so I guess it still had a conflict with DHCP even though it's in bridge mode.

Not sure what your network set up, or if my story will help at all. But thought I would share my experience. I solved this a few days ago with a software change by just disabling IPv6 on my NAS since you can't on macOS without terminal commands that I just found out today.
 
  • Like
Reactions: rhett7660

magicMac

macrumors 6502a
Apr 13, 2010
993
419
UK
i have seen alot of posts on these forums about 10GBit Ethernet Adapters not working on M1 (and i'm sure also M2) Mac mini's. I have an Intel mac mini and reading all this puts me of getting another mac mini.

Actually ironically my Intel Mac mini randomly drops the ethernet connection sometimes, and I have to reconnect the cable to restore it. i've tested other computers on the same port etc no problem. Also when i upgraded my broadband i was not able to get the 500Mbps on the mac mini ethernet, which I was surprised by.

I think it may possibly be something to do with the position of the ethernet port next to the AC power input, poor shielding may be causing interference of the ethernet signal.
 

ml2014

macrumors newbie
Oct 28, 2014
20
7
A workaround I've found for my ethernet port not working anymore on my Mac Mini is to use this 2.5G adapter.

I have a 2.G router so I still get the speed I'm signed up for through Xfinity. The nice thing is additional ports this adapter gives me so I don't "lose" another USB-C port on the mini.
Still an extra expense I shouldn't have to have. I do plan on bringing the mini in to Apple though for inspection/repair.
 
  • Like
Reactions: Paul Argoud

Paul Argoud

macrumors newbie
Dec 11, 2023
1
0
Apple should not forget that a foretaste of failure always has a bitter aftertaste 😡
 
Last edited:

rhett7660

macrumors G5
Jan 9, 2008
14,265
4,357
Sunny, Southern California
I'm writing this to all the poor souls out there that bought the Mac Mini M1 with the 10 GB adapter option:
Your Mac is probably not working at the correct network speed, and this is a hardware problem. It's not software (I think), as I have installed every possible patch, new macOS Ventura Beta's and even macOS Sonoma Developer Beta. All macOS versions shows the same problem for this ethernet adapter.

Since I bought my Mac Mini (2020) M1 with 10 GB ethernet adapter option, it never worked: it connected to the 10 GBE switch at 100 Mbps.

This could be seen using the ifconfig command or in the Network settings. Having a 1 GBE switch (NetGear) could sometimes make 1 GB speed to work. The initial connection to the switch would take between 30 seconds to over 2 minutes, if ever. As I also had Wi-Fi enabled (by default), I didn't notice this the first couple of weeks last year. When I turned off Wi-Fi, I immediately saw the problem. I brought in my Mac Mini to Apple Store, they reparied it by replacing the motherboard, but that board was had the same hardware version level, and of course, a 10 GB connection was not possible.

Apple Store did not have any hardware to test the 10 GB ethernet, and told me the Mac was functioning properly. After 7 months of relentless discussions with Apple Technicians (that could see the problem on my machine), I took my 10 GB switch with me to the Apple Store and showed them the problem. They could obviously see that it didn't work. The still insited that my Mac was working properly according to their tests.

After having sent tons of email, I then sent a letter by standard mail to Apple, Cork, Ireland, to their legal department. Their response, not written of course, only over the phone (so no written evidence whatsoever from Apple - they have been VERY careful), was that the legal department rules according to Apple Store, so my Mac Mini M1 10 GBE was fully functional.

I got frustrated and went back again to the Apple Store, this time with the 10 GB QNAP switch and the 1 GB Netgear switch to show them that it didn't work. This time, they acknowledged that itdidn't work properly and too the Mac in for repairs. After a week, they told me that the Apple support told Apple Store to replace the mother board. They did not do so, as the hardware level is still the same as the one in the machine.

The only thing I want, is a functional Mac Mini at 10 GB, so I want a refund of the Mac and its Apple Care+. Then I can buy a new Mac, this time an M2 (as the M1 is not available anymore), and hopefully that 10 GB adapter will work.

By chance do you have WIFI enabled on your Mac Mini? I had a similar issue with my Studio. What I found is that I had both WIFI and ethernet connections and even though I had the ethernet set to priority, it would still hit the WIFI and my speeds would drop considerable. I ended up disabling WIFI on the studio and have not had a problem since.

Might be something to try out.
 

BeatCrazy

macrumors 603
Jul 20, 2011
5,042
4,409
@minduch - as an owner of a few Macs with 10GbE ports, a 10GbE LAN, and 5Gbps home internet service, I would not recommend you spend the money to upgrade.

Setting up a 10GbE LAN to actually move stuff in/out of that Mac mini port is expensive. And it will continue to be so. And if one day you did upgrade your internet to >1Gbps, it's still very rare to get downloads/content at >1Gbps rate.

In summary, unless you have very specific plans and budget for LAN networking at 10GbE, then save your money - you will see zero benefit. It's not even 'future proof' because by the time 10GbE LAN/Internet gets reasonably affordable, you'll probably be ready to upgrade your Mac mini, anyways. That could take 7+ years, if not 10.
 

ml2014

macrumors newbie
Oct 28, 2014
20
7
I came here looking for anyone else with the same problem and lo and behold. Though mine has worked pretty well until the last month, and then finally today, nothing at all. Have to connect at Wifi. I bought the 10 GB option for a reason, and this is disappointing. I'm not sure what we can do now. I have the M1 2020 version as well.
My 10GB ethernet adapter came back to life after not working for 6 months or more, and I never brought it in for repair. So must have been a software issue, and unfortunately I can't verify what caused it to to work again but may have been the last Venture update before launching Sonoma, as had given up on it and was using a 2.5GB ethernet adapter.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.