Mac Mini doesn't recognize monitor, defaults to low resolution

Discussion in 'Mac mini' started by adjgiulio, Jan 2, 2016.

Tags:
  1. adjgiulio macrumors newbie

    adjgiulio

    Joined:
    Dec 25, 2015
    #1
    I have just purchased a Mac Mini with the intent of using it a family machine in place of my old W7.
    I'm using a KVM adapter to share a monitor (Hyundai) and a wireless keyboard/mouse combo between the Mini and my Ubuntu dev desktop.
    The Mini defaults to a 1280x1024, and cannot see my Hyundai monitor when I try Detect Displays. The result is a couple of inches of black space on the left and right side of my screen.
    Strangely enough the screen looks pretty much identical to my Ubuntu screen when, at times, I used to switch back and forth between Ubuntu and W7. It would happen that switching from W7 to Ubuntu I would get a bad resolution. To fix it, all I had to do was going to Displays and it would automatically revert back to the full screen resolution.
    The Mini problem persists even if I connect it directly to the monitor (bypass KVM).
     
  2. Celerondon macrumors 6502a

    Celerondon

    Joined:
    Oct 17, 2013
    Location:
    Southern Cal
    #2
    I have two questions and two ideas for you adjgiulio.

    Which mini/OS X version combination are you using? What input connections are available on that Hundai(model ?) monitor?

    Without more information it is difficult to guess the source of your problem. Eliminating the KVM switch was a good test. If the cable (and/or adapter) is detachable you can try a cable swap to eliminate another possible cause. Depending on your available connectors you should be able to drive the display through a different pair of ports. :apple:
     
  3. adjgiulio thread starter macrumors newbie

    adjgiulio

    Joined:
    Dec 25, 2015
    #3
    Colerondron,

    I have a late 2014 Mini, with Yosemite 10.10.5.
    On the Hyundai monitor I have a VGA and another connection (not an HDMI). Would like to stick to VGA as much as possible for now.
    Just by playing with the Hyundai monitor settings a little, I found an "auto adjust" option that seems to take care of the black portion of the screen. Now though I cannot tell whether the mini desktop looks right or is it a little stretched. And it definitely looks less sharp than Ubuntu.
     
  4. Celerondon macrumors 6502a

    Celerondon

    Joined:
    Oct 17, 2013
    Location:
    Southern Cal
    #4
    Can you find your other video connection in this group?

    Video Ports.jpg
     
  5. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    OP wrote above:
    "Now though I cannot tell whether the mini desktop looks right or is it a little stretched. And it definitely looks less sharp than Ubuntu."

    Take a look at the Displays preference pane.

    Does it give you any option to reduce/increase overscanning?
     
  6. adjgiulio thread starter macrumors newbie

    adjgiulio

    Joined:
    Dec 25, 2015
    #6
    It's the large DVI port.
     
  7. Celerondon macrumors 6502a

    Celerondon

    Joined:
    Oct 17, 2013
    Location:
    Southern Cal
    #7
    Alright then...

    Try Fishrrman's advice first. It could allow you to solve the problem without changing any cables or ports. If it does not resolve your problem I have another idea. Even though you wish to "stick with the VGA connection" you could test your display with either of these inexpensive adapter/cables.

    http://www.amazon.com/BlueRigger-Di...2940&sr=8-4&keywords=thunderbolt+to+dvi+cable
    MiniDP-DVI.jpg

    http://www.amazon.com/BlueRigger-Sp...=1451952622&sr=1-4&keywords=hdmi+to+dvi+cable
    HDMI-DVI.jpg

    I like the first one because your computer has two Thunderbolt/Mini DisplayPort connections available. Your VGA preference may not be a problem but VGA is an analog interface. I wonder if your signals are getting garbled because of the digital/analog/digital path between your mini's output and the monitor's input?
     

Share This Page