Mac ruined my USB drive

Discussion in 'Mac Basics and Help' started by Sakshichavan, Aug 19, 2018.

  1. Sakshichavan macrumors newbie

    Joined:
    Aug 19, 2018
    #1
    I had a Sony 8 gb usb drive. Tried to format it on the Mac. After formatting, Mac won't detect usb anymore. Tried First aid and recovery option. Nothing works. Please help
     
  2. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #2
    Have you tried connecting the drive to a Windows computer to see if it is detected?

    I've never had any Mac damage a USB drive by formatting is to HPS, exFAT, or Fat16.
     
  3. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #3
    Those things are fragile anyway. Just get a new one for $10.
     
  4. Sakshichavan thread starter macrumors newbie

    Joined:
    Aug 19, 2018
    #4
    T
    Tried connecting to a Windows and an Android phone. Won't detect. Although the USB appears on the Disk utility list, I cannot open it. I think the USB is damaged for good?
     
  5. HDFan macrumors 65816

    Joined:
    Jun 30, 2007
    #5
    So if you highlight it in Disk Utility what options (First Aid, Erase) are available?

    Screen Shot 2018-08-20 at 03.50.32 copy.jpg
     
  6. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #6
    It sounds like it’s dead. Your Mac had nothing to do with it’s failure. That was just coincidence.
     
  7. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #7
    Did the drive appear in Windows disk management window? If yes, did you try using diskpart in an admin command window?
     
  8. Fishrrman, Aug 20, 2018
    Last edited: Aug 20, 2018

    Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #8
    USB drives can fail, "just like that".
    They can go dark, go "read only", etc.
    And sometimes nothing you do will "fix" them.

    If it won't work, and if there was nothing really important on it...
    ... just get another one and toss the defective one.
     
  9. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #9
    Formatting any drive always involves a very small risk. If a drive is dying or has any issues, large reads/writes/formatting can be the death blow.

    Used to test lots of hard drives by writing zeros while formatting in large corporate fleets. Occasionally they died during the process, as expected. Look at it this way:

    Do you want your drive to die while formatting...or while you are using it?


    I always thought of a drive dying while formatting as a blessing in disguise.
     
  10. JoeInMilwaukee macrumors regular

    Joined:
    Apr 7, 2015
    Location:
    Milwaukee, WI
    #10
    If it happens on a Windows machine, simply toss the USB drive and buy another.

    If it happens on a Mac, file a lawsuit against Apple. :)
     
  11. sctv45sr macrumors newbie

    Joined:
    Feb 7, 2018
    #11
    I am having trouble with my usb drive after formatting with my Mac . It only shows 200mb space when I connect to my windows tablet and the full 16gb when connect to my Mac . I have formatted with exfat, ms dos fat , no luck . Please help ![​IMG]
     
  12. dwig macrumors 6502a

    Joined:
    Jan 4, 2015
    Location:
    Key West FL
    #12
    Two things:
    1 - you can't actually format a drive (HD, SSD, USB Flash, Memory Card, ...) as exFAT, FAT32, NTFS, ... from a File Explorer window. What you format is one of the partitions on that drive.
    2 - the window in your screen shot DOES NOT show the drive, but instead shows the partitions on that drive that are formatted properly and with a format that the OS can work with.

    I suspect that there is a flaw in the exFAT partition that prevents Windows from using it. There is also a small EFI partition on the drive that Windows is recognizing. You need to launch Windows' Drive Manager (right click on the Windows icon on the Taskbar for the menu option) and look at what partitions exist on the thumb drive in question. You'll likely see the flawed exFAT partition as well as the EFI. You can likely reformat the flawed exFAT partition from Drive Manager to fix the problem.

    I've encountered similar issues with USB flash drives formatted as exFAT under macOS (several versions). These days, I avoid doing it if at all possible. Instead, when I want exFAT format I use a Windows machine.
     
  13. sctv45sr macrumors newbie

    Joined:
    Feb 7, 2018
    #13
    Tried all of them like you said , still no luck [​IMG][​IMG]
     
  14. Gravydog316 macrumors 6502

    Gravydog316

    Joined:
    May 17, 2016
    Location:
    Canada
    #14
    Getting the same thing (?)
    I formatted on my Mac so I could use on PC @ work;
    doesn't even show up in PC, but works fine on Mac,
    tried using, MS-DOS, DOS, FAT, FAT-32, etc.
    same with all format types...
    Used to work (like 2 months ago)
     
  15. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #15
    What's the computer, MacOS version?
    Judging from the other thread you have a 10+ year old computer that you tried to install unsupported MacOS on it
    https://forums.macrumors.com/threads/failed-installation-with-macpostfactor.2108112/
     

Share This Page

14 August 19, 2018