Macbook 2017 drains 50% battery overnight

Discussion in 'MacBook' started by powellb, May 10, 2018.

  1. powellb macrumors newbie

    Joined:
    Jun 22, 2010
    #1
    Hello, I've been dealing with an issue for the past 3 weeks that I am unable to solve. I have an 2017 m7 1.4GHz, 16 GB RAM Macbook since last September. Up until around 3 weeks ago, it worked flawlessly.

    Now, when I close the lid for the night (say with 80% battery), and I wake it in the morning, there will be 30-40% battery remaining. Power Nap is disabled. Inspecting the Power Management logs shows that the system went into sleep due to 'Clamshell sleep', and there are no more events until "Wake from Deep Idle due to ... Lid Open". Therefore, the machine enters sleep and remains in sleep until it is woken. So, why the battery drain.

    One might suspect that a hardware issue is causing it to drain; however, if I reset the Energy Control Settings to their defaults, shut down the machine, reset the SMC, reboot and then repeat the overnight experiment, there is only 1-2% drain overnight (totally normal). About 1-2 days later, it is back to the above scenario: draining the battery while asleep. I have also disabled SIP, removed the sleepimage, then reenabled SIP to make sure that the sleepimage is not corrupted.

    Based on other threads in this forum, I have the Power Management settings:

    % pmset -g
    standbydelay 10800
    standby 1
    womp 1
    halfdim 1
    hibernatefile /var/vm/sleepimage
    powernap 1
    gpuswitch 2
    networkoversleep 0
    disksleep 10
    sleep 1 (sleep prevented by sharingd)
    autopoweroffdelay 28800
    hibernatemode 3
    autopoweroff 1
    ttyskeepawake 1
    displaysleep 10
    tcpkeepalive 1
    acwake 0
    lidwake 1


    Any suggestions are greatly appreciated.

    Cheers
     
  2. sergeyz macrumors member

    sergeyz

    Joined:
    Feb 14, 2018
    Location:
    Russia
    #2
    Try to find out which application does not allow macOS to go into sleep mode. First of all look at the Energy tab of Activity Monitor (Preventing Sleep column)
     
  3. EugW macrumors 603

    EugW

    Joined:
    Jun 18, 2017
  4. powellb thread starter macrumors newbie

    Joined:
    Jun 22, 2010
    #4
    Thank you for the reply. I checked, and no applications are listed as preventing sleep. As per my original message, the machine actually goes to sleep as shown in the Power Management logs.

    Unfortunately, it doesn't enter "deep sleep" because in the morning, when I open the lid, it instantly wakens.
    --- Post Merged, May 11, 2018 ---
    No, I'm avoiding that for the moment because of the work involved in getting the various applications, etc. reinstalled. I may try a System Restore first to see if that improves things.

    Worse comes to worse, I'll clean install and then restore from Time Machine.

    I am hoping to find the cause though rather than simply start anew...
     
  5. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #5
    I suggest disabling Power Nap while on the battery.
     
  6. Eric8199 macrumors 6502a

    Joined:
    Feb 27, 2009
    #6
    Try resetting the PRAM. I had issues with all three of my Mac laptops after updating High Sierra. Resetting the PRAM fixed it.
     
  7. powellb thread starter macrumors newbie

    Joined:
    Jun 22, 2010
    #7

    Update on this thread:

    I reinstalled the OS over the weekend, and it worked perfectly after that for a day and a half. It then prompted me to install the latest Security Update (which came out sometime back, but since I had reinstalled it wasn't applied), which I dutifully did.

    Now, it is right back to not entering Deep Sleep. It remains sleeping overnight (powernap does not have anything to do with it); however, when I open it in the morning, it instantly comes back on (as opposed to the delay from Deep Sleep) and the battery has been drained in half...

    So, unfortunately, it appears that something in the Security Update prevents my machine from entering deep sleep.
     
  8. Coco Nuts macrumors member

    Coco Nuts

    Joined:
    Jan 1, 2016
    #8
    Try turning wifi off at night.

    Or turn the mac itself off at night, 0% battery drain.
     
  9. Expobill macrumors 6502a

    Joined:
    May 30, 2018
    #9
    you could auto power off, on in energy saver
    i schedule the macbook air to turn off at 11:00 and turn on at 7:00 AM which chimes me to wake up.
    although i never had battery issues, unless i upgraded a new OS X.
     
  10. jingggg macrumors newbie

    jingggg

    Joined:
    Nov 5, 2018
    #10
    have you solved it?

    I have the same issue as well.
     
  11. scoskey macrumors newbie

    scoskey

    Joined:
    Mar 22, 2016
    #12
    Any update on this post? I am having what seems to be the same issue.
     
  12. Biscotti, Feb 9, 2019
    Last edited: Feb 9, 2019

    Biscotti macrumors regular

    Joined:
    Jun 25, 2008
    #13
    I've had several sleeping issues (but with my 2015 rMBP).

    For me, AutoPowerOffDelay was the issue. If your timer is set to 28,800 in seconds, that's 8 hours of time before it actually goes to sleep.

    So if you only go to sleep for 7 hours then it will not go into deep sleep before you even wake up in the morning. My suggestion is to change the values like mine: 7,200 or 3,600. I have had no issues since changing the values. I'll attach my battery rain from last night as well.

    I'll edit the post when I find the terminal command.

    ***Edit: Copy this command into Terminal between the quotations: "sudo pmset -b autopoweroffdelay 3600"

    1) Copy into terminal
    2) Press enter
    3) Enter admin password
    4) Press enter
    5) You should know be ok

    Notes:
    "-a" is ALL power management systems
    "-b" is just BATTERY management systems
    "-c" is just AC power

    3,600 is 1 hour before it enters deep sleep
    7,200 is 2 hours...
    14,400 is 4 hours...
    28,800 is 8 hours... aka WAY too long before it enters deep sleep...
     

    Attached Files:

  13. KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #14
    It happened to mine. Apple eventually replaced the logic board and it’s been fine since.
     
  14. scoskey macrumors newbie

    scoskey

    Joined:
    Mar 22, 2016
    #15
    Thanks both. The autopoweroff is an interesting suggestion, but I think of it as a workaround as it officially shouldn't be necessary. The logic board replacement sounds costly, but worth considering I suppose.
     
  15. Alicia1 macrumors regular

    Joined:
    Nov 13, 2009
    Location:
    Gold Coast, Australia
    #16
    I had the exact same issue on my mbp and it was because find my Mac was enabled. Try turning that off and see how you go. I have since done a clean install and all seems to be ok now.
     
  16. scoskey macrumors newbie

    scoskey

    Joined:
    Mar 22, 2016
  17. Biscotti macrumors regular

    Joined:
    Jun 25, 2008
    #18
    Just as an update - I just purchase a 2017 MB over the weekend and set it to the same settings as my 2015 rMBP above. My battery sleep has been amazing so far. 100% when asleep and 100% after waking in the AM.

    Let us know if you get the issue resolved.
     
  18. MacPoulet macrumors regular

    MacPoulet

    Joined:
    Dec 11, 2012
    Location:
    Canada
    #19
    Interesting. I just got my 2017 rMB a few weeks back and was losing about 20% a night. The most recent macOS update this past weekend helped greatly. Now my battery loss is between 2-4%.

    Oddly enough, that's about how much my battery goes down whenever I open Outlook... Stupid program.
     

Share This Page