Macbook Pro reboots when waking up from sleep

Discussion in 'MacBook Pro' started by claudiuberechet, Feb 17, 2016.

  1. claudiuberechet macrumors newbie

    Joined:
    Feb 17, 2016
    #1
    Hello guys,



    For about a week now I am coming across this issue every time I wake my Macbook Pro (9.2) from sleep: open the lid, and it reboots instead of just waking up from sleep. However, this only happens after a sleep time of more than aprox. 30-40 minutes. When I put the mac to sleep mode over night and when I wanted to wake it up it restarted and was greeted by the following message. I copied the details down below.

    I have tried resetting the SMC and the NVRAM but nothing changed. Still does the same.

    [​IMG]



    Has anyone come across this issue?



    Recently I had switched for a Samsung SSD from my old 750gb HDD that came with the mac. Could this be the problem (it did this reboot thing before but only after unplugging the mag safe connector)?

    Thanks!

    Details from the log:
    *** Panic Report ***

    panic(cpu 0 caller 0xffffff8028fd6a9a): Kernel trap at 0xffffff80294397f5, type 13=general protection, registers:

    CR0: 0x000000008001003b, CR2: 0x0000000108c0a0c0, CR3: 0x000000002c349000, CR4: 0x00000000001626e0

    RAX: 0x0000000000000000, RBX: 0xffffff7faa5ca1e8, RCX: 0x4000000000000000, RDX: 0x0000000000000000

    RSP: 0xffffff91341bbd60, RBP: 0xffffff91341bbd70, RSI: 0xffffff7faa5ca1e8, RDI: 0xffffff803b50c000

    R8: 0x0000000000000000, R9: 0x0000000000000000, R10: 0x0000000000000000, R11: 0x0000001b9ae077f4

    R12: 0xffffff91341bbddc, R13: 0x00000000fffffffd, R14: 0xffffff803b50c000, R15: 0xffffff80fa044000

    RFL: 0x0000000000010217, RIP: 0xffffff80294397f5, CS: 0x0000000000000008, SS: 0x0000000000000010

    Fault CR2: 0x0000000108c0a0c0, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0





    Backtrace (CPU 0), Frame : Return Address

    0xffffff810a903c50 : 0xffffff8028ee5357

    0xffffff810a903cd0 : 0xffffff8028fd6a9a

    0xffffff810a903eb0 : 0xffffff8028ff4093

    0xffffff810a903ed0 : 0xffffff80294397f5

    0xffffff91341bbd70 : 0xffffff7faa628307

    0xffffff91341bbd90 : 0xffffff7faa6242ca

    0xffffff91341bbdc0 : 0xffffff7fa9d43299

    0xffffff91341bbe00 : 0xffffff7fa9d3e9c4

    0xffffff91341bbe30 : 0xffffff80294b8228

    0xffffff91341bbea0 : 0xffffff7fa9d3ea2b

    0xffffff91341bbef0 : 0xffffff7fa9d43209

    0xffffff91341bbf20 : 0xffffff802916cb88

    0xffffff91341bbfb0 : 0xffffff8028fd14b7

    Kernel Extensions in backtrace:

    com.apple.iokit.IONetworkingFamily(3.2)[4DFA207F-1D23-3DD2-A1FF-F4B90D5D3E3F]@0 xffffff7fa9d36000->0xffffff7fa9d62fff

    com.apple.driver.AirPort.Brcm4360(1000.13.1a3)[F81699FD-F0F3-30AC-8977-E96ADE3C 01AA]@0xffffff7faa603000->0xffffff7faacc0fff

    dependency: com.apple.driver.corecapture(1.0.4)[16BA9642-2B81-3FEC-BB6F-FE8E8039DDDF]@0xfff fff7faa4fc000

    dependency: com.apple.driver.mDNSOffloadUserClient(1.0.1b8)[A7681F63-A76A-308E-82EC-E1E3C61 55A13]@0xffffff7faa1d8000

    dependency: com.apple.iokit.IO80211Family(1100.23)[208FCA57-6B2B-3FF2-82F3-3C582B415D5A]@0x ffffff7faa526000

    dependency: com.apple.iokit.IOPCIFamily(2.9)[668E3DEE-F98E-3456-92D6-F4FEEA355A72]@0xffffff 7fa972d000

    dependency: com.apple.iokit.IONetworkingFamily(3.2)[4DFA207F-1D23-3DD2-A1FF-F4B90D5D3E3F]@0 xffffff7fa9d36000





    BSD process name corresponding to current thread: kernel_task





    Mac OS version:

    15A284





    Kernel version:

    Darwin Kernel Version 15.0.0: Wed Aug 26 16:57:32 PDT 2015; root:xnu-3247.1.106~1/RELEASE_X86_64

    Kernel UUID: 37BC582F-8BF4-3F65-AFBB-ECF792060C68

    Kernel slide: 0x0000000028c00000

    Kernel text base: 0xffffff8028e00000

    __HIB text base: 0xffffff8028d00000

    System model name: MacBookPro9,2 (Mac-6F01561E16C75D06)





    System uptime in nanoseconds: 118562679463

    last loaded kext at 56934050129: com.apple.driver.AudioAUUC 1.70 (addr 0xffffff7fab13d000, size 32768)

    loaded kexts:

    com.seagate.driver.PowSecDriverCore 5.2.6

    com.apple.driver.AudioAUUC 1.70

    com.apple.driver.AGPM 110.20.19

    com.apple.driver.ApplePlatformEnabler 2.5.1d0

    com.apple.driver.X86PlatformShim 1.0.0

    com.apple.filesystems.autofs 3.0

    com.apple.iokit.IOBluetoothSerialManager 4.4.0f4

    com.apple.driver.AppleOSXWatchdog 1

    com.apple.driver.AppleMikeyHIDDriver 124

    com.apple.driver.AppleHDAHardwareConfigDriver 272.50

    com.apple.driver.AppleHDA 272.50

    com.apple.driver.AppleMikeyDriver 272.50

    com.apple.driver.AppleUpstreamUserClient 3.6.1

    com.apple.driver.pmtelemetry 1

    com.apple.iokit.IOUserEthernet 1.0.1

    com.apple.Dont_Steal_Mac_OS_X 7.0.0

    com.apple.driver.AppleHV 1

    com.apple.driver.AppleBacklight 170.8.1

    com.apple.driver.AppleMuxControl 3.11.31

    com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.4.0f4

    com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0

    com.apple.driver.AppleSMCPDRC 1.0.0

    com.apple.driver.AppleFIVRDriver 4.1.0

    com.apple.driver.AppleMCCSControl 1.2.13

    com.apple.driver.AppleIntelHD4000Graphics 10.0.8

    com.apple.driver.AppleLPC 3.1

    com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0

    com.apple.driver.AppleThunderboltIP 3.0.8

    com.apple.driver.AppleSMCLMU 208

    com.apple.driver.AppleIntelFramebufferCapri 10.0.8

    com.apple.driver.SMCMotionSensor 3.0.4d1

    com.apple.driver.AppleUSBTCButtons 245.4

    com.apple.iokit.IOBluetoothUSBDFU 4.4.0f4

    com.apple.driver.AppleUSBTCKeyEventDriver 245.4

    com.apple.driver.AppleUSBTCKeyboard 245.4

    com.apple.driver.AppleIRController 327.5

    com.apple.driver.CoreStorageFsck 517

    com.apple.driver.AppleFileSystemDriver 3.0.1

    com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0

    com.apple.BootCache 37

    com.apple.iokit.SCSITaskUserClient 3.7.7

    com.apple.iokit.IOAHCIBlockStorage 2.8.0

    com.apple.driver.AppleSDXC 1.7.0

    com.apple.iokit.AppleBCM5701Ethernet 10.1.11

    com.apple.driver.AppleFWOHCI 5.5.2

    com.apple.driver.AirPort.Brcm4331 800.20.24

    com.apple.driver.AirPort.Brcm4360 1000.13.1a3

    com.apple.driver.AppleAHCIPort 3.1.5

    com.apple.driver.usb.AppleUSBEHCIPCI 1.0.1

    com.apple.driver.AppleSmartBatteryManager 161.0.0

    com.apple.driver.AppleRTC 2.0

    com.apple.driver.AppleACPIButtons 4.0

    com.apple.driver.AppleHPET 1.8

    com.apple.driver.AppleSMBIOS 2.1

    com.apple.driver.AppleACPIEC 4.0

    com.apple.driver.AppleAPIC 1.7

    com.apple.driver.AppleIntelCPUPowerManagementClient 218.0.0

    com.apple.nke.applicationfirewall 163

    com.apple.security.quarantine 3

    com.apple.security.TMSafetyNet 8

    com.apple.driver.AppleIntelCPUPowerManagement 218.0.0

    com.apple.kext.triggers 1.0

    com.apple.iokit.IOSerialFamily 11

    com.apple.driver.DspFuncLib 272.50

    com.apple.kext.OSvKernDSPLib 525

    com.apple.driver.CoreCaptureResponder 1

    com.apple.driver.AppleBacklightExpert 1.1.0

    com.apple.driver.AppleGraphicsControl









    Model: MacBookPro9,2, BootROM MBP91.00D3.B0C, 2 processors, Intel Core i7, 2.9 GHz, 8 GB, SMC 2.2f44

    Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In

    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3431554638424455302D474E2D4620

    Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3431554638424455302D474E2D4620

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (7.21.94.136.1a1)

    Bluetooth: Version 4.4.3f4 16616, 3 services, 19 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: Samsung SSD 850 EVO 250GB, 250.06 GB

    Serial ATA Device: HL-DT-ST DVDRW GS41N

    USB Device: USB 2.0 Bus

    USB Device: Hub

    USB Device: FaceTime HD Camera (Built-in)

    USB Device: USB 2.0 Bus

    USB Device: Hub

    USB Device: Hub

    USB Device: Apple Internal Keyboard / Trackpad

    USB Device: IR Receiver

    USB Device: BRCM20702 Hub

    USB Device: Bluetooth USB Host Controller

    USB Device: USB 3.0 Bus

    Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1




    Thanks!
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Try leaving your external peripherals unplugged overnight (particularly the Seagate external drive) and see if that makes a difference.
     
  3. claudiuberechet thread starter macrumors newbie

    Joined:
    Feb 17, 2016
    #3
    Tried that as well, I left the mag safe charger connected and disconnected and both times it did the same. Usually the hard drive is removed after I'm done working on it.

    Thanks!
     
  4. claudiuberechet thread starter macrumors newbie

    Joined:
    Feb 17, 2016
    #4
    Have done everything you guys said... anybody has other ideas? :)
     
  5. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #5
    Have you tried reinstalling the OS?
    or
    Try doing a clean OS install to a external drive and try running from the external as a test?
     
  6. claudiuberechet thread starter macrumors newbie

    Joined:
    Feb 17, 2016
    #6
    Hello CoastalOR,

    I have installed it on a brand new SSD drive which replaced my old HDD. Nothing changed so I'm thinking that it might actually be something that has to do with the hardware rather than with the software.

    What do you think?

    Thanks!
     
  7. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #7
    It could be software or hardware. It is usually better to test and eliminate the easier (software) first before moving on to the harder (hardware).
    You did not say how you installed the OS on your new SSD. Was it a clean OS install? Did you migrate data/settings from the old HDD?
    From the hardware side it could be a marginal internal drive cable that does not perform reliably at the higher data rate used by the SSD. Using the OS on an external drive would eliminate the SSD and internal drive cable from the problem.
     
  8. claudiuberechet thread starter macrumors newbie

    Joined:
    Feb 17, 2016
    #8
    The install was completely clean, no data migration or time capsule restoration. I did it from scratch. It was rebooting when I was using the old HDD as well, so I think that might eliminate the internal drive cable not being able to cope with the higher data transfer. Furthermore, before installing the SSD I checked the compatibility in terms of speed transfer between the cable I have in my 9.2 MBP and the Samsung SSD, as I was aware of the problems it might bring, and it was a match.

    I will try and make a clean install on a external hard drive, see if that helps.

    Thank you for your help and fast replies!!
     
  9. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #9
    You are welcome.
    You have already done a lot of good troubleshooting. I think the external drive might be a good test. Good luck! :)
     
  10. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    Your panic log shows that your El Capitan system is not updated - still on 10.11
    Current version is 10.11.3
    Open App Store, then Updates, and let the system update itself.
    Not sure if it will provide an answer for your sleep problem, but still worthwhile to update to current system.

    And, booting from your SSD, even through a restart, is much quicker than booting with the old hard drive, eh!
    SO, if you are still concerned, you could simply shut down rather than sleeping.
    That would give you a normal system to boot each time, instead of wondering what is wrong with the sleep function.
    (just a suggestion! :D )
     
  11. claudiuberechet thread starter macrumors newbie

    Joined:
    Feb 17, 2016
    #11
    Hello!

    The panic report is taken right before I updated the OS. I need the Sleep function as I move a lot around with my laptop (from office to office) and many of the times I need to have the same windows/documents open (i know I have the function to have them opened up when booting but it's quite frustrating as it's simply not the same thing as opening the lid and having everything back in less than 3 seconds) :( .
     
  12. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #12
    But, you also said that it only happens after sleeping for more than about 30 minutes or so.
    During the work day, sleep.
    Overnight, shut down.
    Maybe that will work better for you.
    The difference with a longer sleep is that your MBPro goes into a deeper sleep mode after that longer period of time.
     

Share This Page