Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Elektrofone

macrumors 65816
Original poster
Jul 5, 2010
1,033
482
Has anyone else noticed video glitches when watching video full-screen in Safari on Mojave? I have a 2018 MacBook Pro 15" and I'm on the GM of Mojave, but I notice green glitches and other artifacts when playing video. I don't notice this however under Chrome.
 
  • Like
Reactions: Jyite

Einkoro

macrumors member
Jun 18, 2007
78
49
Canada
This doesn't appear to be Mojave specific to me. I've noticed this in Safari 12 on High Sierra with full screen video on both netflix and crunchyroll. Initially I thought crap there goes the GPU with red artifacts appearing over half the screen.
 

Elektrofone

macrumors 65816
Original poster
Jul 5, 2010
1,033
482
This doesn't appear to be Mojave specific to me. I've noticed this in Safari 12 on High Sierra with full screen video on both netflix and crunchyroll. Initially I thought crap there goes the GPU with red artifacts appearing over half the screen.

Damn. Is it specific to 2018 models? I don't notice it in Chrome, so it doesn't seem like a GPU issue.
 

Einkoro

macrumors member
Jun 18, 2007
78
49
Canada
I don’t have my previous machine anymore to check but I wouldn’t be surprised if it’s just a Safari 12 issue.

On the up side the cursor will stay hidden after using space bar to pause/play much more reliably. Mouse interaction hiding or leaving it visible is still pretty random feeling though.
 

MacGizmo

macrumors 68040
Apr 27, 2003
3,135
2,458
Arizona
...On the up side the cursor will stay hidden after using space bar to pause/play much more reliably. Mouse interaction hiding or leaving it visible is still pretty random feeling though.
Wow. I never even noticed that until you mentioned it. I can see where that would be useful for play/pause for Netflix, YouTube, etc. But it also happens on a normal web page where you hit the spacebar to scroll down—the cursor disappears, which in this case is not the optimal result.
 

Einkoro

macrumors member
Jun 18, 2007
78
49
Canada
Wow. I never even noticed that until you mentioned it. I can see where that would be useful for play/pause for Netflix, YouTube, etc. But it also happens on a normal web page where you hit the spacebar to scroll down—the cursor disappears, which in this case is not the optimal result.

It would be nice if it would hide reliably. Usually it does the first time then I scrub past an intro and it won’t go away unless I toggle full screen or pause/play via space. At least Netflix has a skip intro button these days but crunchyroll is a pain.
 

lJoSquaredl

macrumors 6502a
Mar 26, 2012
522
227
This doesn't appear to be Mojave specific to me. I've noticed this in Safari 12 on High Sierra with full screen video on both netflix and crunchyroll. Initially I thought crap there goes the GPU with red artifacts appearing over half the screen.

Yeah I used to actually get red artifacting when stressing FCPX while editing or exporting. When using Netflix fullscreen my screen flashes black for a second when the UI goes away after I leave the cursor alone again, or after every single subtitles change it'll flash until I turn it off again. Super annoying, never happens in Chrome, not sure what the hell it is honestly.
 

LimitGTX

macrumors newbie
Sep 27, 2018
2
1
Updated to Mojave since it was officially released and now I'm seeing glitches with Netflix/Youtube in fullscreen (looks like distortion/screen tearing). Only happens with Safari in fullscreen, no problems with full screen Firefox. Using a 15inch MacBook Pro 2017
 

abn5x

macrumors member
Jul 21, 2018
47
45
Looks like it has been fixed in 10.14.1
can you thoroughly confirm it ?

p.s installed Mojave 10.14.1 beta, can confirm the anterior glitches disappeared, but it introduced a new one, which stretches the video vertically when subtitles disappear, or you turn them on/off.
 
Last edited:

marcioveiga

macrumors newbie
May 21, 2010
8
0
Portugal
Has anyone else noticed video glitches when watching video full-screen in Safari on Mojave? I have a 2018 MacBook Pro 15" and I'm on the GM of Mojave, but I notice green glitches and other artifacts when playing video. I don't notice this however under Chrome.

Same here.
Using a MBP 15' 2018 mid spec and also getting this glitches.

Hope the next Mojave update fixit.

I turn off the automatic graphic mode to force using the dedicated graphic card and it seems to stop.
Can anyone try this too?
 

safariglitching

macrumors newbie
Oct 3, 2018
2
1
Same here.
Using a MBP 15' 2018 mid spec and also getting this glitches.

Hope the next Mojave update fixit.

I turn off the automatic graphic mode to force using the dedicated graphic card and it seems to stop.
Can anyone try this too?

Can confirm. MBP 15" 2018 spec'd out (except storage). Dedicated graphics works fine, it only happens in safari with graphics switching on.
 
  • Like
Reactions: marcioveiga

e1me5

macrumors 6502a
Jun 11, 2013
500
1,078
Cyprus
I've only notice it sometimes on Netflix, but never on Amazon Prime Video. And yesterday, while I was watching a film on Netflix it was fine, up until the point where I received a call to my MacBook Pro though my iPhone pausing the film. Then artefacts appeared when resumed, like bad reception. I switched to the dedicated GPU and they were gone, but the black letterbox lines became dark green. It's weird because on my old 2012 MBP never had this type of problems.
 

fokmik

Suspended
Oct 28, 2016
4,909
4,688
USA
Mojave here, i can report both are true
1) In safari full screen in youtube for example, some video gliches, far less problematic what we had in 2016 MBP
2) It is fixed in the beta 2
 

Elektrofone

macrumors 65816
Original poster
Jul 5, 2010
1,033
482
Mojave here, i can report both are true
1) In safari full screen in youtube for example, some video gliches, far less problematic what we had in 2016 MBP
2) It is fixed in the beta 2

That's great news. Looking forward to the release.
 

Ritsuka

Cancelled
Sep 3, 2006
1,464
968
Actually in beta 2 there are still some issues:
1) low resolution video in youtube and similar websites flickers when fullscreen
2) video colors change when the UI is shown versus when the UI is hidden

all this only when running on the intel integrated card, on the radeon everything is fine.
 

AddVariety

macrumors newbie
Oct 12, 2018
13
93
I've recently purchased the 2018 MacBook Pro 15 inch (coming from a late 2013 model) and notice this behaviour with YouTube and Netflix, both only in Safari. I've not had this issue with Vimeo and watched a hour long documentary yesterday. So that tells me it's not just Safari showing videos in full screen mode, but also something else causing this. Maybe the video codec? I don't know actually.

Another strange thing, but I believe that's more Netflix's implementation is that while I have the current time and scrollbar (which I don't see the point in for Netflix, but who am I?) I don't see the remaining time for Netflix videos in the touch bar. This does work for everything else I've tested.

Seeing the new beta brings some improvements, I'm hopeful that the GM update of 10.14.1 will have fixed the other (new?) glitches that the current beta is experiencing as well.
 

fokmik

Suspended
Oct 28, 2016
4,909
4,688
USA
"with YouTube and Netflix, both only in Safari" since you said that is happening only in safari ...its clear a safari 12 issue,like Apple official said themselves ...we all here have the same issue just in safari...in chrome or other browser no issue
 

BLAKK_RESIN

macrumors newbie
Oct 28, 2018
1
0
"with YouTube and Netflix, both only in Safari" since you said that is happening only in safari ...its clear a safari 12 issue,like Apple official said themselves ...we all here have the same issue just in safari...in chrome or other browser no issue

I have a new MacBook Pro 2,9 Ghz / 32 RAM / 1 TB and I'm experience the same glitches in Chrome while watching fullscreen on Netflix and Youtube. The problem doesn't seem to be a Safari only issue.
 

rjruiz2

macrumors 6502
Jan 28, 2014
483
413
Same thing is happening to me. Video artifacting while watching YouTube only in Safari and only on certain videos. Tried watching the same videos in Firefox and no artifacting at all even on the same videos. Going to try and install the nee OX 12.14.1 tonight and see if that will hopefully fix it.
 

Ritsuka

Cancelled
Sep 3, 2006
1,464
968
One issue was fixed in 10.14.1, but some more remains when running on Intel GPUs:
1. small h.264 video have weird artefacts in fullscreen
2. random flash of unrelated image when switching from UI + video to video only in fullscreen
3. color changes in fullscreen when only the video is shown.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.