MacOS Mojave - App Compatibility

Discussion in 'macOS Mojave (10.14)' started by BasicGreatGuy, Jun 4, 2018.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. Elebato macrumors newbie

    Elebato

    Joined:
    Dec 3, 2013
    #551
    TextWrangler is dead, is has been superseeded by the free version of BBEdit. The non-paid Version of BBEdit offers the same functionalities TextWrangler had and works without problems in Mojave.
     
  2. macbookpro13 macrumors member

    Joined:
    Feb 6, 2010
    #552
    How has printer software compatibility been? My Canon all-in-one is a 32 bit application so I am afraid of upgrading to Mojave.
     
  3. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #553
    32-bit apps are supported in mojave; it's next year's OS that will move exclusively to 64bit.
     
  4. cateye macrumors member

    cateye

    Joined:
    Oct 18, 2011
    #554
    Anyone out there using Font Explorer X Pro that can comment on Mojave compatibility? Current version is 6.0.5. No word from the (traditionally pretty slow) developer, so I thought I'd see if anyone had any hands-on experience. It's a critical piece of my workflow as a designer. Thanks!
     
  5. mike_r_c macrumors newbie

    Joined:
    Jul 20, 2018
    #555
    Google file stream (27.1.49.2230) locks up on Mojave 10.14. Fresh OS install and drive wipe.
     
  6. swandy macrumors 6502

    Joined:
    Oct 27, 2012
    #556
    I see from the "apps that work list" that Codeweaver's Crossover is listed. Does that mean that an old Windows app (Lotus Approach) which I have gotten to work under HS will also work when I upgrade to Mojave? Thanks.
     
  7. meteor71 macrumors newbie

    Joined:
    Sep 24, 2018
    #557
    I have an Epson WF-3540 printer and compatibility has not been a problem for me since I upgraded to macOS Mojave. I use applications like Microsoft Office, PDF Expert, and PDFScanner as well as Apple's own Image Capture and have not had any problems whatsoever.
     
  8. Truyrhtbtfyjn macrumors newbie

    Truyrhtbtfyjn

    Joined:
    Oct 15, 2018
    #558
    Keynote animation is super buggy. I can animate fine, but when recording but especially when exporting it’s rubbish.
     
  9. don1138 macrumors newbie

    Joined:
    Oct 23, 2013
    #559
    Anyone having trouble getting Go2Shell to install in Finder toolbar?

    I think it was working when I updated to Mojave, but now it's gone and won't re-install in toolbar.
     
  10. ultradk macrumors newbie

    ultradk

    Joined:
    Oct 1, 2009
    Location:
    Denmark
    #560
    Unison not working..
    Sonos is also in trouble in Mojave
     
  11. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #561
    PathFinder 8 is a mess on any platform, but the way Cocoatech has tried to do dark mode on Mojave’s is an abomination. And their ‘support’ is virtually non-existent. That’s a huge shame because they used to be good, responsive and helpful.
     
  12. Droid13 macrumors regular

    Joined:
    Jul 22, 2009
    Location:
    United Kingdom
    #562
    The list of apps that are working includes Caffeine 1.1.1 (http://lightheadsw.com/caffeine/). However, I have found that it is not working at all - although it appears to load, filling the cup with coffee doesn't keep my MacBook awake anymore; the screensaver just kicks in anyway.

    Before I edit the Wiki, can anyone else verify?
     
  13. Zax, Oct 19, 2018
    Last edited: Nov 4, 2018

    Zax macrumors newbie

    Joined:
    Jan 10, 2007
    #563
    Anybody else here is using Adobe Director? I would like to confirm a couple of issues. I cannot create projectors unless I exclude all the Xtras. Maybe the problem is in my machine only?
     
  14. antibolo macrumors newbie

    Joined:
    Sep 27, 2017
    #564
    I assume Lightroom Classic is fine now? It has been updated recently.
     
  15. Tech198, Oct 20, 2018
    Last edited: Oct 31, 2018

    Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #565
    https://www.codeweavers.com/about/blogs/rabhiram/2018/6/26/the-good-the-bad-and-maybe-not-so-ugly

    The take-away, is "they CAN offer 64 bit for Mojave" .

    I've been using Wineskin (winery) with HS, and it continued to work after Mojave upgrade.. http://wineskin.urgesoftware.com/tiki-view_blog_post.php?postId=87

    The only thing is brakes if "Auto detect GPU" for DirectX, which i had to disable, but part from that, everything still works.

    I know this is a feature of Wineskin, but i think its always on in Crossover:

    https://www.codeweavers.com/support/forums/general/?t=27;mhl=123990;msg=123978

    Can sometimes cause issues, but may be ok.
     
  16. yellow8 macrumors member

    yellow8

    Joined:
    Mar 14, 2017
    #566
    PDFZone is now fully compatible with macOS Mojave!
    Also support the Dark Mode :cool::)
     
  17. Starman535 macrumors member

    Starman535

    Joined:
    Apr 12, 2018
    #567
    --- Post Merged, Oct 23, 2018 ---
    I think Mojave is the OS from Hell. This OS bricked my 2015 I5 2.5 Ghz Macbook Pro by deleting ALL my account passwords, so I couldn't even get logged in. Need to restore High Sierra from backup, unless someone knows a fix for this.
     
  18. dwfaust macrumors 601

    dwfaust

    Joined:
    Jul 3, 2011
    #568
    This is the first that I’ve seen/heard of this. I’ve upgraded 4 Macs of varied vintage and configuration. No such issues here.
     
  19. Starman535 macrumors member

    Starman535

    Joined:
    Apr 12, 2018
    #569
    Its odd, perhaps, but I have 16 Gb of RAM on my Mac. The first time, the install failed, and I stopped it after 6.5 hrs of no activity. Restored High Sierra from the latest time machine backup. Second time, It seemed to work, but I couldn't log on as all the account passwords were corrupt, including a guest account that had no password. Reason for upgrade: *&^$%*$%* Microsoft puts an expiration date on Skype, which I use to communicate with the Grand Children.
     
  20. MacJunk macrumors newbie

    Joined:
    Sep 21, 2018
    #570
    I am experiencing this with the BruceX benchmark project on the latest FCPX (10.4.3) and Mojave 10.14 (18A391)

    Running FCPX on High Sierra on my 2015 13" MBP (base model basically i5, 8GB RAM) I could scrub seamlessly through the timeline with instantaneous preview and export took 1:30 or so. just switched over to a 2014 15" MBP with i7 and 16GB RAM, significantly more power and scrubbing is jerky and not smooth and export took twice as long. After upgrading to Mojave on the previous laptop it's now doing the same thing.

    Anyone else having these issues?
     
  21. Tech198 macrumors G5

    Joined:
    Mar 21, 2011
    Location:
    Australia, Perth
    #571
    Wineskin is broken.. in Mojave..... It may work, but not always. Most likely Winetricks crashes as well.

    App opens sometimes, depending on the app.. it may not even open at all.. and no error popup.
     
  22. PitBullCH macrumors newbie

    PitBullCH

    Joined:
    May 14, 2015
    #572
    Anybody had any joy with a Canon CanoScan 9000F ?

    Been very happy Canon updated the drivers and MP Navigator for each OSX/MacOS update in recent years, but so far nothing for Mojave in their downloads section, and the Sierra/HighSierra version just crashes immediately :-(
     
  23. ferences macrumors newbie

    ferences

    Joined:
    Nov 13, 2018
    Location:
    Ottawa, Canada
  24. Hawaiian Starman macrumors member

    Joined:
    Oct 27, 2001
    Location:
    Somerset West, South Africa
    #574
    I tried PF8 (trial) for 10 minutes…immediately went back to PF7. Hard to believe Cocoatech released 8. As you say, quite a mess. PF7 works without issue on Mojave.
     
  25. tommiy macrumors member

    Joined:
    Dec 11, 2015
    #575
    Tuxera NTFS 2018, Mojave, VMWare Fusion 11 on a 2017 MAC results in a kernel lock when shutting down a VM. Need to power off the MAC by the power button.
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page