Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
Status
The first post of this thread is a WikiPost and can be edited by anyone with the appropiate permissions. Your edits will be public.

xflashx

macrumors regular
Original poster
Aug 12, 2016
183
629
This is a wikiPost that will be updated regularly.

Current Bugs:
  • No sound in Plex https://forums.macrumors.com/threads/frontrunning-the-macos-issues-plex-has-no-sound.2299627
  • Most VPN apps are broken Seems to be partially resolved in Beta 2 (Wireguard works, NordVPN does not)
  • Safari's color matching top not perfect yet
  • Can't use dynamic pictures from Big Sur as desktop
  • Universal Control apparently not included in Beta 1,2, 3 and 4
  • Some UI elements (like the Dock or Safari Tab Bar) might look blurred Seems to be resolved in Beta 2
  • Network mounts are displayed on the desktop with a hard-drive icon
  • handwritten messages do not show up in Message
  • Mouse/Trackpad input might be laggy
  • Safari Tab Group Sync between iOS 15 beta 1 and Monterey don't seem to work
  • Private Relay in System Settings automatically reenabled after some time
  • Hide IP Address in Safari automatically reenabled after some time
  • 3D Globe in Maps unavailable on Intel macs (is available on Big Sur and lower)
  • Quick Look no longer plays videos. Rebooting corrected this.
  • "Reset the Bluetooth module" and other Debug features (like resetting paired Apple Devices) not available in the Bluetooth menu using Option+Shift anymore
  • Lumix G9 Burst Raw files cannot be opened by OS inbuilt apps. ( finder, photos, preview ). Third party apps using apple RAW engine seem to work.
  • Magic Mouse 2 looses scrolling after Mac returns from sleep mode. Mouse off/on fixes it.
  • There are a few reports that external cameras are not being detected (no video device). Examples are piwebcam (a raspberry pi based webcam) which presents as a UVC device. IOKit matching seems to pick them up, but MacOS is not seeing them as video devices. The same devices were working with Big Sur and earlier.
  • Spatial Audio not working in Apple Music
 
Last edited:
  • Like
Reactions: moloukhya

Joseph C

macrumors 6502a
Apr 15, 2013
826
1,095
Safari doesn't look like it did in the Keynote to me with the colour matching at the top.
 

glbski

macrumors newbie
Jun 8, 2021
1
0
Messages crashes out immediately on my intel MacBook pro...UPDATE, copied over the Messages app from another beta upgraded Mac, it still crashed, then removed the copied app with the help of Clean my Mac, which also cleaned out a bunch of other stuff...now working just fine
 
Last edited:

petekjohnson

macrumors newbie
May 24, 2012
29
18
Springfield, MO
MacBook Air (M1, 2020)

I am here to report that for 14 hours I have found DP1 to be frigging amazing. Far and away the most seamless OS upgrade I have ever performed, beta or not. I had exactly ONE app that flat out refused to run, and all it did was crash gently into a crash report window. Another app needed to install a System Extension that required me to restart into Boot Options and reduce my Security Policy before I could get them approved for loading. And then it worked fine. EVERYHING else has worked great. Not one hiccup.

I haven't had enough time to really explore all over the place, but one thing that I was eager to check into was the new built-in 2-factor authentication feature, and I can report that it works flawlessly. I was using OTP Auth before, and thought that was an excellent Mac/iOS/iCloud combo solution, but now I don't even have to go and GET codes to enter, it all happens automagically. It's fantastic!

  • 1Blocker 3.16.1 (works flawlessly)
  • AdGuard 2.5.3.955 release (works flawlessly)
  • Airflow 3.3.1 (works flawlessly)
  • Audiobook Builder 2.1.2 (works flawlessly)
  • Carbon Copy Cloner 6.0.1 (gives message about unsupported operating systems, then allows you to continue anyway, and seems to work fine. I wouldn't necessarily use it for a restore, but definitely to do a backup)
  • Cisdem PDFMaster 4.0.0 (crashes on launch)
  • CleanMyMac X 4.8.4 (works flawlessly)
  • DAEMON Tools 8.2 (requires System Extensions and rebooting twice to get up and running, then works flawlessly)
  • Deliveries 9.1.2 (works flawlessly)
  • Downie 4.2.6 (works flawlessly)
  • Droplr 5.9.5 (works flawlessly)
  • ExpressVPN 10.3.0 (works flawlessly, but after connection, got a message that it conflicted with iCloud+ Protected Browsing)
  • FE File Explorer Pro 3.0.4 (works flawlessly)
  • ff·Works 2.3.2 (works flawlessly)
  • Filmage Screen 1.3.1 (works flawlessly)
  • Fission 2.7.0 (message about unsupported operating systems, allows you to proceed anyway, seems to work fine)
  • Friendly Streaming 5.9.7 (works flawlessly)
  • Google Chrome 91.0.4472.77 (works flawlessly)
  • HandBrake 1.3.3 (works flawlessly)
  • IINA 1.1.2 (works flawlessly)
  • iMazing 2.13.8 (works flawlessly)
  • KeyboardCleanTool 3 (works flawlessly)
  • Linguist 2.4 (works flawlessly)
  • Facebook Messenger 97.11.116 (ONLY item to indicate needing Rosetta to continue, works flawlessly)
  • Meta 2.0.5 (works flawlessly)
  • OTP Auth 2.17.4 (works flawlessly)
  • Pacifist 3.6.2 (works flawlessly)
  • Permute 3.6.4 (works flawlessly)
  • Plex 1.31.1 (works flawlessly)
  • PlistEdit Pro 1.9.2 (works flawlessly)
  • Radio Silence 3.1 (works flawlessly)
  • Remote Desktop 3.9.4 (works flawlessly)
  • Signal 5.4.0-beta.4 (works flawlessly)
  • Skype 8.72 (works flawlessly)
  • Spotify 1.1.60.668.gff09d345 (works flawlessly)
  • Tampermonkey 4.11.6117 (works flawlessly)
  • The Unarchiver 4.3.0 (works flawlessly)
  • Transmission 3.00 Nightly (works flawlessly)
  • WhatsApp 2.2119.6 (works flawlessly)
  • Yate 6.5 (works flawlessly)
  • zoom.us 5.6.6 (works flawlessly)

An intermittent but very annoying problem where nearly all my "messaging" apps (Messages, Signal, Facebook Messenger, etc.) would stop playing notification sounds has gone away. They seem totally consistent in always playing them now.

SMB network connections seem more reliable.

Podcasts app continues to occasionally not remember my specified window placement and size.

Everything else has been seamless so far - KNOCK ON WOOD.

I'm NOT a developer, but the way I see it, with Catalina they introduced the split system and data volumes with "firmlinks" to make it appear as one unified file system, and System Integrity Protection (SIP). Lots of stuff was badly broken right from the start. Big Sur introduced the cryptographically Signed System Volume (SSV) and totally eliminated kernel extensions in favor of system extensions, while also making it much harder to install and authorize and load them, so many other things badly broke. Introducing the M1 architecture brought changes to all things related to the Restore/Install/Security boot-up modes, and the way of making external drives bootable. With Monterey, it does not SEEM to have nearly as many fundamental architecture changes that appear to be breaking apps. In the past, I would DEFINITELY already have had an app freeze or crash or a kernel panic by now. This time: nothing - flawless!

-Pete
 
Last edited:

Gtx_Asti

macrumors newbie
Jun 24, 2020
9
3
Can someone please check if Sketch works fine on the first beta?
 
Last edited:

Dr Kevorkian94

macrumors 68020
Jun 9, 2009
2,158
47
SI, NY
Playing around with Shortcuts it seems it’s generally less extensive than Automator. Makes sense but I hope it improves over time instead of being a more walled in version. I imported an Automator workflow that simply adds photos from a location to photos app and I noticed the “Check for Duplicates” option is gone for the specific action of adding. Additionally I can’t add to Photos library only recents but they are possibly one and the same now idk.
 

Donga120

macrumors 6502a
Sep 19, 2014
746
445
UK
My late 2015 iMac takes about 10 minutes to boot to get to login screen, enter password and it just freezes
 

mgworek

macrumors member
Feb 21, 2006
71
45
Safari would't load previous session windows with multiple tabs. I hate to exit and go back in and they opened again.

Messenger doesn't seem to always autoscroll showing the latest message in the window.
 

gank41

macrumors 68020
Mar 25, 2008
2,357
2,024
I'm wondering if anyone else is having issues with Safari NOT remembering to Trust the Browser when signing into the Developer Portal. I'm still on macOS 11.4, not macOS 12, and I'm prompted to Trust the Browser every day I sign in. Is this an issue for anyone on macOS 12?


Screen Shot 2021-06-08 at 7.07.35 AM.jpeg
 

AlanShutko

macrumors 6502a
Jun 2, 2008
803
213
I'm wondering if anyone else is having issues with Safari NOT remembering to Trust the Browser when signing into the Developer Portal. I'm still on macOS 11.4, not macOS 12, and I'm prompted to Trust the Browser every day I sign in. Is this an issue for anyone on macOS 12?
Every single time on macOS 12.
 
  • Sad
Reactions: gank41

nortonandreev

macrumors 68020
Jan 11, 2016
2,080
2,649
Manchester, United Kingdom
I'm wondering if anyone else is having issues with Safari NOT remembering to Trust the Browser when signing into the Developer Portal. I'm still on macOS 11.4, not macOS 12, and I'm prompted to Trust the Browser every day I sign in. Is this an issue for anyone on macOS 12?


View attachment 1789668
I have been having this issue for ages...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.