MBP mid-2012 SSD upgrade getting no permission on boot up

Discussion in 'MacBook Pro' started by Jordikitchen, Dec 20, 2016.

  1. Jordikitchen macrumors newbie

    Joined:
    Dec 19, 2016
    #1
    Hi All!

    First post on here after reading two dozen posts across here and other forums that unfortunately haven't worked for me.

    I have a a factory mid-2012 MBP with 4gb RAM and 500gb hdd, which obviously well overdue for an upgrade. I purchased a Crucial 8gb RAM kit and Samsung Evo 850 500gb SSD. The ram was supposably "delivered" over a week ago and hasnt turned up; so far my upgrades aren't going well...

    When installing the SSD I begun by using Carbon Copy Cloner to copy over the hdd contents using a Unitek external data converter. I did a complete clone including the recovery partitions and all, which took around four hours. Once copied I rebooted, held option and the ssd boots externally and runs fine. So I proceed to removing the hdd and replacing with the ssd.

    When booting with the ssd installed into the laptop, i get the Mac chime but the I get a grey screen with no entry sign.

    Because this didn't work, I reinstalled the old hdd and tried running recovery mode and installing a fresh copy to the ssd. Again, this all appeared fine until I get the same symbol.

    So, both cloning and installing a fresh copy both don't work. I can revert back to the hdd and it runs normally in OSX. I've tried resetting the PRAM also. From my reading it seems like the only two remaining options are a faulty ssd cable (maybe not given my hdd works) or the ssd is faulty.

    Any help would be much appreciated, after trying this multiple times I'm losing my mind...

    Thanks!
     
  2. Huge125 macrumors member

    Huge125

    Joined:
    Jun 16, 2011
    Location:
    Charlotte, NC
    #2
    Hello Jordikitchen,

    I have the same 2012 MBP, and have a 500gb Samsung Evo on the way as we speak, lol. I do not have much advice for you, but am interested in following your thread as this is my project for this week.

    I'm planning on using a USB with Sierra on it, and am going to be doing a fresh install as everything on El Capitan seems to be magically breaking within the past few weeks, such as email not syncing and weird messages about proxy network settings.

    Have you tried holding the option key down when you boot up with the new SSD drive installed? That should bring you a start menu where you can choose which drive you want to use. For me, I'm going to boot from the usb, partition the SSD etc, but for you if the SSD is already cloned you should be able to point to it and get rolling? Sorry if you've already tried that, its the only thing I can think of.

    Good luck!
     
  3. Jordikitchen thread starter macrumors newbie

    Joined:
    Dec 19, 2016
    #3
    Yes, so to be more specific once the hdd contents have cloned to the sdd, while it is still hooked up externally i test its booting capability by restarting the computer, holding down option and it boots up from the ssd fine. Once the drive is installed in the laptop however, that's when I get the no entry sign on boot up.
     
  4. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #4
    What you described is the classic way you test for a problematic internal drive SATA cable. There have been instances in the forum of a marginal SATA cable not being able to perform properly at the increased data rates of the SSD. The old slow data rate of a spinner HDD performs fine internally.

    I think you need to replace the internal SATA cable.
     
  5. Jordikitchen thread starter macrumors newbie

    Joined:
    Dec 19, 2016
    #5
    Thanks CoastalOR. Excuse my ignorance, but would something like this suffice? Or how can I get the correct part number?
    https://www.amazon.com/923-0741-Hard-Drvie-Cable-821-1480/dp/B00GJQCJWG

    I'm in New Zealand, so ideally I'd tried source a cable here by way of supplying a part number or something presumably.
     
  6. CoastalOR, Dec 21, 2016
    Last edited: Dec 21, 2016

    CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #6
    That looks like the correct part.

    Here are some good repair instructions for you:
    https://www.ifixit.com/Guide/MacBook+Pro+13-Inch+Unibody+Mid+2012+Hard+Drive+Cable+Replacement/10379
     
  7. Jordikitchen thread starter macrumors newbie

    Joined:
    Dec 19, 2016
    #7
  8. b0fh666 macrumors 6502a

    b0fh666

    Joined:
    Oct 12, 2012
    Location:
    south
    #8
    try a PRAM reset after installing the cloned SSD. if that fails you need a new cable.
     
  9. Jordikitchen thread starter macrumors newbie

    Joined:
    Dec 19, 2016
    #9
    Okay, finally got the new cable! Installed it, and the new SSD booted fine externally, so I installed a fresh copy OS X on it and it continued to boot up fine externally. I installed it internally, as well as the RAM that also finally turned up also, transferred most of my stuff over manually, and all was smooth sailing for two days!

    Now however, I'm back to issues already .. When I boot up, a grey screen appears and eventually a folder with a question mark appears.

    This seems to be a common problem so I followed the advise of a few other posts; starting with entering recovery mode (which goes straight into internet recovery). This takes a while to get into but I get into disk utility which says the SSD has just 40mb of free space (when I started transferring stuff over it when OS X was installed it may have got to about half capacity so this seemed weird!). The partition is also greyed out on the left.

    I run disk utility which fails and I get the message attached.

    I'm ridiculously stuck, someone please help ha...
     

    Attached Files:

  10. Jordikitchen thread starter macrumors newbie

    Joined:
    Dec 19, 2016
    #10
    Hi all, I tried running through an install again. Again, I successfully installed PwC while the SSD was connected externally. I installed it into the laptop and when I try booting up, a flashing folder with a question mark keeps appearing - it seems the new SATA cable hasn't worked.

    I put the old drive back in, and connected the new drive externally, and when holding option to choose which drive to boot from, the SSD doesn't even show up... When booting into OS X on the old drive I can view the new drive and it's contents through Finder.

    Any help please? Thanks for all those so far for their replies!
     

Share This Page