Messages in OS X fail to display

Discussion in 'OS X El Capitan (10.11)' started by cocoatronik, Apr 19, 2016.

  1. cocoatronik macrumors member

    cocoatronik

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #1
    My Messages app on my MacBook Air suddenly stopped displaying new messages. Old conversations show, but they have not updated since about a week ago. The problem does not correspond to any updates I performed. The Messages version is 9.2 and the OS is 10.11.4, but this problem started while I was still using 10.11.3.

    When I receive a new message, the "new message" icon appears to the left of the dock (so something is reaching the computer), but the message never displays as a conversation in the app. The new message is also not under ~/Library/Messages/Archive.

    I can begin new conversations from the Messages app, and replies to those conversations display properly. But conversations not initiated from the app fail to display. Messaging continues to work fine on my iOS devices. It's just the OS X Messages app that doesn't work.

    I have tried removing the files com.apple.imessages.bag.plist and com.apple.ids.service.com.apple.madrid.plist from ~/Library/Preferences.

    I have also tried deleting the files chat.db, chat.db-shm, and chat.db-wal from ~/Library/Messages. These are recreated as new files upon rebooting, but the problem persists even with fresh DB files.

    I also repaired permissions (which in El Capitan apparently needs to be done as a sudo command in Terminal).
     
  2. cocoatronik, Apr 19, 2016
    Last edited: Apr 19, 2016

    cocoatronik thread starter macrumors member

    cocoatronik

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #2
    SOLVED!

    Turns out, the problem was not on my MacBook Air, but instead on my iPhone. I had reset all iPhone settings last week while attempting to solve a separate problem (my iOS Mail app kept crashing). That reset cleared the settings that allowed my other devices to receive texts.

    To fix this on the iPhone, I needed to update Settings > Messages > Send & Receive to include my iCloud email, and also Settings > Messages > Text Message Forwarding to allow other devices (like my MacBook Air) to receive.
     

Share This Page