More wifi issues on iOS 8.1

Discussion in 'iOS 8' started by keysofanxiety, Oct 22, 2014.

  1. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #1
    Not sure what else to do. Tried hard reset and everything's fully up-to-date. Wifi keeps slowing to a crawl -- issues especially obvious when playing live online games (Poker, Pool, SSG2).

    I'm open to suggestions on how to fix it. Painfully unsatisfied with Apple recently and I pray there's a simple fix that I've overlooked.

    I'm on an iPhone 5S.

    Does anybody have any suggestions please? :)
     
  2. hernan1304 macrumors member

    Joined:
    Apr 27, 2011
    #2
    Have you tried changing your router security to WPA2? Other people have reported success doing that.
     
  3. dcharleyultra macrumors 6502

    Joined:
    Sep 28, 2013
  4. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hi hernan, thank you for taking the time to reply. Regrettably I've already tried that. :(

    Thank you again for your efforts though.

    ----------

    Ah, that's the answer I was hoping to avoid! If there's nothing else I can do though, I'll definitely give it a go.
     
  5. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #5
    Silly question but have you actually restarted your router regardless if other devices have issues or not?
     
  6. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #6
    Not a silly question at all Armen, I really appreciate you taking the time to suggest things! I haven't reset the router since I updated to 8.1 (though I did on 8.0). I'll try that now.

    Thanks again. :)
     
  7. Skevaboy macrumors member

    Joined:
    Dec 14, 2011
    Location:
    Toronto
    #7
    Is the issue on all Wifi networks or just your own?
     
  8. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #8
    If it worked you're welcome! :D

    If not...try resetting network settings on your phone. (if you haven't already)

    note: resetting network settings wipes Wifi passwords.
     
  9. keysofanxiety, Oct 22, 2014
    Last edited: Oct 22, 2014

    keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #9
    Thanks dude. Router reset didn't work, just reset network settings. Hopefully this will do the trick.

    Again thank you for taking the time. I know I should have done a little more research before on this matter, and I hate it when people do what I do (start a thread with minimum research and maximum moaning). So for that I really appreciate your patience.

    You guys are all great.

    ----------

    [/COLOR]
    All wifi networks, so hopefully the network setting reset on my phone, as kindly suggested by Armen, should do the trick. :)

    For those wondering, who are in a similar position to me:

    Settings > General > Reset > Reset Network Settings

    ----------

    ----------

    Just tried a few games. No luck guys, sorry :(
     
  10. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #10
    turn off "wifi networking" in settings>privacy>location>system settings. That seemed to helped with iOS 8. Also set router to a fixed channel (turn off auto select channel). Lastly try setting a static IP address either in phone or reserve it in your router. Of course do these one at a time to see if any change and if so which one.
     
  11. keysofanxiety, Oct 22, 2014
    Last edited: Oct 23, 2014

    keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #11
    Thank you for the advice, sincerely appreciate it.

    Wifi networking disabled fixed the issue. Again: you have FIXED the issue!!!! Thank you so, so much, and to everybody who contributed.

    May I pass on my personal well wishes for taking the time to assist.

    EDIT: issue came back in a few hours. :(
     
  12. bertimus2002 macrumors newbie

    Joined:
    Sep 11, 2014
    #12
    So, I have been having the same issue with my iPhone 5S as well as my wife's.

    Router is WPA2, no WiFi Networking turned on in the Privacy Settings.

    Reset her device completely, still issues. Reset Network Setting on both, still issues.

    Any other suggested fixes? I have an Apple Store appt for Friday to talk with them about it and see what we can do (or get a replacement).

    No issues on iOS 7, but ever since the iOS 8->8.02->8.1 update, WiFi has been having issues like it is connected, but no data will transmit.
     
  13. gambit75 macrumors newbie

    Joined:
    Oct 11, 2013
    #13
    Same issue on my 5s. Upgraded to 6 and don't have the issue, but gave my wife my 5s and did a restore with her backup and same thing.

    Have done all the suggestions above. Let me know what you find out.
     
  14. Mattman17 macrumors newbie

    Joined:
    Oct 20, 2014
    #14
    Your not alone. Initial iOS 8.1 update, network worked well for 8 hours, then after that, I've had to toggle wifi off/on, like when updated to 8.x.x...

    From the multiple threads about this, "seems" to lean towards the routers running 802.11g more so, then the folks with routers running 802.11n
     
  15. jmxp69 macrumors 6502

    Joined:
    Dec 10, 2008
    #15
    Interesting read. I turned Wifi networking off in system services when I first got the phone based on a privacy article I read. Coincidentally I've not experienced Wifi slowdown issues. On 8.0 I had a few Wifi dropped signal/fail to reconnect issues, but nothing related to a slow down. Good to know and glad you got it fixed.

    Half the time in these issue threads I'm tempted to say "mine works" to lend moral support and give some hope what people are seeing isn't necessarily a universal flaw. Glad I kept my pie-hole shut on this.

    Going to turn Wifi networking back on to see if I can replicate the issue.
     
  16. shook187 macrumors member

    Joined:
    Sep 21, 2014
    #16
    I was having the slow Wi-Fi issue but only at work. Since the 8.1 update my work Wifi have been incredible fast.

    If you're having issues with all Wi-Fi's you may have a hardware problem
     
  17. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #17
    May have spoken too soon. After a few hours the issue came back. Sorry guys. :(

    This is driving me mental. For the money iPhones cost and Apple's self-smug attitude about making the best products in the world, we're having to delve into the bowels of the phone to enable the simplest of functionalities.

    I'm happy to be people's guinea pig -- I'll keep trying and let you know what does/doesn't work.

    Really pleased to see everybody's feedback and I'm at least reassured that I'm not alone.

    Thank you all for reading through and I hope we'll all get a fix for this issue.
     
  18. jmxp69 macrumors 6502

    Joined:
    Dec 10, 2008
    #18
    I've had past issues with automatic channel selection. Doesn't seem to impact my current setup. Last Gen Time Capsule, 802.11n, auto channel.

    Try setting a fixed channel and use only one radio band (2.4 or 5). I'd start with 2.4g because it has better range. Also try changing the channel. If you have access to a wifi scanner (Android has really good ones) you can find out if there are conflicts close to you on the same channel. Then hard code the least used channel in your router.
     
  19. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #19
    The WiFi networking setting in Privacy is supposed to gather information about WiFi access points around you.

    If having this feature enabled was detrimental to the device's WiFi performance why would the option even be there let alone turned on?

    There has to be another explanation as to why turning it off is improving WiFi performance.
     
  20. jmxp69 macrumors 6502

    Joined:
    Dec 10, 2008
    #20
    Maybe the route from his ISP to the collection server was messed up and the phone hangs trying to send packets. Point is any of it is speculation without the proper test/analysis tools. Barring packet capture capabilities, the next best option is to eliminate variables to the greatest extent possible.
     
  21. X-X macrumors 6502

    Joined:
    Aug 22, 2014
    #21
    Settings > Privacy > Location Services > System Services > Wi-Fi Networking

    What does it do exactly?
     
  22. hernan1304 macrumors member

    Joined:
    Apr 27, 2011
    #22
    I'm just guessing here but haven't seen it mentioned so feel free to ignore but perhaps try updating your router's firmware?

    Also for anyone who doesn't know about it there is an app from Speedtest.net that you can download from the App Store to check your speeds.

    Oh and also try the "forget" option on your network and reconnect to it (I think reset network settings does the same thing).
     
  23. bertimus2002 macrumors newbie

    Joined:
    Sep 11, 2014
    #23
    I have a Cisco EA4500 router running the latest firmware. I will try and connect to my 5Ghz network only and see if that has an impact later on tonight.
     
  24. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #24
    2 posts above yours

    The WiFi networking setting in Privacy is supposed to gather information about WiFi access points around you. I'm pretty sure it also makes your GPS location more accurate based on that as well.
     
  25. jmxp69 macrumors 6502

    Joined:
    Dec 10, 2008
    #25
    You know that error message you get that says, "location information is improved with wifi enabled" They're collecting Wifi names and GPS locations to help with location accuracy. Android does the same thing. You don't need it enabled to use wifi.
     

Share This Page