New graphics problem on 2011 MBP with failed AMD chip

Discussion in 'MacBook Pro' started by Amanda Ripanykhazova, Apr 29, 2018.

  1. Amanda Ripanykhazova, Apr 29, 2018
    Last edited: Apr 29, 2018

    Amanda Ripanykhazova macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #1
    Here's a new one?: A few months after successfully deactivating the AMD chip and using the Intel one, I ran a command-D hardware diagnostics to check memory. (check reported a bad chip with both inserted on extended testing but testing each one individually in either slot reports both SODIMMs OK???)

    Half way along the test, suddenly the whole background turned into vertical black and green bars! Now, I can with difficulty get rid of it by exiting out of Command R S a few times; but if I can get the screen to display properly, after a few hours of use, I get the more usual christmasy pink and white vertical bars suddenly bursting through all over the screen, and each alternate bar shows a nasty moiré effect. This does come and go and leaves the green and black vertical bars on backgrounds and all over graphics on the screen (but not on white text).

    Any ideas on this please? Is something from that AMD chip breaking through (yes, I have deleted all the AMD kexts) or is this some new problem with the Intel one which displays the same way as the AMD chip problem?

    Curiously the MBP DOES now boot properly and doesnt go into kernel panic on startup with the pink and white vertical bars on the apple and progress bar. It does occasionally go to a (uniform) dark blue screen on exiting out of single users mode.

    (It is not inconceivable that I have some memory problems, the pointer leaves a small trail on the screen and Safari wont render pages properly, but I wouldnt imagine that can be relevant to this obvious graphics problem)
     
  2. Amanda Ripanykhazova thread starter macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #2
    Sorry that my posting didn't elicit any interest but i wonder if there is any way of resetting my 17inch 2011 MBP with the dead amd chip? Does reinstalling the OS achieve this or will it just completely stop my computer from booting?

    Summarising my problem, after a few months of working properly on the intel chip, suddenly during an extended hardware test, I got VERY strong green and black vertical bars which now won't go away. I cant figure out if this is the dead chip interfering or a new problem with the Intel chip

    I thought I would try a bit of self-help. I tried https://forums.macrumors.com/thread...efi-variable-fix.2037591/page-7#post-24599874 in high sierra.,

    That didn't help and now almost everything I try in Command S R (except disabling or enabling SIP) gives an error message. Even Command S now scrolls past former stops to enter commands, and after lengthy verbose messages gives the uniform dark azure (kernel panic?) screen.

    Should i reinstall and try 24599874 again or are there updated instructions for HS?
     
  3. Macbookprodude macrumors regular

    Macbookprodude

    Joined:
    Jan 1, 2018
    Location:
    ЗША
    #3
    Hi, this could be a graphics issue with the chip as the 2011's had issues with the chips. Try to run a stress test on the graphics to be sure its not the chip. Also, you could try reinstalling the OS, but that may not work if its the chip for sure.
     
  4. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    If you have removed the kexts that the AMD chip uses, to bypass that chip - then your chip is bypassed WHILE booted to your normal installed system. The diagnostic test runs in its own OS, and doesn't use your installed system. at. all.
    So, a failed chip will still fail testing.

    And, memory faults might show up in a variety of ways. It is not inconceivable that memory faults would show up as graphic problems, and would be one of the symptoms of possible bad RAM in the first place. Remember that memory testing also tests the logic board memory controller.
    But, with the history of the graphics issues on the 2011 15 and 17-inch models, what you are seeing is likely just more symptoms of the graphics chip issue on those models.
    Did you think that a little software manipulation (deleting a few kexts, etc) would permanently fix a hardware issue on your logic board? Works for some, but not for everyone, and it's just delaying the inevitable failure of a poor design.
     
  5. Amanda Ripanykhazova thread starter macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #5
    But, incredibly, the failed graphics chip passed hardware testing, - while displaying all the symptoms of failing at the exact moment it was doing so!!!

    And whatever was wrong with the memory keeps passing extended diagnostics! And then boots up to the rippling pool effect spreading vertically up the screen on boot up and in Chrome, just to annoy me!
     
  6. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    I would try replacing the RAM, just because of the potential of the RAM contributing to your issue, even if they test good.
    Swapping with different memory is your real test.
    If there is no change with different RAM installed, then you move on to some other solution.
    You could also try the comprehensive testing that Memtest will provide.
     
  7. Amanda Ripanykhazova thread starter macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #7
    Two problems now with this ultra-flakey computer.

    It has rebooted a few times, when it suddenly gave me the INSTALLING UPDATES 20 MINUTES REMAINING screen! On a normal looking white background. then it went to the azure blue screen after about 80% completion. When nothing happened, after 30 mins, I hit the power button and it restarted to the pink and white christmassy vertical bars (your amd chip has died) screen which usually precedes a kernel panic.

    Then, it restarted itself into single user mode and when it emerged, - all the problems went away!! Except that I do get the rippling pool effect spreading vertically up the screen on boot up and in Chrome; but otherwise, everything works fine suddenly!
     
  8. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #8
    I'm wondering if the back cover could be pressing against the "topmost" RAM dimm, causing errors?

    In that case, I would open the back, remove the top dimm, put the cover back on, and see if the memory problems went away.

    But you seem to have found "a good spot" with the system re-install.
    In that case, better not touch anything!
     
  9. Amanda Ripanykhazova thread starter macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #9
    both memory chips test OK in either slot

    I suspect there is some minor incompatibility with the chips? Which is otherwise relatively inconsequential
     
  10. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #10
    Your laptop is 7 years old that is two years longer than anyone should expect a laptop to last. Cut your losses and get a new computer would be my advice any time or money invested in a laptop this old is time and money wasted in my opinion.
     
  11. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #11
    Agreed, time to put the old girl to rest and get a new laptop.
     
  12. Amanda Ripanykhazova thread starter macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #12
    Thank you for your opinion, which appears to be annoyingly OT.

    FYI I do have a new Moore's-Law-defying touchbar MBP. It can't be used for many tasks, including word processing, because of pathetically bad trackpad design and even worse driver design . It is also not good for use with any normal modern camera, which makes ever increasingly large photo file sizes. Apple accidentally left the SD slot off it, presumably because they knew that either the ssd was too small or that no one wants to use an ultra lightweight notebook with a handful of dongles.

    That is why I am still reliant on the older one.

    --- Post Merged, May 8, 2018 ---
    At some stage this problem will be cured when someone starts a class action suit against Apple for the problems with the trackpad palm-rejection and highlight-disable problems.

    Apple will probably have to replace motherboards at some stage, and they have a cash pile of $100 billion to assist in this. This will not be a attornies-get-$50-million-users-get-10c-each lawsuit.

    Until then lots of us are stuck with using these older computers for all sorts of reasons
     
  13. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #13
    As far as I can tell the trackpad on the new 2016/2017 ones is just bigger and the machine works exactly the same as the older ones in that dept including drivers etc. It has all the same palm rejection etc that they’ve always had.

    If you use a multi purpose usb c dock you can solve all your dongle problems with one small lightweight $60 solution with all the legacy ports sad card slots and charging pass through you need or you can just replace the cables for your peripherals. It will still be a far faster lighter and more useful solution than your 2011.

    https://www.amazon.com/HooToo-Adapter-100W-Delivery-MacBook/dp/B072268Q68/ref=dp_ob_title_hi

    None of your reasons are anything but personal preference, that’s fine but you could have just returned it within the 14 day period and bought something else if you chose not to then that’s your choice as well, all the things you mentioned would be noticed within a few hours of use.
     
  14. dohspc macrumors 6502

    dohspc

    Joined:
    Jun 7, 2008
    Location:
    Plano, TX
    #14
    There were class action lawsuits but then Apple had the GPU replacement program for a short while and the lawsuits went away. I know it sucks but I doubt anyone is going to file a lawsuit over such an old laptop. I'm still using mine and it has had the GPU replaced twice. I just try to keep the GPU disabled until it dies again.
     
  15. Amanda Ripanykhazova thread starter macrumors newbie

    Amanda Ripanykhazova

    Joined:
    Apr 29, 2018
    Location:
    New York City
    #15
    The trackpad is so unnecessarily huge that significant numbers of users cannot now word process (you should try it for a while. Then you would see) and whereas I never had a problem with palm rejection before, now it turns typing into jibberish. And the highlighting feature rarely works properly. Maybe if you try to highlight, cut and paste 7-8 times it might work IF it doesn't send bits of text all over the page! Which is another party trick it does! No, it emphatically isn't even similar to the earlier pre-two level trackpad. Which worked.

    And being able to return within 14 days is only as good as the replacement. When there is no replacement, and you can't even replace for one slightly more compatible with modern digital cameras without being outrageously gouged, what is the use? Am I supposed to replace my whole system with some Dell?

    --- Post Merged, May 8, 2018 ---
    (I meant lawsuits on the new MBP! For Apple's promised trackpad driver. etc)
     
  16. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #16
    Well yes you should have returned it and bought a different computer if you dislike it that much that you don’t use it. That is surely the only sensible option instead of having a thousands of dollars paperweight.
     

Share This Page