Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Resolved No Sound Macbook6,1 OS X 10.5.8 Please help

Eva011

macrumors newbie
Original poster
May 30, 2016
5
0
NOTE:
I fixed this myself:

I upgraded from 10.5.8 to 10.6.0 (issue did not get fixed), I then ran updates and updated to 10.6.8 and that eventually fixed my problem. Updates where breaking for me so I had to run 1 update at a time otherwise my Mac would just crash on reboot.


_______________________________________________________________




Things I have tried:

Reboot
Safe boot
Command, Option, P, and R
Repair Permissions
Delete the BezelServices preferences file
Pluged standard headphones into the headphone jack
Turned Bluetooth on and off again
Reinstalled the 10.5.8 combo update


I opened the terminal and ran
Code:
ps -ef | grep audio

and the only two options are


Code:
0     169    1    0    0:00.1    ??    0:00.3   /usr/sbin/coreaudiod
501   327   314   0    0:00.00  ttys000  0:00.00  grep audio

I then ran
Code:
sudo killall coreaudiod

but coreaudiod won't die and stays running no matter what.



Mac OSX
Version 10.5.8
MacBook6,1




where do I go from here?
 
Last edited:

Eva011

macrumors newbie
Original poster
May 30, 2016
5
0
Comment

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
I've had this odd problem on a 10.5.x iMac. It's annoying as all get out, but a reset of the systemwide audio preferences usually clears it up. These files are in /Library/Preferences, all start with com.apple.audio and all end with .plist. (Oddly enough, this same fix works perfectly on 10.6.x through 10.11.x!)

You'll need to reboot after moving / trashing the files.
 
Comment

Eva011

macrumors newbie
Original poster
May 30, 2016
5
0
I've had this odd problem on a 10.5.x iMac. It's annoying as all get out, but a reset of the systemwide audio preferences usually clears it up. These files are in /Library/Preferences, all start with com.apple.audio and all end with .plist. (Oddly enough, this same fix works perfectly on 10.6.x through 10.11.x!)

You'll need to reboot after moving / trashing the files.


I tried this. I only have one file
Code:
com.apple.audio.AudioMIDISetup.plist
and it won't re-appear in the "prefrences" folder after I move it out and reboot. :C

Any other ideas? and thank you :)
 
Comment

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
It's been a long time since I last used Leopard. The files in question may very well live in a different place. Try the Audio folder inside /Library, if such a thing exists. Is there a folder called Audio inside Preferences? Look there too.
 
Comment

Eva011

macrumors newbie
Original poster
May 30, 2016
5
0
It's been a long time since I last used Leopard. The files in question may very well live in a different place. Try the Audio folder inside /Library, if such a thing exists. Is there a folder called Audio inside Preferences? Look there too.

The Audio folder that I have inside /Library is just filled with empty folders(I am new to mac are there "Hidden Files" like in Windows?). Except for the folder "MIDI Configurations" and that only has the file "Default.mcfg"

There is no audio folder inside of Prefrences sadly
 
Comment

Eva011

macrumors newbie
Original poster
May 30, 2016
5
0
It's been a long time since I last used Leopard. The files in question may very well live in a different place. Try the Audio folder inside /Library, if such a thing exists. Is there a folder called Audio inside Preferences? Look there too.

I fixed it but I thank you for the help :)
 
Comment

Ashka

macrumors 6502a
Aug 9, 2008
599
66
New Zealand
Just in case there's someone else looking :)

Mac OSX 10.5 & 10.6
From old notes >

USB Speakers not working
I deleted the com.apple.soundpref.plist from the MAIN LIBRARY -PREFERENCES - (not the users library).

Again in the same PREFERENCES folder I went into the AUDIO folder and deleted com.apple.audio.DeviceSettings.plist and com.apple.audio.SystemSettings.plist

~~~~~~~~~~~~~~~~~~~~~
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.