No sound when exporting iMovie project in HD (missing AAC codec)

Discussion in 'Digital Video' started by Poemmser, Jan 14, 2016.

Tags:
  1. Poemmser macrumors newbie

    Joined:
    Jan 14, 2016
    #1
    Hi there everyone!

    I am facing a problem when trying to export a finished project from iMovie as an HD video, it has no sound!

    Here's the scenario:

    MacBook Pro (Mid 2010), OS X El Capitan 10.11.2, around 90GB free space on the hard-drive, iMovie '09 (Version8.0.6)

    The project is finished in iMovie, ready for publishing in HD, when I preview it there, no issues with the sound. However, as soon as I try to export it and select HD as the output quality, the .mov file will open without playing any sound in Quicktime. If I select the lower quality "large" it gives me an .m4v file with sound. Even when I select "export with quicktime" and manually select the audio options there (256 Kbps AAC) the final version will not have any sound.

    A few months ago I worked on another project, also exported it in HD. When I check the file info of the earlier exported project vis-à-vis that of the current one, it will say "Codec: H.264, AAC" with dimensions "1280x720", when I export the current one it is missing the AAC whilst having the same dimensions.

    I am really no expert on such questions, but I have tried to look for option in iMovie, no luck. Maybe somebody has encountered a similar problem or knows why this does not work. I would greatly appreciate any help.

    Thanks in advance!!
     
  2. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #2
    There are a few issues with earlier versions of iMovie and El Capitan, which is why I'm staying with Yosemite. This could well be one of them.
     
  3. Edgar L. Owen macrumors newbie

    Edgar L. Owen

    Joined:
    Nov 13, 2017
    #3
    --- Post Merged, Nov 13, 2017 ---
    Dear Poemmser,

    There is a simple fix for this. In the project window double click on the clip that doesn't export sound to open its inspector window. Select audio and check 'Revert to original'.

    Now export in HD again and it should be fixed. File info should show the proper AAC codec.

    This worked for me in iMovie 9. I first tried clicking Normalize clip volume, and then denormalized it but I doubt you need to do this.

    You can view the results in my YouTube Deep Reality talks by searching YouTube on Edgar L. Owen

    Hope it works for you too. I spent days trying to solve this problem but never found this fix mentioned anywhere. Just tried everything & this worked!

    Best,
    Edgar L. Owen
     
  4. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #4
    As it was nearly two years ago, I guess he may have solved it by now.
     

Share This Page