Resolved Odd issue with download speeds (DELL server)

Discussion in 'Windows, Linux & Others on the Mac' started by keysofanxiety, Aug 4, 2016.

  1. keysofanxiety, Aug 4, 2016
    Last edited: Aug 4, 2016

    keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #1
    Hi all,

    Not sure if this is the right place to post for a pure Windows machine, but I'm properly stumped on this one and I was hoping somebody could help!

    I have an old DELL OptiPlex 760 on Windows 10 that is permanently plugged into Ethernet as a seedbox/game(s) server. C2Quad Q8200, 8GB RAM, 120GB SSD/1TB HDD.

    The network adapter is a Gigabit Intel 82567LM-3, currently showing as driver version 12.12.50.6, dated 20/03/2015. Tried a number of other drivers too. Power management is disabled and power settings are on High Performance/no sleep. Hardware IDs are:
    PCI\VEN_8086&DEV_10DE&SUBSYS_027F1028&REV_02 and
    PCI\VEN_8086&DEV_10DE&CC_020000.

    Here's the issue: download speeds won't go beyond 40MB/s, through either Speedtest, FTP downloads -- anything. However the upload speed has no issues?!! No throttling from the ISP or limits.

    123.png

    Yet as soon as I plug my 15" 2012 MacBook Pro in via Ethernet, it gets 1000/1000 speeds without a hitch?! Same with my housemate's 2011 17" and every other Mac we've had through the doors.

    I just don't get it. Tried manually setting Speed & Duplex from Auto Negotiation to 1.0 Gbps Full Duplex, everything else I can think of... ran it by the IT guys at work too. They haven't the foggiest.

    Can anybody hypothesise as to any Windows 10 settings that could be throttling downloads but not uploads? I've disabled all of the snooping tools that Microsoft have kindly bundled. Router is RT-N66U. Already changed reservable bandwidth settings in gpedit.msc.

    @Weaselboy, hope you don't mind me tagging you if you have any ideas? :)

    Thank you for any suggestions anybody may have! I'm completely stumped so I'm more than happy to entertain any troubleshooting you feel is necessary.

    Best wishes.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    No problem, but sorry... I have little clue since I have not touched a Windows machine in years.

    I know Windows has a stripped down safe mode boot similar to OS X where it runs with no third party drivers. Maybe try that to eliminate third party software as the issue?
     
  3. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #3
    Good thinking! I'll give that a go when I'm home (Win 8.1/Win 10 predictably doesn't allow restarting in Safe Mode remotely :rolleyes:)
     
  4. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #4
    A few things with uncertain relevancy pop to mind.

    You didn't mention what cat cable you were using. I'm sure you know the proper one.

    Disable Windows Update Delivery Optimization.

    Not sure about W10 but have used in W7 (the machine used Windows Public network connection) -- disable Windows TCP Scaling Heuristics.

    Uninstall and reinstall the adapter.
     
  5. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    Hey Rshrugged!

    Thank you for taking the time to reply :) Cat5e I think; though I've tried swapping with a other cables too that were tested as having the proper throughput.

    I ran that command and tested -- netsh interface tcp set heuristics disabled. Same outcome.

    I also tried netsh interface tcp set global autotuning=disabled but then it consistently went down to under 200, though with same ~900 upload. So possibly there's something to do with the global autotuning as the download speed was always consistent until that was changed! I'll look into it further and see if there's anything else that can be changed with those settings.

    Thank you again for your suggestions! You've pointed me in a direction I wouldn't have otherwise gone. :)

    EDIT: yep, just tested same server consistently.

    netsh interface tcp set global autotuning=disabled gets 200/900.

    netsh interface tcp set global autotuning=normal gets 350/900. :confused:
    --- Post Merged, Aug 4, 2016 ---
    Just want to thank you again for this suggestion! Wish I could upvote you twice. Went through a few things and then when setting netsh int tcp set global autotuninglevel to experimental, the speeds went up faster than they ever have!

    Still not full download speeds, but this stupid Windows box has never, ever, ever hit beyond 400. So it has to be something to do with those settings. Thank you again! I'll keep looking into this.

    test2.png

    All the crap I tried (applied, speedtested, went onto next command) is below if anybody cares.

    Code:
    C:\Windows\system32>netsh interface tcp set global autotuning=disabled
    Ok.
    C:\Windows\system32>netsh interface tcp set heuristics disabled
    Ok.
    C:\Windows\system32>netsh int tcp set global chimney=disabled
    Ok.
    C:\Windows\system32>netsh int tcp set global dca=enabled
    Ok.
    C:\Windows\system32>netsh int tcp set global rsc=enabled
    Ok.
    C:\Windows\system32>netsh int tcp set global autotuninglevel=disabled
    Ok.
    C:\Windows\system32>netsh int tcp set global autotuninglevel=experimental
    Ok. 
     
  6. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #6
    Ah, *splash,splash*(typing through the drool induced by your speed), you're welcome. Glad to help; especially nice to help someone who contributes as much as you do.

    Thanks for posting the useful info. Will keep watching this thread. :)
     
  7. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #7
    Did one more command: netsh interface tcp set global autotuning=experimental

    No idea how that's different to netsh int tcp set global autotuninglevel=experimental :D

    However it's made such a great difference! I'm more than happy with this seeing as it wouldn't ever, ever, ever go past 400.

    loveya.png

    Thank you, thank you, thank you again for pushing me in the right direction. 100% wouldn't have been able to sort this without your assistance.

    Please, genuinely, PM me if you're ever in Newcastle upon Tyne in the UK. I'll feed you Guinness, Tanquaray, whisky -- whatever your poison is. Thank you again :) :)
     
  8. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #8
    Very cool. :)
    I'll keep your invite in mind; ta.
     

Share This Page