iPad Pro Odd mail fetch bug on new iPad

Discussion in 'iPad' started by ThatSomeone, Apr 17, 2016.

Tags:
  1. ThatSomeone macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #1
    Hello everyone, I hope your sunday is great so far!
    I bought myself a new iPad Pro 9.7" barely 2 weeks ago. So far I'm pretty satisfied by it, but I've discovered a rather annoying bug with fetching mails..

    I noticed shortly after my purchase that the mail wasen't being fetched automaticly and I had to open the mail app every single time in order to check for new mails. After trying rebooting a few times, a hard reset and following Apple's troubleshooting for mail without result, I decided to switch around the settings and then switch them back to normal, and to my surprise it solved it! But now after a few days of normal fetching, the problem has occured once again and my previously mentioned solution doesn't help anymore..

    I don't belive this is account related as I have 3 different accounts linked with 2 different providers and NONE of them fetch correctly.. :(

    Does anyone else reconize this behaviour?
    Thanks!
     
  2. gobikerider macrumors 65816

    gobikerider

    Joined:
    Apr 15, 2016
    Location:
    United States
    #2
    Do you have push email setup in settings or is it set to fetch. If it is set to push the email, then your account is probably not happy with email honestly I gave up on built in mail app I would switch to outlook app works perfectly with multiple accounts from exchange to gmail and everything in between and you can add document accounts like google drive or Dropbox so that you can easily attach files when sending emails right from the app.
     
  3. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #3
    One of them is set to push, and that's the iCloud one. The other 2 are Gmail accounts set to fetch since Gmail no longer supports push(I'd probably stick to fetch even if they added it again). My old Air never did this and my iPhone 6 has no issues at all...
     
  4. gobikerider macrumors 65816

    gobikerider

    Joined:
    Apr 15, 2016
    Location:
    United States
    #4
    Gmail has no problem with push on the mail app.
     
  5. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #5
    Really, I thought they disabled push for iOS devices in 2013? Or do you mean the Gmail/Exchange app?
     
  6. gobikerider macrumors 65816

    gobikerider

    Joined:
    Apr 15, 2016
    Location:
    United States
    #6
    Push should work normally in the iOS Mail app with a gmail account it has for me and I only stopped using it a month ago.
     
  7. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #7
    Huh, I haven't seen the option to enable push for Gmail for years now... I found this article about it. And I can't see the option on either devices, just fetch or manualy...
     
  8. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #8
    Glad to see I am not the only one. I started this thread about the exact same problem at:http://forums.macrumors.com/threads/fetching-mail-problem.1965726/

    I have never had this problem and always used fetch every 15 minutes on my email account for years and until I got my iPad Pro unit never seen this. When I wake in the AM and check mail it will say mail not check since yesterday!

    This problem can not be widespread as it seem to affect only a few of us. My previous post got little help or suggestions so I will be watching here. I have deleted my email account and re-entered it several times.

    Just seem my iPad Pro will not fetch every 15 minutes like my previous iPads and it is really weird that BOTH of my iPPro units are failing to do it and one was set up as new.

    Crazy!
     
  9. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #9
    It sure is weird! Believe it or not, but it started to fetch again barely 2 hours ago:confused:
    I'll see if it makes it through the night. Interesting to hear that deleting and re-adding the accounts plus restoring doesn't help, then I could cross them off my list of last-resort-troubleshooting. I've actually submitted a bug report about this 2 months back when I noticed my phone did the same.. Although it didn't want to fetch AT ALL until I rebooted it, luckily I haven't seen it the past weeks. I actually just had a look and the report is still marked as "Open".. I've also reported it when I spoke with AppleCare regarding it. It MAY be widespread as some people either don't contribute to these threads, or they don't bother looking it up at all.

    Another thing that's not related to the mail issue, is that I've had quite a lot of other problems with the new iPad since I got it. I NEVER experienced these many when I last got my Air back in the iOS 7 days, if any at all... It's a pretty long list, but for example today I went to the Apple Store to buy a Smart Cover for it. And on my old Air I used to have a problem that occurred immediately after updating to iOS 9, was that the lock sound was cut off 3/4 times I locked it with the Smart Cover. And even with this new device it's STILL occurring even after the upgrade! I really don't like the direction Apple is heading...
     
  10. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #10
    Funny you should mention your iPhone but my 6S+ has the same email fetch problem from time to time and never had it prior to my iPad Pro ownership. This is really freaking crazy when you think about it. How could BOTH of my iPad Pro 9.7 have a fetch problem and how could it, on occasion, do this to my phone.

    Strange indeed.
     
  11. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #11
    Yeah this is really REALLY strange... It HAS to be a iOS bug, presumably introduced in 9.2.1. I'm thinking about submitting another bug report or calling the support again tomorrow. It'd be really interesting to see what causes this..
     
  12. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #12
    If it were a bug we should be seeing others with the same problem but are not. I thought it was just me until my 9.7 did it when started as new with no backup.

    Anyway best of luck to both of us.
     
  13. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #13
    It's just so strange that only a few of us are affected... Hopefully the next iOS version makes the new 9.7" more compatible with iOS since I've seen other issues with it after the launch. I found this aswell, but it's pretty hard to search around the Apple Discussions since it doesn't list new post to 'old' threads. I'll submit another bug report later on today, I'd suggest you and everyone else with this issue to do the same for increased chance of the engineers to notice it. And the we can only hope for it to be fixed..
     
  14. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #14
    I files a bug report yesterday. Will likely do it again today.
     
  15. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #15
    I just filed mine aswell. I'm also glad to say that it's been fetching normally the past 24 hours, but since it might aswell stop out of the air once again, I'm not getting my hopes too high..
     
  16. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #16
    And of course it stopped again when I posted that and filed the report:mad:
     
  17. Serban Suspended

    Joined:
    Jan 8, 2013
    #17
    i have this issue on my ipad air 2 for several days
     
  18. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #18
    Interesting, well mine started to work again after 1:30 hours... This is ridiculous.
     
  19. bradbomb macrumors regular

    Joined:
    Jan 7, 2002
    Location:
    Los Angeles, CA
    #19
    Gmail only had push if you had it setup as a Microsoft Exchange account, which only currently works with Google Apps accounts now. Gmail has never had native Push with the iOS app. To get native Gmail push, you need to use the Gmail or Inbox App.
     
  20. dumastudetto macrumors 68020

    Joined:
    Aug 28, 2013
    #20
    This is why I use iCloud mail. It just works across all my devices.
     
  21. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #21
    I mentioned above that my iCloud account is affected aswell(Not sure if you were referring to me or someone else).
     
  22. Newtons Apple macrumors Pentium

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #22
    The problem is not the mail provider, sometimes both of my iPPro 9.7 just quit fetching mail. I regularly wake in the morning to check mail and at the bottom it will say something like "mail last checked at 9:30pm yesterday"!

    One iPad was set up as new and the other was restored from my previous iPad Air 2.

    To this date they fail to fetch every 15 minutes like they are set to do.
     
  23. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #23
    Indeed. Mine has gone even weirder now, it stops and starts to fetch automatically even more frequently now, but most of the time it refuses. And no response to the bug report either... This needs to be fixed ASAP, I'm missing a lot of important mails..
     
  24. lakerchick4life macrumors 6502

    Joined:
    Oct 14, 2007
    #24
    I have outlook as my email provider..I notice sometimes it doesn't say I have new mail right away, sometimes it does..the weird thing is(I even noticed this with my iPad Air 2) is that when I go into edit to search for a particular set of emails sometimes the mail app will go gray and I have t close out the app and open it again for me to be able to work with it again
     
  25. ThatSomeone thread starter macrumors regular

    ThatSomeone

    Joined:
    Jan 9, 2016
    Location:
    Here, where else?
    #25
    That doesn't sound good... I've never experienced it before though.
     

Share This Page