OS X El Capitan on Unsupported Macs

Discussion in 'OS X El Capitan (10.11)' started by TMRJIJ, Jun 5, 2015.

Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
  1. Rocko99991 macrumors 6502a

    Rocko99991

    Joined:
    Jul 25, 2017
    #1101
    I had a problem doing my 2009 Mac mini. Once I installed High Sierra on the hard drive, I couldn't get back into the installer USB to do the post install. It somehow corrupts the installer USB. I redid the installer USB on another computer and was able to use that to complete post install work. Not sure If this is happening to others but may be worth creating 2 usb's prior to install just in case.
     
  2. Baboo85 macrumors newbie

    Baboo85

    Joined:
    May 5, 2018
    #1102
    Even MacPostFactor doesn't work.

    If I try to install directly on the disk I get error code 1. If I try to use an external usb drive, the drive shows up on boot but it boot back on Lion installed on the internal hard disk.

    This little **** won't let me install anything ffs...
     
  3. hiroshi.rio, Oct 4, 2018
    Last edited: Oct 7, 2018

    hiroshi.rio macrumors newbie

    hiroshi.rio

    Joined:
    Sep 8, 2017
    Location:
    Rio de Janeiro - Brazil
    #1103
    I was trying to install 10.11.0 with MacPostFactor but I am stuck on installing OSX window. Everytime it reboot and do the same (Macbook 2.1).

    [update]: I read all thread unfortunately only method 3 will work.
     
  4. Luque34 macrumors newbie

    Luque34

    Joined:
    Oct 11, 2018
    #1104
    Hi! I have a MacBook 4,1 with the core 2 duo 2,4ghz, and upgraded 4gb of ram. I would like to throw an sad in this machine, but i've seen that one of the pre-requisites is to have mac os x lion installed. The thing is that the USB that I had with mac os x lion got erased, so, is there any way to install it without having mac os x lion preintalled?
     
  5. hiroshi.rio macrumors newbie

    hiroshi.rio

    Joined:
    Sep 8, 2017
    Location:
    Rio de Janeiro - Brazil
    #1105
    OS Lion or above. It is just a minimum OS requirement to install 10.11.
     
  6. KeithJohn macrumors member

    KeithJohn

    Joined:
    Aug 18, 2015
    Location:
    Glasgow
    #1106
    Hi Guys, Security Update 2018-004 for El Capitan came up on my Mac Pro 2.1, I guess I should give this a miss as it will probably destroy the boot up? Any thoughts guys?
     
  7. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #1107
    Just "Hide" it and forget it, cause the update will break your system.
     
  8. barcode_turk macrumors member

    barcode_turk

    Joined:
    Sep 24, 2018
    #1108
    dude it's to bad to use macbook 4,1 cause the VGA is problem on this macbook so the only you can install 10.7.5 officially but with macpostfactor you will be able to install 10.10.5 that is the latest version of yosemite on the other hand el capitan is not math with this version of macbok dont try to install it on macbook 4,1
    --- Post Merged, Oct 22, 2018 ---
    did you disable SIP ?
     
  9. TMRJIJ thread starter macrumors 68030

    TMRJIJ

    Joined:
    Dec 12, 2011
    Location:
    South Carolina, United States
    #1109
    Minor Backend Changes are happening with the OS X Hackers server for the next 24 hours. Support Tickets and other features are not working. Downloads and the AutoPatch might be affected as well.
     
  10. mocteo macrumors newbie

    mocteo

    Joined:
    Jul 15, 2018
    #1110
    Hello, i installed el capitan on a mac pro 1,1, but it crash everytime, even when i do nothing, like 1 or 2 minutes after the boot. I changed graphics card and ram configuration several times but it wont work, it’s the same
     
  11. jbarley macrumors 68040

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #1111
    Sounds like maybe a Hardware test might be help.
    check this link for instructions, and scroll down to find the download for your MP1,1.
    https://github.com/upekkha/AppleHardwareTest
     
  12. doynton macrumors 6502

    Joined:
    Oct 19, 2014
    #1112
    I did exactly this with mixed results.

    I have a MacBookPro2,2 (a Core2Duo T7400 with 3GB RAM) running 10.11.1 just fine thanks to the third method. I then upgraded to 10.11.6 yesterday and it would immediately shut down (processor too old to have necessary instructions I suppose)

    I replaced /System/Library/Kernels/kernel from the version downloaded yesterday (11.4MB dated 22 Jun 2018) with the original version (10.7MB dated 20 Nov 2015).

    It now boots on 10.11.6 and all built in apps work (Safari, Terminal etc) and with the exception of MacsFanControl most third party apps work. Everything without exception downloaded from the App Store fails with the Kernel not providing correct security response.

    I'd appreciate it if someone running 10.11.6 on a C2D could upload /System/Library/Kernels/kernel - ideally from 2017/early 2018 or whenever they brought in the new CPU requirement.

    If simply replacing the kernel file is a bad idea and everyone thinks I should reinstall I can - but I don't know what version to use - not the current one certainly.
     
  13. MacMan737, Nov 17, 2018
    Last edited: Nov 17, 2018

    MacMan737 macrumors newbie

    Joined:
    Mar 3, 2014
    #1113
    Been struggling to get anything to load on my MacBook 4,1 2.4GHz 2GB RAM.

    I've tried macOSExtractor, MacPostFactor, removing the PlatformSupport.plist, and all that good stuff with both Mavericks, and El Cap. Going to try Yosemite next. Error 1 on MPF when doing the "update" on device method. When I chose clean install, it screwed over my Lion install (Not a big deal). I'm not really sure what is entirely going on with it. I've done work with installing Sierra/High Sierra/Mojave on unsupported Macs with dosdude1's tool and they've always worked great, and I know the idea here is pretty much the same, but I'm not too sure what's going on. Does anyone have an idea of what I could do?

    Update: Yosemite works. Wifi/Graphics/Audio are all working nicely. I really need to get 4GB of RAM next.
     
  14. osafo macrumors newbie

    Joined:
    Dec 4, 2018
    Location:
    Durban, South Africa
    #1114
    This can be changed easily. Looks like your mac was sleeping.
    --- Post Merged, Dec 4, 2018 ---
    Hi MacMan737

    which machine are you trying this on? Check my breakthrough with yosemite on macbook 4,1 early 2008 at http://enosafo.website2.me
    --- Post Merged, Dec 4, 2018 ---
    can anyone assist with el capitan on macbook 4,1 early 2008?
     
  15. Yojx21 macrumors newbie

    Joined:
    Dec 26, 2017
    Location:
    Dijon, France
    #1115
    Hi,
    Back in the business i have tryed to install El Capitan on an iMac6,1. I noticed that this model is not in the list of compatible computers, is that normal ?
    Anyway, is used first method to do it. I have replaced the two boot.efi (with both boot32.efi and boot.efi provided by OS X Hackers Patch Files ) and blessed the disk.
    The problem is that when i try to boot on my el capitan install partition in verbose mode i end with a "root device uuid is XXX". I have left it like that 30 mins to see if something else happen, but it's stand like that...

    Any idea of what to do ?
     
  16. osafo macrumors newbie

    Joined:
    Dec 4, 2018
    Location:
    Durban, South Africa
    #1116
    --- Post Merged, Jan 31, 2019 ---
    Hi All, I tried all the options but did not work until I came up with a plan that circumvented the whole process and it worked perfectly for me. my macbook 4,1 early 2008 2.1 ghz processor, 4gb ram is breathing now with el capitan. macpostfactor and the rest have all failed. Will post details soon here and on my website http://enosafo.website2.me
     
  17. fanfzero macrumors member

    Joined:
    Oct 8, 2016
    #1117
    I just wish mountain lion's graphic acceleration could be achieved on those macbooks someday
     
  18. wpan008 macrumors newbie

    Joined:
    Mar 7, 2019
    #1118
    Trying to following the macOS Extractor (1.43) guide to install El Capitan on my MacBook Pro 2,1 late 2006 17 inch. But B4 in the guide is "(for non 64 bit Macs) Unlock and Replace the boot.efi files located in /System/Library/CoreServices and /usr/standalone/i386 with the copy provided in /Applications/OS X Hackers Patch Files/Boot EFI/ or from here". However, there is no Boot EFI folder under path:/Applications/OS X Hackers Patch Files/. Does this step still apply?
     
  19. jackluke, Mar 10, 2019
    Last edited: Mar 11, 2019

    jackluke macrumors 65816

    jackluke

    Joined:
    Jun 15, 2018
    #1119
    @TMRJIJ , I have a MacbookAir1,1 I guess this is an EFI64 capable, even if reported as EFI32 machine so it should boot with stock El Capitan boot.efi and kernel , I know enough how to play with kextcache, chmod, chown and many others unix/OSX terminal commands. I do have an external USB SSD with El Capitan 10.11.6 clean installed, I do have already modified the /L/Pref/SysConf/com.apple.boot.plist to allow unsupported machine (-no_compat_check), kext invalid signature (kext-dev-mode=1) and so on. I don't need to disable SIP since it's an external disk I can operate on system folders from another mac.

    When I attempt to boot with verbose mode (I use Refind bootloader), I can pass many verbose lines even the Wifi kext, until I get the known "still waiting for root device", so I assume that my current untouched El Capitan drive doesn't have some legacy kext installed to complete booting on MacbookAir1,1 .

    Now my question is: which are the minimum kexts I need to replace onto my ext USB clean El Capitan inside /S/L/E/ to allow booting ?

    I guess they are some AHCI, ATA and USB legacy kexts needed, but could you point exactly which ones?
    Thanks.

    edit:
    I found your website and using the link provided in all-kexts, I got El Capitan 10.11.6 clean working from external USB SSD (pre-installed from a supported mac) on MacbookAir1,1 (Merom cpu SSE3, 2 Gb DDR2 onboard soldered RAM) , I add just a few notes:

    - I used the stock El Capitan 10.11.6 kernel and its stock boot.efi (64bit capable on a EFI32 machine)
    - replacing only some of the kexts in your zip package (especially those related to IOUSBFamily) fixed the "still waiting for root device"
    - Bluetooth is working (but with other IOBT legacy kext)
    - Backlit keyboard with F5/F6 is working and trackpad (with no pressing zone but one physical button) full gestures is working
    - IR Blaster is working with apple remote
    - Facetime's iSight is working (I guess with the legacy IOUSB* kext)
    - Audio and microphone are working with HDA legacy kext
    - Wifi Airport (0x14e4 , 0x8B) worked OOB with the stock El Capitan IO80211Family.kext
    - Using the GMAX3100 64 bit kext (I guess token from Lion 10.7.5) I got of course no OpenGL acceleration and no brightness control, however with only FrameBuffer system is fairly usable
    - apparently "sleep" is working, and I got even the smooth fade-in/out effect

    I have also enabled the AirDrop icon in Finder through Terminal with:
    defaults write com.apple.NetworkBrowser BrowseAllInterfaces -bool TRUE; killall Finder
    AirDrop is working but unluckily it is shown as black screen, that's because maybe it requires graphics acceleration (OpenGL) to render that window.
     
  20. jackluke, Mar 12, 2019
    Last edited: Mar 12, 2019

    jackluke macrumors 65816

    jackluke

    Joined:
    Jun 15, 2018
    #1120
    @TMRJIJ thanks for your MacPostFactor tool, I have other question regarding MountainLion on MacbookAir1,1 , I have tried to replace the boot.efi (only i386) renaming the boot64.efi you provided in your tool and it still boots but I don't get the OpenGL acceleration but only FrameBuffer. I get instead OpenGL acceleration with GMAX3100 32 bit kexts and boot.efi 32 bit.

    Is possible to achieve booting the GMAX3100 64 bit kext with full QE/CI ?

    I noticed also in your packages there is a folder GFX_ML that contains OpenGL and OpenCL frameworks (probably legacy previous OSX), are maybe these required to be replaced to achieve QE/CI with GMAX3100 64 bit kext ?

    edit:
    Tried using GMAX3100 64 bit kext (from SnowLeopard the last compiled by apple) both with stock and/or downgrade the OpenGL OpenCL frameworks but no QE/CI and also downgrading those frameworks OSX freezes when LaunchPad is opened, so better staying on 32 bit (i386).
     
  21. Macbook 2.1, Mar 24, 2019 at 8:17 AM
    Last edited: Mar 24, 2019 at 8:33 AM

    Macbook 2.1 macrumors newbie

    Joined:
    Yesterday
    #1121
    --I have a problem with : During the AutoPatch installation. Select the USB or partition (Installation Drive) that you want as the installer. (No, this is not the Mac OS X Install ESD) WARNING: DO NOT SELECT YOUR CURRENT PARTITION (i.e Macintosh HD) I run the AutoPatch, choose a second partition and click ok. Then it goes for about 5-10 seconds and then it says The Installation Failed, that it encountered an error.
    --But when i try MacPostFactor for el capitan, everything goes fine until i choose witch partition i want in the El capitan installer. It goes fine for like 1 minute, then it restarts, starts over, restarts again. Its in a loop.
    My Specs: Macbook 2.1
    Intel core 2 duo 2GHz
    4GB RAM
    320 HDD
    10.7.5 Lion
    GPU: GMA 950 64 MB
     
Thread Status:
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Share This Page