OSX Clock Showing Wrong Year - MessageGate?

Discussion in 'macOS High Sierra (10.13)' started by AdamskiUK, Mar 22, 2018.

?

How has it taken Apple this long to sort out such a glaring issue?

  1. Yes

    0 vote(s)
    0.0%
  2. Yes

    0 vote(s)
    0.0%
  1. AdamskiUK macrumors regular

    Joined:
    Sep 6, 2011
    #1
    Hi all,

    This crap with messages arriving out of sync is well known by now and some people have suggested that it's an issue with a device's date/time functions. Lo and behold, my OSX Menu bar clock displays the correct time, day, and date, but when I click for the year, I'm told it's 2015. I've reset the NVRAM to no avail.

    Messages shows that things are coming in in 2018 and my Time/Date Settings panel (auto-tuned to clock & time-zone servers) show 2018, also. Changing the settings to manual does jack all.

    This messages bug is really starting to **** me off now. It's one of the biggest reasons I stick to the  ecosystem and if it isn't fixed before my next phone update, I'll really consider shifting to an S9.

    Any suggestions?
     
  2. AdamskiUK thread starter macrumors regular

    Joined:
    Sep 6, 2011
    #2
    I just spent 2 hours on Apple support chat and I've solved the message order problem (but other problems exist).

    Try changing your language/region settings in MacOS preferences to a different English-speaking country & back to your own again.
     

Share This Page