Password autofill didn't work - How I fixed it

Discussion in 'iPad Tips, Help and Troubleshooting' started by jagooch, May 20, 2018.

  1. jagooch macrumors 6502

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #1
    I migrated my 100's of Web logins from 1Password into Keychain yesterday ( quite a long process! ) using my Mac, and then tested it on my iPhone.

    Then I tested it on my iPad by spot-checking logins that I had added.

    Problem 1) none of them were there.
    Fix: I fixed that by logging in/out of iCloud on my iPad. Afterwards, the newly added accounts were there.

    Problem 2) I navigated to Macrumors and tested to see if it would prompt me to use the stored password. Nothing.
    I navigated to Macrumors on my iPhone, and it prompted me to use the stored password.
    The problem turned out to be that I was using a Smart keyboard with shortcuts disabled in Keyboard settings.
    Fix: I turned shortcuts on and tested the login again. The shortcut bar appeared and prompted me to select which credentials I wanted to use to login.

    WIN!
     
  2. gobikerider Suspended

    gobikerider

    Joined:
    Apr 15, 2016
    Location:
    United States
    #2
    How did you do said migration...
     
  3. jagooch, May 29, 2018
    Last edited: May 29, 2018

    jagooch thread starter macrumors 6502

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #3
    it wasn’t easy.

    Export 1password logins to csv
    install old, pre-quantum version of firefox ( I think that it was version 56)
    reformat data to meet firefox data format requirements
    import passwords into firefox
    import firefox passwords into Safari
     

Share This Page