Paste-behaviour in Pages

Discussion in 'Mac Apps and Mac App Store' started by VSG, Jun 16, 2017.

  1. VSG macrumors regular

    Joined:
    Aug 9, 2014
    #1
    Hi there,

    I've been extensively using the iWork-suite lately in order to make it my supplement for my expiring Office365-subscription soon.

    However, I've come upon a problem regarding the copying/pasting of text in Pages that I can't seem to work out.
    Issue is this: I have a document that is written in plain text, no special style, nothing italic, bold or underlined. Then I have a different document where I want to copy specific words right into the text of the first document. That second document is indeed specially formatted (italic text). However, when the copied text from the document written in italic is pasted into the first document, Pages keeps the existing format there and turns the italic text to normal text.

    As I said, the things I copy are just a few words each, not whole paragraphs.
    I can't seem to find an option to keep the original style when copying just a few words into the middle of an existing text.

    Anyone who can help?
    Thanks in advance!
    Best regards,
    VSG
     
  2. HobeSoundDarryl, Jun 16, 2017
    Last edited: Jun 16, 2017

    HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #2
    This problem is usually the other way: the person wants the content pasted into a Pages document to match the font style already in that document.

    Are you choosing the "Paste" option in Edit (menu) or "Paste & Match Style"? The latter is the one to do what it seems to be doing for you. The former is the one that should paste in a copy of the original (preserving the original formatting).

    Are both documents opened in Pages or are you perhaps copying from something else (maybe a Word document?) If both are in Pages and you can't find a solution, perhaps copy & paste the other way? In other words, copy your new content into the document already formatted replacing old text you don't want but not overwriting the already formatted content you want to preserve "as is"?

    Maybe the formatting is based around copies from websites and thus preserved in Word's HTML capabilities, which might be stripped when you are pasting into a Pages document. Something else to try if you ARE opening both documents in Pages is to first save the document in Pages format (if it's a Word doc), close and re-open it in Pages. If the formatting is still correct, try copy & pasting the desired sections into the new Pages document now (choosing "Paste," not "Paste & Match Style").

    Yet another option. If it's Word doc, try "save as" and choose the "RTF" option. Then open that in Pages and try a copy & paste.
     
  3. neutrino23, Jun 16, 2017
    Last edited: Jun 16, 2017

    neutrino23 macrumors 68000

    Joined:
    Feb 14, 2003
    Location:
    SF Bay area
    #3
    I believe this has to do with how the text is formatted on the clipboard. I did some testing and was able to duplicate your issue. There is a workaround, though I have no solution.

    It seems that Pages is rather picky about the format of the text on the clipboard. I tried creating text in a text editor, Tex-Edit Plus, and then copying it to the clipboard.

    Before pasting to Pages I go to the Finder and use Edit/Show clipboard to view the clipboard.

    If I just use command-I to make the text italic then the Finder shows it as RTF but does not render it in italic.

    If I use the Font tool and choose an actual italic font then the Finder renders the clipboard in italic.

    However, no matter how I format the text in Tex-Edit Plus, Pages still ignores the style and matches the style of the existing document.

    If I format text in Pages it successfully can be copied to Tex-Edit Plus with formatting.

    If I use TextEdit to create some text and format it it can be copied with formatting to Pages.

    My guess is that there is a proper way to format text for the clipboard and not everyone follows the rules to the letter. It seems like Apple products know how to follow these rules, others might not.

    A clue to this is that I can make text in Tex-Edit Plus using Geneva (no italic font installed on my computer) and then make it italic in the document. If I copy this to TextEdit it recognizes Geneva but ignores the italic setting. In TexEdit I cannot set Geneva to italic because it doesn't exist on my computer.

    If I try another font, Gill Sans, which has an italic form on my computer, I can copy this to Pages and Pages ignores this and matches the document settings.

    If I paste this (Gill Sans text) to TextEdit, TextEdit recognizes this and displays it properly. If I now select the same text in TextEdit and copy it to Pages the text is correctly pasted in with Gill Sans italic. Somehow, TextEdit has formatted the same information in the clipboard differently so that it can be recognized by Pages.

    The upshot is that I think your original source doesn't properly format the text and then Page refuses to even try to apply formatting that is not properly formatted.

    It is a minor pain, but a workaround would be to keep an open document in TextEdit, paste it into that first, select it and copy it then paste it into Pages.

    The fastest way would be to have a blank document, then do command-V, command-A, command-X, which formats the text and clears the document for the next use. Or you could copy the entire document and paste it into TextEdit and work from that.

    What is the formatted document? Is it a Word document? If so, open that in Pages in then you can copy easily from one to the other. Maybe you could open it in TextEdit and then you could easily copy with formatting.


    Edit: I just found that Mail works the same way. I can paste into a Mail document I'm composing and it formats properly. If I now select and copy that text I can successfully paste this into a Pages document with formatting. Seems like this is system wide behavior. Maybe Pages does this on purpose in order to not put corrupted text into documents which are considered more valuable than transient messages and text?
     
  4. VSG, Jun 16, 2017
    Last edited: Jun 16, 2017

    VSG thread starter macrumors regular

    Joined:
    Aug 9, 2014
    #4
    There is an even easier way to reproduce the issue: I started up Pages and created a new document. I then copied the "Lorem ipsum"-text from a website (Safari) into TextEdit and from TextEdit into Pages.

    In Pages I made a copy of the "Lorem ipsum"-paragraph and formatted the second paragraph in italic. Then I selected just two words from the second paragraph and copied them into the first paragraph. Please see the screenshot how it looks before pasting.

    Now, no matter where you paste the italic "Lorem ipsum"-text into the first paragraph the outcome will be Pages adjusts the formatting to plain and doesn't keep italic.
    It is the same with text that was solely written in Pages and is not copied over from a website. It is as if Pages decides since the rest of the surrounding text has this formatting, the text you paste there needs to have it as well - which is simply not the case and not helpful in any way. Undo doesn't help either, the only possible way is to reformat the pasted text the way you want it.

    As I said, any help is greatly appreciated. This behavior is driving me nuts and costing unnecessarily more time than it should.

    PS: If I look at this support-article, I suppose it's a bug. It shouldn't be that way, obviously.

    pages_test.jpeg
     

Share This Page