Possible bootcamp wifi driver bug w/ 2016 MBP

Discussion in 'Windows, Linux & Others on the Mac' started by scotty588, Nov 14, 2016.

  1. boxxyfied macrumors newbie


    Dec 29, 2014
    +1 to all accounts. I didn't have anything to add until this tin foil theory:

    I am using a smaller Moto modem with older airport express as router. 2016 tbMbp running boot camp on external t3. Same issues on 2.4 and no connectivity on 5- I thought it was my set up.

    I'm out and about and needing to connect to a wifi network and as an xfinity customer they let me mooch any xfinitywifi. Log in. No disconnect. Curious so I Tried at home. Neighbors have xfinity, same deal. Not one disconnect. 2 more times different areas and same result.

    So yea- I'm just wondering if maybe it's not a driver issue but a router setting? I wonder if Everyone from this thread was using their own router or those that volunteered the models just seem to follow same issues. could different routers settings be the cause compared to the ones companies like xfinity offer?
  2. dbackeus macrumors newbie


    Feb 7, 2017
    Actually turned out my WiFi issues were fixed after running Apple Software Update.

    I was wrongly assuming that the updates would already be pre-installed since I did my initial bootcamp installation about two weeks after those updates were released.
  3. foursided macrumors newbie

    Feb 8, 2017
    Las Vegas
    I installed all available updates. Still non functioning.
  4. mrblog47 macrumors newbie

    Dec 16, 2009
    --- Post Merged, Feb 17, 2017 ---
    Hi, I'm having the same issues connected to a Ubiquiti network also with my MacBook Pro 15" 2016. Haven't read through the whole thread at the moment but just wanted to comment first to say that I seem to have the same network setup as you and am having the same problems. Also seemed to be creating similar problems for other windows users on the network.
  5. case_break macrumors newbie


    Mar 2, 2017
    Experienced the same problem as all of you. The latest Windows 10 updates within Bootcamp seem to have solved the problem, for now at least.

    I was losing connection once every 5 monutes, but have remain connected for over an hour now.
  6. Michelinu macrumors regular


    Dec 27, 2013
    Sant'Antioco, Sardinia (Italy)
    Same problem here. After few tries I can connect to my home network, but it doesn't work at all with my iPhone 7 Plus hotspot and for other severals network I use to connect.
    The latest driver is of course installed through Apple Software Update and the OS too (Windows 10 Pro) is updated, and I can't change Wi-Fi preferences for each network because they aren't mine. Have you any workaround?
  7. CaliDuck916 macrumors newbie


    Mar 4, 2017
    I have a similar issue on my 15" MBP tB.

    I have a Linksys E3200 B/G/N router. I am able to see both 2.4 and 5ghz bands, and I can connect to either one. However, the 5Ghz band is limited to 54Mbps. Other N devices in the house get 130Mbps frequently.

    It is definitely a Win driver issue, we are at Apple's mercy as the card works great in macOS.

    Playing with the advanced properties of the Wireless card had no resolution for me.
  8. CaliDuck916 macrumors newbie


    Mar 4, 2017
    One workaround I discovered is that by using VMWare Fusion Pro, the Bridged network connection is way faster than when using the Wifi adapter running Win 10 natively. Not a solution, but a work around if you have VMWare and just need a fast network speed for a transfer of some sort.
  9. CaliDuck916 macrumors newbie


    Mar 4, 2017
    Using my work's wifi (Eduroam), the adapter has a speed rating of over 975 Mbps, so the issue appears to be compatibility issues with different routers IMO.

  10. williamsa17 macrumors newbie

    Mar 12, 2017
    Currently also trying to connect to either 2.4ghz or 5ghz band from a 2016 Macbook Pro without any luck. The most current driver is updated and yet I am unable to connect to either bands. I have no problems with the wifi on Mac OS, which I am getting 35 down and 8 up on. This problem is new, as only a few days ago I was running great. Then, I started to experience dramatically high ping and packet loss while gaming. Even more recently, I am seeing the my wifi as "secure" but not connected. Really hoping that they will update the Broadcom drivers, this is extremely frustrating. ANY workaround would be helpful.
  11. imac2go macrumors newbie


    Dec 22, 2016
    sorry for this question:

    anyone noticed while connecting an USB Stick to an USB C Dongle ( Satechi or Hyperdrive ) that the wifi connection directly is turning off ?!

    i thought that i solved this issue, but its still there....

    tmbp 15 + Win 10... everything is working fine, except if i connect something to my USB C Dongle ...
    (this issue is only under Bootcamp, so i doubt it could be an hardware issue ....)
  12. slewis72 macrumors newbie

    Apr 20, 2017
    Well it looks as though I may have found a problem with this. At least for what my WI-FI was doing as described by most of you. Go into Device Manger in Windows 10. Expand Network adapters. Disable EVERYTHING except the Broadcom 802.11ac Network Adapter. Let me know how it works.

    Attached Files:

  13. terion macrumors newbie


    May 13, 2017
    2 all:
    run th apple software update and everything will be fixed
  14. xxyxxyxyx1, May 17, 2017
    Last edited: May 23, 2017

    xxyxxyxyx1 macrumors newbie

    May 17, 2017
    I ran the software update, and it is not fixed

    I have also noticed that wifi will drop whenever I plug in my Satechi usb c hub on bootcamp. It is not reliable when the hub isn't in use either.

    Edit: I shouldn't have said "whenever" in my original post. I have experienced, for at least 5 minutes, perfectly working wifi on bootcamp with my multiport hub, utilizing the usb-c power passthrough, hdmi, and two usb-2 devices, all at the same time.
  15. cognitdiss, May 23, 2017
    Last edited: May 23, 2017

    cognitdiss macrumors newbie

    May 23, 2017
    Thanks for the hint imac2go and xxy!

    At first I was like USB yeah whatever, but then I checked it out, and have to say that on my tbMBP I report the same behavior with the Apple branded USB2/USB3/HDMI to USB3 hub, as well as my Apple branded USB2 to USB3 dongle, connecting the mac to external drive and mouse via powered hub: I plug either of those two in and my wifi is done. Unplug, and wifi returns, immediately!! Absolutely repeatable. Used to work fine, has gotten progressively worse- this has probably what has made the problem so hard to trace.

    Interestingly, I can plug my USB3 power cord directly in with no wifi repercussions. I also seem to be able to plug in my external HDMI monitor via the multihub with no ill-effects. There were complaints about this Apple-branded multi hub present even before i bought it and i bought it anyways, but it is interesting that my single port to single plug USB2 to 3 dongle behaves the same way as the multi-port when USB is plugged into it regardless of HDMI, so I can't pin it on the multi-hub alone.

    Upshot- it seems like something about USB2 to USB3 implementation is causing software or radio interference that causes wifi to bug out. I am talking out of my ass here, and it could be something in my peripheral chain, but at the same time plugging and unlugging either of these two turns my wifi off and on like a light switch, with quick and unambiguous response. Wifi will report connected, secured regardless of actual performance.

    I have checked it again, and still confirm an absolute correlation. I have tried plugging in a USB-2 drive enclosure via my USB2-USB3 dongle, and the drive reads while wifi shuts off, so I have determined it is not any particular USB peripheral. Also, I can plug the dongle w/drive into any of the 4 ports and the same effect happens- it is immediate, and so is complete wifi recovery when I unplug.

    EDIT-- It seems like data transmission via USB is what kills the connection, and not on all 4 ports either, as the port on the right hand side closest to the trackpad seems to allow the drive to be hooked up while not killing the wifi internet connection, though the connection does seem sluggish. Also, I can use my wireless mouse reciever in either the multi-hub or single port dongle in any USB3 port on the computer with no ill effect on wifi, furthur casting my suspicion upon high speed data via USB2/3 (which is all I have, I have no native USB3 drives or enclosures yet). I have tested the above with two different drive enclosures and drives so far, same results for each.

    If I figure out it is a particular peripheral I will mention it in a followup, but in the meantime could I hear if anyone else can replicate my experience?
  16. icy-pop macrumors newbie

    Sep 14, 2014
    Los Angeles, California
    Omg thank you. This worked for me so far
  17. Stacc macrumors 6502a

    Jun 22, 2005
    FYI I am having this issue with the 2017 iMac. I have tried some of the suggestions in this thread and not had any luck. I'm trying to connect to an Apple Airport Extreme.
  18. LukeChannings macrumors newbie


    Sep 9, 2015
    London, England
    I have a 15-inch rMBP with Touch Bar from 2016 and had this problem. The WiFi would drop after a few seconds, I couldn't get a sustained connection dispite being in very close proximity to the AP.

    It turns out that the Windows (10) driver for the WiFi card can't seem to handle 5GHz networks where the channel width isn't 20MHz. My Unifi AP AC PRO is configured to use 40MHz by default (labelled channel width: VHT40). Changing to 20MHz has resulted in a much improved connection that hasn't yet dropped, and can sustain a fast connection.

    I *shouldn't* have to do this, and I'm losing some performance from my AP as a result of configuring it this way, and I don't have this problem in macOS. As far as I can tell it's a WiFi card driver bug, and the workaround is *reconfiguring your router*, which will be unacceptable to many people.
  19. Mayito macrumors newbie

    Aug 11, 2017
    I got my MBP this week and Ive successfully installed windows 10 home, but Im having issues with the wifi being ridiculously slow, its unusable. was their an update or fix on this??
  20. cchangx macrumors newbie

    Nov 22, 2016
    I think the issue's still there, and it's router dependent. Wifi was really bad for me at home on Windows 10, but once I went somewhere else, Wifi performance was normal.
  21. Stacc macrumors 6502a

    Jun 22, 2005
    Check and see if there are updated drivers in the windows apple software download. My experience on my 2017 iMac has gotten better since then. Also make sure windows is up to date.
  22. distro21 macrumors newbie

    Sep 7, 2017
    Same issue here. Just purchased within the last few days a brand-new MacBook Pro 13-inch with Touchbar from Apple. Updated all MacOS software to latest version. Used Bootcamp Assistant to install Win 10 latest build with licence key and ran all updates until there were no more to download. Then ran into the wireless issue described by OP. Despite a perfect fast wireless link to my BT Hub6 AC-enabled router on the MacOS side, I had many, many disconnects on Win 10 Bootcamp trying to hook up to the same router on the same SSID on 5GHz AC band.

    I seem to have found a working solution. By using Win 10 Updater it seems to install Broadcom 802.11ac Wireless driver version dated 12/07/2017 (as of yesterday). However, as suspected by the OP, this driver seems incompatible with the Win10 setup for unknown reasons (is it a Win10 issue or a Bootcamp one-who knows?). The fix I found was to completely uninstall this version of the driver (by double-clicking on it in Device Manager, selecting the Driver tab, then clicking on the Uninstall Device button) followed by a reboot into Win10 (remember to hold down the "alt" Options key to select Windows during reboot) where the machine will auto install a previous driver namely dated 21/11/2016 which seems to be working very happily again with the 1733 Mb/s throughput of my router on 5GHZ AC.

    I hope this might help other with the same issue. YMMV -if so let us know.
  23. Exie macrumors newbie


    Dec 31, 2016
    Similar thing here, I'm on the 13" MBP with Ubiquity AP AC PRO.
    I am using the Broadcom driver
    I configured the driver:
    "Bandwidth Capability" to "11a/b/g 20MHz"
    I can now connect 5Ghz all day long.

    Your point is correct though, it *SHOULD* just work.
  24. Encrypto macrumors newbie

    Dec 31, 2015
    You saved my bacon with this:
    MBP 15 Mid 2017, Kaby4.1, Win 10 Pro on BCA
    Driver Broadcom, 21/11/2016

    Plugged in Samsung EVO 1T in Simplecom USB-C enclosure, WIFI stopped,
    Plugged in Volans 3 Port USB3 and Ethernet dongle, WIFI stopped,
    Plugged in Hyper Drive Dongle, WIFI stopped,
    Tested on all four ports with the same problem.

    With nothing in the Ports, WIFI works well!
    Replicated this on Macos Sierra and WIFI worked with the dongles plugged in.

    How do we get APPLE to provide a fix?
  25. Mrmole macrumors newbie


    Nov 20, 2017
    So have we figured out a solution. I get the same problem macboopro 13 inch touchbar 2017. Cannot do a single thing with wifi...

Share This Page