Possible bootcamp wifi driver bug w/ 2016 MBP

Discussion in 'Windows, Linux & Others on the Mac' started by scotty588, Nov 14, 2016.

  1. b76302 macrumors newbie

    Joined:
    Jun 11, 2011
    #26
    Same issue here. My wifi (only in bootcamp) keeps disconnecting every couple of minutes or so in BootCamp. I have had my 15" 2016 for about 2 weeks now with no issues on wifi in MacOS. I have a lot of devices in the house and have no other wifi issues. I am using a single Apple Airport Extreme 4th generation (A1354) a/b/g/n router with the latest firmware 7.6.7. I installed bootcamp this morning with the intention of setting up a few games. The bootcamp drivers were installed properly and device manager shows Broadcom 802.11ac Network adapter. The driver version is 7.35.118.64. This is on Windows 10 Professional 1607. Bootcamp shows no updates in Apple software update. Right clicking in device manager and checking for a driver also shows it is up to date as of today.
     
  2. aaron5566 macrumors regular

    Joined:
    Jun 23, 2012
    #27
    It might be a router issue. I just tried playing Overwatch connected from my 4G hotspot on my phone and didn't have any drops. However, today I managed to game for 3 hours without any drops when connected to my normal router and wifi.
     
  3. maroony macrumors newbie

    maroony

    Joined:
    Nov 15, 2016
    #28
    Switching from Auto to 20 MHz Channel width works for me too! Thanks!
     
  4. 4ever4, Dec 5, 2016
    Last edited: Dec 7, 2016

    4ever4 macrumors newbie

    Joined:
    Dec 2, 2016
    #29
    TP-Link Archer C9 AC1900
    h/w ver. 2.0
    5Ghz works in bootcamp!
    new, default settings, out of the box

    1 tcp connection (iperf3 -w 1M)(im assuming its 80Mhz chanel):
    [ ID] Interval Transfer Bandwidth
    [ 5] 0.00-1.00 sec 80.9 MBytes 678 Mbits/sec
    [ 5] 1.00-2.00 sec 87.8 MBytes 736 Mbits/sec
    [ 5] 2.00-3.00 sec 84.7 MBytes 710 Mbits/sec
    [ 5] 3.00-4.00 sec 84.3 MBytes 707 Mbits/sec
    [ 5] 4.00-5.00 sec 83.1 MBytes 698 Mbits/sec
    [ 5] 5.00-6.00 sec 84.4 MBytes 708 Mbits/sec
    [ 5] 6.00-7.00 sec 76.3 MBytes 640 Mbits/sec
    [ 5] 7.00-8.00 sec 80.3 MBytes 673 Mbits/sec
    [ 5] 8.00-9.00 sec 81.9 MBytes 687 Mbits/sec
    [ 5] 9.00-10.00 sec 80.1 MBytes 671 Mbits/sec
    [ 5] 10.00-10.03 sec 1.85 MBytes 628 Mbits/sec
    - - - - - - - - - - - - - - - - - - - - - - - - -
    [ ID] Interval Transfer Bandwidth
    [ 5] 0.00-10.03 sec 0.00 Bytes 0.00 bits/sec sender
    [ 5] 0.00-10.03 sec 826 MBytes 691 Mbits/sec receiver

    P.S. got similar speed in MacOS
    There is nothing special about this particular router model, its just the ability to work in windows with the same speeds and reliability
    at least with some h/w.
    Under certain conditions I'm getting 933 mbit/s (116MB/s) in iperf3 both in windows and macOS, which is close to 945 mbit/s of my wired network.


    There are certainly some bugs in windows driver, such as problems with 40MHz channels and its unstable at 2.4Ghz. Sometimes it even refuses to connect to 2.4Ghz network (hibernate/reboot helps)!
     
  5. arnoz macrumors regular

    Joined:
    Jun 20, 2007
    Location:
    Lausanne
    #30
    I've managed to resolve that issue by unplugging my USB-C external hard drive. Tried 4 times first, and this apparently resolved the issue.
     
  6. dotdotdot macrumors 68020

    Joined:
    Jan 23, 2005
    #31
    I can't connect to any 5 GHz network with this new 2016 MacBook Pro too. This is a replacement unit and the issue was on both, so I assume it's a software issue (or incompatible hardware). Notably, I also can not connect my Logitech MX Master via Bluetooth as well, so something with boot camp and wireless connectivity is causing an issue.

    The ironic part is the 5 GHz network is from my AirPort Extreme. So my MacBook Pro in Windows can not connect to my Apple router.
     
  7. kasimodem, Dec 21, 2016
    Last edited: Dec 21, 2016

    kasimodem macrumors newbie

    kasimodem

    Joined:
    May 28, 2009
    Location:
    Paris, France
    #32
    Hello,

    I tried yesterday on a MBP16 with fresh install of W10 via Bootcamp assistant, and yes, you can't switch to 5GHz with Wifi network and can't associate a Bluetooth mouse too. Of course the two problems are the same because it's the same Broadcom chip for Wifi and BT. It's clearly a driver issue from Apple.

    With Wifi, at least, at 2.4GHz, I should be able to surf at a reduced speed but not such reduced. Sometimes it disconnect a few seconds, then come back, but with 500k download speedtest and 2000ms ping.

    I found a temporary solution by connecting an USB3 gigabit ethernet adapter through the USB-C to USB3 Apple adapter, and I get my 1GB speedtest back immediately. This solution however doesn't fully work under macOS, the ethernet adapter is seen in the Network panel but can't get a DHCP address, you have to set it a manual IP.

    I did not try more tests, but one solution would be to identify the vendor ID of the Broadcom chip and try to find manually a new driver for this particular model on the Boradcom support if it exists. Anyway, I hope Apple will release a Broadcom update soon.

    Edit : I just made a report on Apple site, hope it can accelerate things.
     
  8. sn00p macrumors regular

    Joined:
    Nov 10, 2009
    #33
    I have the wifi problems but no problem using my Magic Mouse with windows 10.
     
  9. kasimodem macrumors newbie

    kasimodem

    Joined:
    May 28, 2009
    Location:
    Paris, France
    #34
    I bet the Logitech Mouse would work with the Unify small USB key which is in the box, but I don't have any USB hub to test it. However I managed to pair a Sony Dualshock 4 V2 with Bluetooth in the Bootcamp Windows 10, so it's not completely broken.

    About the Wifi, I identified the chip as Broadcom BCM15700A2, which is the same as the one in the Dell XPS 15 9550. So I tried to download the driver from Dell support, but it did not work, I revert to the Apple one.
     
  10. smokeandapancake macrumors newbie

    Joined:
    Dec 23, 2016
    #35
    New here and same problem. New 2016 MBP 13"
    Thank goodness I found this, I was troubleshooting for days.
    Has anyone logged officially with Apple?
    --- Post Merged, Dec 23, 2016 ---
    Follow up: I found reference to disabling band 802.11a through the driver as a work around.
    Obviously not a fix though...
     
  11. kasimodem macrumors newbie

    kasimodem

    Joined:
    May 28, 2009
    Location:
    Paris, France
    #36
    There was an Apple Update yesterday evening for Bluetooth 6.1, but it says it only correct resume from sleep Bluetooth bug, and I tested it, it does not solve the pairing issue for the moment.
     
  12. Ragart macrumors newbie

    Joined:
    Jul 26, 2010
    #37
    Also having this issue on a 2016 13-inch MacBook Pro with Touchbar and Win 10. Wi-fi is unreliable and doesn't work 95% of the time, whereas it works perfectly in Parallels and macOS. I tried doing a few of the different tips in here (tweaking driver settings, reinstalling driver), but none have helped so far.

    Apple really needs to patch this up. Given the price of these machines, this really should work right out of the gate. Not having internet in Bootcamp is pretty crippling.
     
  13. Exie macrumors newbie

    Exie

    Joined:
    Dec 31, 2016
    Location:
    Melbourne
    #38
    I've had the same thing for the past few weeks, 13" MBP connecting to a Ubiquiti AP-AC Pro

    I have a late 2015 MBP which works fine and a Dell XPS which is fine, but the new 2016 MBP continually dropped out.

    I ended up splitting the networks and found 2.4Ghz was fine, but 5Ghz wouldnt connect at all.

    As mentioned in this thread, I identified my chip as a BCM15700A2 which I suspect is a custom made Apple version of a Broadcom BCM4360

    I will add that when I use 40Mhz on 5G band I saw events with:
    Code:
    Source: WLAN-AutoConfig
    Event: 10002
    Level: Warning
    
    WLAN Extensibility Module has stopped.
    Module Path: C:\Windows\System32\bcmihvsrv64.dll
    This could be a red-herring, but until anyone can confirm/deny it, that could be related to this issue.
     
  14. Huntn, Jan 3, 2017
    Last edited: Jan 3, 2017

    Huntn macrumors G5

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #39
    Guys, I missed this thread and started a different thread, but here is the gist of it- I have a 2016 13" MBP (see signature) with a wifi connection issue at home that only appears using Bootcamp/Windows 10. It either won't connect, or it won't stay connected. Wifi over the MacOS is fine. I have a Netgear 900 router with a 2.5 and 5 Ghz connection.

    I too thought this was a bootcamp/hardware/driver issue, until we went to visit friends for New Years and there, Bootcamp/windows 10 connects to their network without issue. We are still visiting, so my question is, what is the difference between my home network and their network? I'll connect with their router and see what it is, but I won't be home until Friday to look at my network for comparison. Any network specialists know what a likely setting culprit might be?

    Thanks.

    Update:
    Friends Modem: Netgear N600 Router, up to 300mbps, using WPA2-PSK [AES].
    My Modem: Netgear Wireless Router N-900, using WPA2-PSK [AES]. Not home yet to verify settings, but this is what I have recorded.

    So why does my computer using bootcamp/W10 connect to the slower modem, but has trouble with my modem? Are there any other settings that could effect the connection? I wonder if a firmware update might be the answer?
    Thanks!
     
  15. Patrick-Photo macrumors regular

    Joined:
    Mar 22, 2012
    #40
    +1. I can't connect to the 5gHz network at home (AirPort Extreme A/B/N). However connecting it with a "cheap" Linksys router on 5gHz isn't a problem...
     
  16. Huntn macrumors G5

    Huntn

    Joined:
    May 5, 2008
    Location:
    The Misty Mountains
    #41
    That's the one I have that show up to date from Sept 2016.

    Don't you guys find it interesting that the older and/or slower modem connections have no problem? Using my friends Netgear N600 (max 300mbps), there is absolutely no issue connecting Windows to it (on my 2016 MBP).
     
  17. Ragart macrumors newbie

    Joined:
    Jul 26, 2010
    #42
    Just downloaded a new update from the Apple Software Update while in Win 10. One of the bullet points did mention a 5 GHz fix. My Wi-Fi worked properly tonight, but haven't really tested this. Hoping this is the fix.
     
  18. dan9700 macrumors 65816

    dan9700

    Joined:
    May 28, 2015
  19. smokeandapancake macrumors newbie

    Joined:
    Dec 23, 2016
    #44
    not fixed!
    May seem fine but will soon show same problem....
     
  20. princ2 macrumors newbie

    princ2

    Joined:
    Jan 18, 2017
    Location:
    Poland, Gdynia
    #45
    Exact same problem here, guys. My brand new MBP 15" was flawless until this came up.

    I noticed my Windows 10 installation started to behave really weird. Chrome started to be very buggy and slow - this is related to faulty network adapter drivers, I presume.

    Any updates on this?
     
  21. Cidolfus macrumors newbie

    Cidolfus

    Joined:
    Feb 2, 2017
    #46
    Registered an account just to say I have exactly the same problem. tMBP 15" running Windows 10 on bootcamp.
    Very frustrating, are there any known fixes or workarounds?
     
  22. princ2 macrumors newbie

    princ2

    Joined:
    Jan 18, 2017
    Location:
    Poland, Gdynia
    #47
    Update from me, I solved it on the same day as my post - 26.01.

    What I did is created new wifi network 5Ghz range only. This solved my problems completely and I don't have any timeouts/wifi acting weird anymore.

    This is of course not a solution, only workaround... Once I'm back on 2.4Ghz network problems begin again. Clearly a Wi-Fi driver issue, which Apple & Broadcom need to address.
     
  23. Undercoveravid macrumors newbie

    Undercoveravid

    Joined:
    Feb 4, 2017
    #48
    I tested many times by updating 2.4ghz only modem router firmware,reset SSID and unplug everything and wait for 1 mins then turn on the router. Its works fine for the first day, but drastically speed drop on the second day.

    I did the same as the first test to 2.4ghz & 5ghz dual band router ,doesnt connect to both band neither.

    3rd test on portable pocket wifi failed to connect surprisingly, however it's connect to my iPhone's hotspot.
     
  24. dbackeus macrumors newbie

    dbackeus

    Joined:
    Feb 7, 2017
    #49
    Also experiencing issues in Windows 10:
    - Can't connect at all to my offfice WiFi
    - Using my home WiFi internet speed drops from 100mbit/sec to 20mbit/sec

    Submitted a report at https://www.apple.com/feedback/macosx.html
     
  25. foursided macrumors newbie

    Joined:
    Feb 8, 2017
    Location:
    Las Vegas
    #50
    Chiming in to add my frustration with the same problem. I can't believe this has been unaddressed for months now. Just picked up my new tbMBP two days ago, installed Windows 10 in boot camp, and no wifi. Connects for a minute, slow to almost no connection, then drops. Submitted a report with Apple as suggested above. This is pretty unacceptable.
     

Share This Page