Power Mac G3 B&W Chimes but no video

Discussion in 'PowerPC Macs' started by eperezf, Mar 27, 2017.

  1. eperezf macrumors newbie

    Joined:
    Apr 17, 2011
    #1
    Hi,

    I recently got a B&W tower PowerMac G3 (don't know exactly which model) without DVD reader and HDD. I powered it and saw a grey screen with a folder and a question mark followed by the finder logo. Probably couldn't find OS X (duh). At least it booted. I powered it off, got a OS X Tiger install CD, got an IDE DVD reader I had lying around, a 30GB HDD and plugged them in. Went to boot again but nothing happened. Just the chime and then nothing. No beeps, no video, no grey screen. Tried turning it off, disconnecting power and turning it on to drain it completely.

    Is there any kind of troubleshooting flowchart or steps to resolve issues? I don't have a Mac keyboard with me. I'm using a regular USB mouse and keyboard with Windows keys. Also, neither the mouse or keyboard lights turn on after the chime. Are the USB dead? or it gets stuck before powering them on?

    Thanks!
     
  2. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #2
    Here's a link to help identify the later Rev2 B&W G3 model:
    http://www.xlr8yourmac.com/G3-ZONE/yosemite/newfeatures.html
    If yours is the earlier model (lacking the above features), its logic board is known for a corrupt IDE controller.
    Many owners at the time resorted to Mac-compatible PCI host cards (SCSI or IDE).
    However, maybe your boot-up problem is from a wrong jumper setting (Master/slave) on the HDD.

    xlr8yourmac.com has a lot Blue & White G3 owners contributing to a users experience data base.

    Btw, recently I tried to install a couple of Linux distros on my working B&W,
    and what a series of nope, nope, almost, is it gonna really happen?....absolutely NOT.
    I think the firmware & junk IDE confused the installers...or something.
     
  3. eperezf thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #3
    Just noticed that this G3 has a Radeon 7000 GPU, not a Rage. Probably the previous owner changed it. The IDE chip didn't have a 402 in the part number so I assume it's the earlier model. I'm now trying to boot without DVD and HDD to see if I can get to the same grey screen with the question mark but I'm still getting a black screen and nothing powered on on the USB ports. It's like it booted fine once and then died.
     
  4. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #4
  5. eperezf thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #5
    Hi, sorry for the late reply. I got a new PRAM Battery and still no video after the initial chime. Also no beeps. I tried several combinations of unplugging, removing PRAM battery, resetting PRAM, etc. but no success.
     
  6. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #6
    Since your B&W chimes, I'm guessing the logic board & RAM must be good.

    After all your resets/etc and with the DVD-ROM & HDD reconnected with ribbons & power cables,
    were the jumpers for both drives set to Master for a test reboot?
    I mention the drives' Master/slave jumpers since having the jumpers set wrong can prevent proper boot-up, even no video IIRC.
    And in case you received the B&W missing an original HDD IDE ribbon, I'll mention things that may be redundant, but this Mac is finicky.

    A single drive is always attached to the very end of a two-drive ribbon. I'm sure the Rev 1 originally had a single drive ribbon.
    The CD/DVD IDE ribbon (a different ribbon from the HDD's) went to optical bays with ROM Drive on top (connected by ribbon's tail end)
    and optional zip drive on bottom (mid ribbon connection).

    Your DVD Drive, is it originally from a Mac and/or Apple branded?
    Some PC optical drives could mount & burn data discs but not work as functional Mac Installer boot-ups or burn Mac-bootable installer discs.
    Of course, if you don't have a compatible optical drive, it looks like installing an Apple OS is a moot point right now.
    And firewire target mode doesn't work with the B&W G3 or Yikes G4.

    Also, if you don't know if OSX was ever installed in your B&W (originally Mac OS 8.5.1, 8.6),
    it may need a firmware update before installing OSX.
    If you could at least get video, you may be able to do an Open Firmware reset.
    While in OpenFirmware mode the firmware info is listed.

    Regarding a B&W using a PC USB keyboard,
    I read in an Ars Technica forum a user that successfully pressed the [C] key to initiate a CD-ROM installer disc.
    But if your USB ports still seem dead after the resets you did, other options would be:
    1) a old PCI USB card (NEC chip or Belkin), USB 1.0 would work.
    2) an older Mac keyboard using the older serial ADB (Apple Desktop Bus) port (looks similar to but is different from a PS/2 port)
    The B&W G3 was the last PowerMac to retain the ADB port.
    ADB is not considered hot-pluggable like USB.

    If you want to cull through info about the B&W's firmware update needed for
    OSX, google Power Macintosh G3 (Blue and White) Firmware Update.
     
  7. eperezf thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #7
    So, I got some good news and some bad news.

    For some reason the computer was chiming BUT it had one bad RAM stick. I tried a combination of all the sticks and whenever I inserted that one in any slot it didn't boot again. So now I have that sorted out.

    Fortunately, the DVD reader was detected and could boot a install CD. It's a Samsung one and was recognized by the Mac as I could boot Mac OS 9.2.2 and OS X 10.3 install CDs.

    The problem now is that it doesn't recognize my Hard Drive. It's a 80GB Maxtor Diamond. I have set the DVD reader as Master and the Hard Drive as Slave. It doesn't appear in the disk list in disk utility on the 10.3 install CD. I doubt it is because it's formatted as NTFS (as this was from an old Windows PC I had). Any ideas on why it's not detected?

    I also have a 20GB Quantum Fireball Hard Drive and will test with that one but I prefer the 80GB one for more space.

    thanks for all the help!
     
  8. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #8
    As I understand the Rev1 IDE controller for the HDD,
    it doesn't recognize more than one IDE connection - so no Master/slave setup or slave period.
    I'm speaking of the IDE (PATA) connection on the logic board right in front of the HDD mounting tray.
    It almost sounds like you have the DVD-ROM & the HDD on the same ribbon? If so, that won't work.

    The B&W's separate ATAPI connection for the Optical & Zip drive
    (another different ribbon leading to the front bays)
    does allow Master/slave. That's the ribbon for the DVD-ROM, set as Master.

    With the HDD set as Master & connected by itself on the logic board's IDE (PATA),
    then OSX's Disk Utility should see the PC HDD (greyed out, IIRC).
    Select it and Erase, format with HFS+ Journaled.
     
  9. eperezf thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #9
    No, the HDD and DVD drive are in separate cables. The HDD on the bay at the bottom of the case where it should be, connected with the short single ribbon.

    The DVD Drive is connected to the IDE port beside the HDD one with a long ribbon going under the logic board to the front bays.

    The HDD spins up and the led indicating HDD access does lit up before showing the "no OS" question mark folder and then booting to CD. After that, it doesn't show any activity even when accessing Disk Utility.

    The setup currently is: DVD as Master (jumper at master position) and HDD as slave (no jumper). Should I change it to DVD as slave and HDD as master? I tried with the 20GB HDD and it didn't recognize it either.
     
  10. QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #10
    Keep the everything as connected but change the HDD to Master.
    Separate IDE ports (or whatever they're called) & ribbons can each have a Master setting.
     
  11. eperezf thread starter macrumors newbie

    Joined:
    Apr 17, 2011
    #11
    IT WORKED!

    Thank you very much for all the help! now for a last question before closing the thread: Do you recommend installing 9.2.2 and 10.3 (the ones I have available) in separate partitions or just use classic mode on 10.3 for older software?
     
  12. QSDP-User, Apr 1, 2017
    Last edited: Apr 1, 2017

    QSDP-User macrumors regular

    QSDP-User

    Joined:
    Jan 13, 2015
    Location:
    California, USA
    #12
    You're welcome & good call on the RAM troubleshooting.
    Hmm, well personally I was never a fan of Classic Mode,
    preferring to run the Classic OS & software in its own installed partition if the space was available.
    You've got an 80 GB HDD, right? I think that's big enough to partition.
    Plus I like using the usual repair utilities for the specific OS in its own partition.
    Others may chime in on their opinion.

    EDIT: Btw, I just realized that my previous post about the Rev1 IDE controller saying it
    "doesn't allow Master/slave or slave period" is very confusing. I should have type it as:
    The Rev1 IDE controller is a one-drive controller, period.
    1) It doesn't allow a Master with a slave, meaning two drives on a two-drive PATA/IDE ribbon
    (to do so then data corruption is predicted).
    2) It doesn't allow a one-drive ribbon (or a two-drive ribbon for that matter) with the one
    connected drive set as slave.
     

Share This Page