Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

TheShortTimer

macrumors 68030
Original poster
Mar 27, 2017
2,796
4,926
London, UK
Using the search function, I couldn't see a thread that was dedicated to the discussion of gaming on PPC Macs: running OS X and OS 9 - or even older, so I've decided to create one. :) It would nice to see what everyone is playing and to share recommendations on titles (and emulators) to check out. I'll keep this going every so often with posts and hopefully others will join in too.

Via MacMAME on my Mini:

kowOhIx.png


LP4B3nj.png


quJBtKR.png


r55gKAf.png


z62pxZF.png


ASSegSZ.png


dnUd65y.png


hYNuHAw.png
 

Project Alice

macrumors 68020
Jul 13, 2008
2,025
2,100
Post Falls, ID
Using the search function, I couldn't see a thread that was dedicated to the discussion of gaming on PPC Macs: running OS X and OS 9 - or even older, so I've decided to create one. :) It would nice to see what everyone is playing and to share recommendations on titles (and emulators) to check out. I'll keep this going every so often with posts and hopefully others will join in too.

Via MacMAME on my Mini:

kowOhIx.png


LP4B3nj.png


quJBtKR.png


r55gKAf.png


z62pxZF.png


ASSegSZ.png


dnUd65y.png


hYNuHAw.png
If you’re on Facebook, there’s a group called “PPC Gaming Lounge”. Not as active as it used to be but still a lot of good info. It’s one of the only reasons I’m still on that site.
 
  • Like
Reactions: TheShortTimer

MrPilot

macrumors 6502
Apr 30, 2013
316
24
check this reply, #24 from me on this gaming thread:
 
  • Like
Reactions: TheShortTimer

z970

macrumors 68040
Jun 2, 2017
3,580
4,502
I'll say it once more...

The Myst saga are by far my favorite games on PPC OS X, probably even Windows. Something about the immersion, atmosphere, score, and life lessons really touch me. And, the series' storyline is eerily relatable...

Rand Miller, and Jack Wall (in III+), are damn geniuses.

...Seriously, the music is unmatched.




But I ramble...
 

dr.zeissler

macrumors member
Oct 1, 2018
92
16
Are you using 10.4 or 10.3 ? I am using 10.3.9 and I am collecting Games for my G4-1.42Ghz MacMini.
Does anyone have these perhaps OS9 and 10.x working files:

The newer ones require 10.4 and I would like to keep the machine to 10.3.9

Btw. MAME 0.66-2 that I am using is working fine with 10.3.9. The newer ones do not have any benefit. Some games are broken, some games do only work in the newer ones. Do you have the opengl-plugin for mame?

Greetings
Doc
[automerge]1573821649[/automerge]
What mame version are you using and what about performance and vsync!
 

TheShortTimer

macrumors 68030
Original poster
Mar 27, 2017
2,796
4,926
London, UK
Are you using 10.4 or 10.3 ? I am using 10.3.9 and I am collecting Games for my G4-1.42Ghz MacMini.

I'm using 10.4.11 on my Mini.

What mame version are you using and what about performance and vsync!

The version of MacMAME that I'm using is 0.103u2 which I believe was the final version before development halted.

Do you have the opengl-plugin for mame?

I don't have an OpenGL plug-in for MacMAME: V.0.103u2 features a built in OpenGL renderer and it also includes an option for Sync to VBL.

drJIbjW.png


QoC63Tn.png


KYDCohR.png



Btw. MAME 0.66-2 that I am using is working fine with 10.3.9. The newer ones do not have any benefit. Some games are broken, some games do only work in the newer ones.

A downside of MAME as you've seen is that it requires you to either have the correct ROM set for your release or that you use a ROM Manager to convert a set to work with your MAME release. Otherwise you'll run into problems with broken games. I can't be bothered to fiddle around doing the latter.
 

hardon

macrumors regular
Aug 27, 2003
178
48
UK Kent
6E549796-D721-4F43-B25D-4E309582FD59.jpeg
F30CB2C3-F178-4B9E-8182-976FF7CC0D99.jpeg
B6B939FC-CBF8-459D-B59F-463E822205B9.jpeg

[automerge]1573982608[/automerge]
Tbh I’m playing Warcraft 2 and 3 again, haven’t played games for decades, but as the nights draw in I have found myself engrossed again.

Just bought a quicksilver on eBay for £12.
I only intend to use Mac OS 9, and I’ll be pimping this rig, I’ll keep posting over the winter. ?
 

dr.zeissler

macrumors member
Oct 1, 2018
92
16
You can use OS 9.2.2. native on your mini, but I think you knew that already.
Can you tell me, what "frameworks" are installed and what versions your are using. (SDL etc.).
Does this start on your mini: https://www.gianas-return.de/?page_id=4531 (Version OSX PPC >10.3. above)

These look really awesome on a G4Mini. Gfx and Textures are awesome https://alephone.lhowon.org

BTW Diablo2 can play without any cd in drive if you install it completely and copy one additional file from CD to HDD. (don't know what file exactly)
 
Last edited:

TheShortTimer

macrumors 68030
Original poster
Mar 27, 2017
2,796
4,926
London, UK
I'll say it once more...

The Myst saga are by far my favorite games on PPC OS X, probably even Windows. Something about the immersion, atmosphere, score, and life lessons really touch me. And, the series' storyline is eerily relatable...

Rand Miller, and Jack Wall (in III+), are damn geniuses.

...Seriously, the music is unmatched.




But I ramble...

I picked up Myst IV from a local thrift shop ages ago but I haven't gotten round to checking it out yet.

60fp2aT.jpg


I'll have to rectify that very soon. :)
 
  • Like
Reactions: z970

bunnspecial

macrumors G3
May 3, 2014
8,330
6,437
Kentucky
RTCW has to be one of my favorite games to pay on PPC Macs.

Aside from being a lot of fun-it's playable on most G4 and newer hardware(or even hot G3s), but you can crank up the settings if you want to flex your muscles a bit.

One of my main "gaming computers" is a Cube with an 800mhz G4(1mb L3) and Geforce 3.

I prefer to game in OS 9 where possible. The system overhead is a lot lower.
 

MacFoxG4

macrumors 6502
Nov 22, 2019
437
609
Played a game called "Sci-fi Pinball" on my Sawtooth under OS 9. I really like pinball games and one of the tables was based on my favorite TV show, Buffy the Vampire Slayer.
 

TheShortTimer

macrumors 68030
Original poster
Mar 27, 2017
2,796
4,926
London, UK
A fabulous remake of the classic 80s computer game that should be familiar to many Brits. :)

If you're into action and puzzles then you'll be in your element with this.

Played on my iBook G3/500:

H6D2soy.png

QVKlaGZ.png

NTNtRxA.png

6BiLbna.png
 

TheShortTimer

macrumors 68030
Original poster
Mar 27, 2017
2,796
4,926
London, UK
Has anyone had any success with getting the SDL based PPC version of XMAME to work?

On my G3/500 running Tiger, I've followed the instructions to download the SDL library (I downloaded SDL-1.2.13) and then copied the SDL.framework folder into /Library/Frameworks. When I attempt to run the xmame_ppc_sdl executable, it fails with this error message:

/Applications/xmame_ppc_sdl; exitdyld: Library not loaded: /opt/local/lib/libSDL-1.2.0.dylib
Referenced from: /Applications/xmame_ppc_sdl
Reason: image not found
Trace/BPT trap
logout
[Process completed]

Is XMAME failing to see the SDL library or does it require the exact 1.2.0 version in order to work? Can anyone offer any pointers at all please? BTW: I'm attempting to set up XMAME because it would have a lower overhead on my G3 (no GUI) than MacMame.
 

wicknix

macrumors 68030
Jun 4, 2017
2,607
5,267
Wisconsin, USA
Looks like it was built with macports. I've attached the 4 common needed sdl-1.2.0 libs in an archive. You'll need to put the SDL libs in to /opt/local/lib. (create those directories if you dont have them)

Cheers
 

Attachments

  • sdl-libs.zip
    260.8 KB · Views: 261
  • Like
Reactions: TheShortTimer

TheShortTimer

macrumors 68030
Original poster
Mar 27, 2017
2,796
4,926
London, UK
Looks like it was built with macports. I've attached the 4 common needed sdl-1.2.0 libs in an archive. You'll need to put the SDL libs in to /opt/local/lib. (create those directories if you dont have them)

Cheers

Thanks for that! :)

Ok, I created the directory in the root folder, as you can see here:

6z3rlE6.png


I still receive exactly the same error message though.

Have I put it in the wrong area?
 

wicknix

macrumors 68030
Jun 4, 2017
2,607
5,267
Wisconsin, USA
It should be 3 separate directories. From the screenshot it just looks like 1 folder called "opt/local/lib". What you want to do is open terminal.app, then type:
cd /
sudo mkdir /opt
sudo mkdir /opt/local
sudo mkdir /opt/local/lib

Now that those directories are made you can copy those files over. You'll see "opt" in finder.
Screen Shot 2019-12-06 at 1.51.35 AM.png

Cheers
 
  • Like
Reactions: TheShortTimer
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.