General Privacy Issue with iOS Snapseed

Discussion in 'iOS 12' started by dialogos, Nov 29, 2018.

  1. dialogos, Nov 29, 2018
    Last edited: Nov 29, 2018

    dialogos macrumors member

    Joined:
    Sep 22, 2017
    #1
    I have Snapseed installed on my iPhone. I decided not to use it anymore so instead of uninstalling it I disabled the access to my photo library
    Settings -> Privacy -> Photos -> Snapseed -> Never

    Snapseed still has access to my photos though! There is the option to open photos from device (as it is been called in Snapseed) and I can still access my photos!

    I tried to re enable the access to my photo library and disable it again. The problem still occurs.

    Edit: I just realized that other apps like facetune have the same behavior. Despite the fact photo access is disabled they can still access my photo library by selection Open Photo in the app's interface.

    What is the point of all those privacy settings if apps have an indirect way to access my photos?
     
  2. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
    #2
    This prompted me to take a look at those settings as well and I was surprised to find the list under Privacy / Photos completely empty. It's strange because I have plenty of image editing apps that have access to the Photos library. I even reinstalled Pixelmator to see if it would prompt for access but it didn't, nor was it added to the Privacy list.

    This happens on an iPad that was restored from an iCloud backup 2-3 weeks back. My iPhone shows the Privacy list content properly, but also has the problem you described - toggling Photos access has no effect. In Pixelmator's case I had not previously given access to the camera and when I denied it, toggling that setting worked as it should.

    Both devices are on iOS 12.1. I wonder what we're missing here.
     
  3. oodi macrumors regular

    Joined:
    Sep 26, 2015
    #3
    Jesus! This cant be true. Whats the point of that setting then? Is this an iOS bug?

    First I thought sneeky snapseed uploads photos to google cloud. But then i saw the same behavior by other apps
     
  4. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
    #4
    I'll check this behavior next week on a newer-before-used iPhone without restoring from a backup. If the privacy settings work then I suspect this is a bug resulting either from the iOS update process or from restoring an iCloud backup.
     
  5. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #5
    The privacy option is to allow/disallow direct control on the photos library. The Photos Picker doesn't require an authorisation because it must manually be invoked by the user and it can't be use to automatically load photos.
     
  6. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
  7. dialogos, Dec 10, 2018
    Last edited: Dec 10, 2018

    dialogos thread starter macrumors member

    Joined:
    Sep 22, 2017
    #7
    In this case why can't I manually allow GPS tracking in some apps even if GPS location is off in privacy? What about manual access to my mic despite the fact that it's off for specific apps? Why Photos is an exception? Why it works properly for most apps?

    I'm sorry but when access to my photo library is set to OFF that means that it should be OFF - period!! No access at all!!!! And this is my understanding so far by Apple. I would like to see an official explanation.

    Right now I could assume that Apple's privacy settings are just plain marketing.
    --- Post Merged, Dec 10, 2018 ---
    My iphone is new and I didn't restore it from icloud. This is how it works. Apparently privacy settings in iOS mean nothing as long as they can be manually changed through an App. I assume we will find apps that have access to location, to microphone, to health data and we will call it an exception even if every setting was set to off in privacy menu.

    It's interesting that so few users here are interested in this privacy issue.
    --- Post Merged, Dec 10, 2018 ---
    I don't know if snapseed uploads photos to cloud without permission but maybe it just scans our photos. We can safely assume that any app can scan our photos without permission - for example exif data.

    PS. I would like to change the thread's title to something more general about iOS privacy - not snapseed specific, but I don't know how to do it :)
     
  8. Puonti macrumors 6502a

    Joined:
    Mar 14, 2011
    #8
    I've now moved to a new phone without restoring from a backup, and the privacy settings once again appear properly. This was not the original issue reported by @dialogos but something I had run into myself. Glad to have it sorted, though I can only guess as to what caused it.

    As for the original issue I'm inclined to think @Ritsuka got it right - the privacy controls for Photos access only apply to apps' wholesale background access to Photos. What I'm seeing in Pixelmator (and what's probably going on with Snapseed) is a user-initiated Photos dialog which the app itself does not see. It's like an extension running on top of the app, which sends a reference or copy of a file to the app once the user makes a choice. That would not constitute a privacy issue and I'm not seeing any credible proof to the contrary (this would be all over the news if true).

    Since it's not, I'm fine with waiting and seeing if it will be.
     

Share This Page