Prohibitory sign after Sierra update, unmountable partition

Discussion in 'macOS Sierra (10.12)' started by RedFlag, Jul 6, 2017.

  1. RedFlag, Jul 6, 2017
    Last edited: Jul 6, 2017

    RedFlag macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #1
    Hello.

    Yesterday I decided to update to Sierra from El Capitan on both the disks on my Macbook Pro (mid 2012); the update on my SSD went without a hitch so I decided I'd update my other disk, too. I downloaded the .app and the installation started as normal; once it got to the point where I'd have to restart, though, the problems started.

    Once the Mac booted, a folder with a question mark appeared; I read that resetting the VRAM and choosing a startup disk (again?) helps in these cases, and it did; however, now I get a prohibited symbol whenever I try to log in on my hard disk. To be exact, it happens after I insert the login password and the loading bar is almost full.

    Is there some way to gain back access to the volume, or even just access to the files? I have 100GB+ of Photos Library that I'd really, really like not to lose...

    Here are some of the things I tried:

    • Basic Fix & Repair Options : from both the terminal and Disk Utility, on both Single User Mode and Recovery Mode. The "Repair" option in Disk Utility, in particular, gives this error: "File system exit code is 8. An internal error has occured". Trying to Mount the volume, in whatever way, has no effect whatsoever or I just get an error that the volume can't be mounted. Also, the partition now shows up as greyed out and called "--" (empty); it was called "Macintosh HD". The name still appears in several other disk utility apps, but still something to note.

    • Recovery Mode : I tried re-installing the OS but the volume is now unmounted so it doesn't show up as a possible option. Also, I found an article saying that booting problems could come from old extensions that no longer work after an update; the article described the terminal steps to take in order to move all non-Apple extensions to a folder on the volume and make it bootable again. However, same problem, the volume is unnamed and unmounted and it doesn't show up anywhere, nor can I "cd" into it.

    • Safe Mode : I can't start Safe Boot into the damaged partition: to load it, I need to hold the Option key and choose it from a list and doing that and holding Shift too doesn't do anything. I can only boot in Safe Mode on my working OS X partition (SSD) and that defeats the purpose. Thinking about it now, is there a way to Safe Boot into a different disk/partition?

    • Single User Mode & fsck : I ran the fsck command (and variations) multiple times on the faulty partition and others, too, and at some point I got a "GRUB.Geom.Hard Disk.Read.Error" or something like that, that as far as I can see now it's been resolved; still, no success on booting the OSX partition. After the fixes, though, an "EFI" partition that wasn't mounted and visible from any OS now suddenly is. It contains a folder called "APPLE" with three more folders inside it: CACHES (one more folder, empty), EXTENSIONS (Firmware.scap) and FIRMWARE (MBP91_00D3_B0C_LOCKED.scap). What are these?
    • VRAM Reset : did nothing.

    • Volume Rebuilding : I've tried using both TechTool Pro and DiskWarrior to rebuild the partition, as both apps signaled damaged volume integrity and structure; neither app was able to rebuild the volume. TechTool Pro, in particular, stops at the very first verification step, "Journaled HFS Plus Volume". Does that mean the volume isn't recognised as HFS+ anymore? Does this have any significance?

    • OS X Combo Updates : The volume, being unmounted, doesn't show up so I can't install anything on that partition.

    • Data Recovery Tools : I tried using Data Rescue 4 and it extracted a bunch of unusable and un-extractable .bz2 and .gz files, size around 10GB.

    • SMC Reset : Will try this one later.
    This is my partition scheme; the "damaged" volume, on /dev/disk1, has the identifier disk1s2.
    As you can see, the same disk holds two more partitions, booting Windows 7 and Ubuntu Linux; both are working correctly, so this rules out the hard disk suddenly failing, I guess. Also, several checks of the drive show nothing amiss.
    The other disk (disk0) is working fine, it's my boot drive and I'm using it right now.

    Code:
    /dev/disk0 (internal, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *250.1 GB   disk0
       1:                        EFI EFI                     209.7 MB   disk0s1
       2:                  Apple_HFS Crucial SSD             249.2 GB   disk0s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
    
    /dev/disk1 (internal, physical):
       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:      GUID_partition_scheme                        *500.1 GB   disk1
       1:                        EFI EFI                     209.7 MB   disk1s1
       2:                  Apple_HFS                         301.2 GB   disk1s2
       3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
       4:       Microsoft Basic Data BOOTCAMP                165.8 GB   disk1s4
       5:           Linux Filesystem                         32.2 GB    disk1s5

    I really hope there is something else I can do to fix this... Would creating an image of the drive save the files?
    I had been thinking about switching this disk for an SSD and was preparing for that; I backed up both the BOOTCAMP and Linux partitions, so if it can help those can go and be removed, but I thought I'd backup the OSX one after the update...

    Awaiting ideas... Thank you.
     
  2. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #2
    You have two drives in the MacBook Pro, correct?
    And you regularly boot from the SSD, correct?

    If the answers are "yes", then why do "separate" installs on both of the drives?

    Why not use something like CarbonCopyCloner (or SuperDuper), to "clone over" the good install (SSD) to the HDD?

    It can serve as a backup of the SSD and "alternate boot source" for maintenance, etc.

    This is such a simple alternative approach, why wrestle with what you're wrastlin' with now?
     
  3. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #3
    From what I see, your HD has problems and there's nothing that you've mentioned to indicate that there would be a quick fix. There's different types of HD failures, perhaps my experience of the last six months will illustrate that. In one case, the disk outright failed - this was a Linux backup disk and sometimes the disk-image copying software would see it, other times not but in no case could it see any partitions. In another case, there was a disk with 3 partitions, one bad, the other 2 were fine. I just renamed the bad partition BAD and the other 2 partitions are secondary backups of not-great importance. I fully expect this disk to go fully bad at some point. In other case, I had another disk and there was nothing in normal usage indicating that the disk was bad, but a disk analysis program I have (Scannerz) indicated that sectors were not responding as quickly as it should. I created a partition around those questionable sectors and use the rest of the disk, again for secondary backups. I'll have to be sure to run the analysis program on that HD on a regular basis. Just because one partition works doesn't mean that another partition hasn't gone bad. You shouldn't let the fact that the partition table and the Windows partition appear OK fool you.

    At this point, you should presume the partition has gone bad and make a determination about what you want to do. If possible, you should try to make a sector-by-sector copy of the disk. I've used Easeus (free) which works on PC's. If you decide to use this, I can give you some tips. There's a program called Clonezilla but I'm not familiar with it.

    After that, you can make a visit to the Genius Bar and see what they have to say. They probably would take similar steps of diagnosing the problem that you did. Besides the software you've used, Seagate has recovery software that you can try before you buy.
    http://www.seagate.com/services-software/recover/recovery-software/

    There are data recovery services as well - Seagate also offers this service - I don't think they limit their software/services to Seagate drives. I mention Seagate because one would think they have special expertise since they've been manufacturing drives for a long time - I have no experience with their software or services.
     
  4. RedFlag thread starter macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #4
    Thank you both for your answers.

    Yes, I have two drives and I regularly boot from my SSD; thing is, the SSD is quite new, maybe a year or so, and before that I'd been using Mac OSX on my regular hard drive, and once in a while I've been updating it for convenience and for usage as an internal backup disk, of sorts.

    I can't clone the good install to the hdd because otherwise I'd lose all the data on my hdd, would I not? Also, the "bad" partition doesn't even show up in CCC - I'd wager it's because it's unmounted, and I can't seem to find a way to mount it because of it being damaged in some way.

    I really need to find a way to mount the partition or access the files on it...

    I ran maybe five or more different apps and made different checks on the hdd with each one, and none showed any signs of impending disk failure - or anything else, really; the hdd truly seems to be fine and working.

    I created an image of my drive using Disk Utility; 300GB+ of .dmg that wouldn't even load in the end because it says there's problems with the file system... I could try some other program, I suppose; at this point I've nothing to lose and everything to gain. I'll look up some EaseUs software to help with that, maybe hoping for a good image from Disk Utility was too much to hope for.

    How much would going to an Genius Bar cost me, though? My Macbook's warranty expired years ago.
    Same thing with the data recovery services; I live in Italy and I can't seem to find anything around here, and I haven't looked it up really well since I'm afraid of the possible cost...

    I'm downloading the Seagate recovery software right now, all the others have been useless but I'm crossing my fingers.
     
  5. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #5
    To be clear, the idea of making a sector-by-sector clone is to have a working disk that is a copy of the bad disk, flaws and all. A lot of times using the bad disk can make the situation worse. Also, if you do use data recovery software, it's likely to be easier if you're working with a disk that's working vs. one that has problems.

    The Genius Bar won't charge unless they fix some hardware. I'm pretty sure they don't do data recovery. The idea in going there is that they may be able to offer useful advice and I think they have access to the best organized store of knowledge about the Mac. But if it's difficult getting to an Apple Store, you can probably skip it.

    Some times hard drives give signs of failing, other times they don't.

    So, since you're looking into Easeus, I'll mention again, you need a PC and you need to create a bootable USB flash drive or CD/DVD. It does work from a bootable CD on my 2009 Mini, but not my other Macs. When doing the clone, you can't use the PC for anything else - on my USB2 PC, it takes about 6 hours to do 500GB. It will try to do error recovery for a bad source disk. I've never encountered such an error so I don't know what it will do - probably it will try multiple times to read from a sector and skip to the next sector if it fails.
     
  6. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #6
    OP:
    Some questions:

    1a. What is the overall capacity of your SSD?
    1b. How much of that space is currently "used up"?

    2a. What is the overall capacity of the old internal HDD?
    2b. How much of that space is currently used?

    Answer these, and I'll give you suggestions as to what to do next.
     
  7. RedFlag thread starter macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #7
    Seeing as I've been pretty busy, I've only been able to create a clone of my partition using Mac software, Data Rescue 4 in my case. It has almost finished creating the image, a .dmg file that I really hope will mount, seeing as my other attempt with Disk Utility generated an unmountable image.

    In the meantime, another software has managed to "recover" all of my partition's 300+GB of data; only problem is, it's nested into folders with weird names, and the files are few and with huge sizes. Example: "jpeg" folder with 38 items that range from being ~600MB to more than 2GB. Obviously, I can't preview any of them; what gives? Does this mean that my data is corrupted, or do I need to access it in some other way?
    This is getting pretty confusing.

    Hello, thanks for answering.

    1a, 1b. The SSD has 250GB of storage, of which ~206GB are currently used up.

    2a, 2b. My HDD has 500GB of capacity; there is no actual "free space" because the disk is divided into partitions, but if we consider the free space on each partition, I'd say it's about 110GB in total of non used up space, across all partitions. I'm not sure, though, because the faulty OSX partition doesn't read correctly so it's showing as being full, when I had around 25GB or more of free space when I updated, if I remember correctly.
     
  8. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #8
    Are you saying that you've tried to open the files with Preview (or whatever) and they don't open? You may try renaming a file to have a .jpg extension (if it already doesn't have one) although most software will try to open a file and will figure out what it is based on the file header. I suspect the files are corrupted. In that case, if that's the best that can be done, then you would need software that will intelligently look at the data and try to separate them out (the file headers and in some case footers for most formatted files are pretty distinctive).
     
  9. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #9
    I should clarify what I said in my previous post. Your files may or may not be corrupted. Obviously the file table which lists the files and points to where it's located is corrupted.

    You didn't mention if how you "recovered" the files. If you didn't use the Seagate software - if you look back at the Seagate link I posted, they have a "Types of Files" listing, with "jpg" being one of them. This would imply (I don't know - again I haven't used the software) that it will look for the file header (the beginning portion of the file) and determine it's file type. If the file format has something to indicate "mileposts" along the way, it could use that as well. If the software you used doesn't have this feature (if it doesn't mention file formats it supports, then it likely doesn't have it), then it may be that a more intelligent software will be able to put your files together.
     
  10. RedFlag thread starter macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #10
    Yes, they don't open; I have an icon view and there isn't even a preview of the files. Another example is a "recovered" .doc file, named "385820209.doc", size 5,77GB. Obviously, this isn't one of my documents, it looks like the app took everything under a certain file header and "condensed" most of them - maybe because it wasn't able to separate them out.

    The software itself is Ontrack EasyRecovery; it does have the option to select file extensions, and more, so I'm guessing there's too much going on with my data that any app can understand. I had the same problem with other software, such as Data Rescue 4, EaseUS Data Recovery and Seagate Recovery Suite, as you suggested. Only thing is, those other software found less "files" - still unreadable though, all of them.

    In the meantime, I tried to make another clone of my hdd with different software and still it results in a .dmg file that won't mount because of "missing file systems". *sigh*
     
  11. RedFlag thread starter macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #11
    I just noticed that fdisk has the option to set the whole disk as an HFS+ partition; what if I were to try that? There's also a boothfs option for setting an 8MB boot plus an HFS+ root partition...
    I don't care about the Windows and Linux partitions, I've already backed those up. I'm also noticing something weird with the starting and ending sizes of the sectors, or are they supposed to look like that?

    sudo fdisk /dev/disk1
    Code:
    Disk: /dev/disk1    geometry: 60801/255/63 [976773168 sectors]
    Signature: 0xAA55
             Starting       Ending
     #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    ------------------------------------------------------------------------
     1: EE    0   0   2 - 1023 254  63 [         1 -  588785887] <Unknown ID>
     2: AB 1023 254  63 - 1023 254  63 [ 588785888 -    1269536] Darwin Boot
    *3: 07 1023 254  63 - 1023 254  63 [ 590055424 -  323803136] HPFS/QNX/AUX
     4: 83 1023 254  63 - 1023 254  63 [ 913858560 -   62914063] Linux files*
    
     
  12. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #12
    OP wrote:
    "1a, 1b. The SSD has 250GB of storage, of which ~206GB are currently used up.
    2a, 2b. My HDD has 500GB of capacity; there is no actual "free space" because the disk is divided into partitions, but if we consider the free space on each partition, I'd say it's about 110GB in total of non used up space, across all partitions. I'm not sure, though, because the faulty OSX partition doesn't read correctly so it's showing as being full, when I had around 25GB or more of free space when I updated, if I remember correctly."


    Here is what I'd do if you handed that laptop to me.

    First, I'd get an EXTERNAL drive. 1tb would be good, but even a 500gb external should do in a pinch.

    Next, I'd begin copying stuff from the internal HDD (hereafter referred to as simply the "HDD") to the external drive.
    I'd copy from one partition, then just copy from the next partition, etc.

    I WOULD NOT set up multiple partitions on the external drive, just "dump everything onto it".

    I WOULD NOT worry about the OS on the HDD. What I would do is "manually copy over" the home folders (if you use them on that volume), and any other data, and perhaps applications that are on the HDD but NOT on the SSD.
    I would intentionally "leave this copy of the OS behind".

    The end result will be an external drive with "all your stuff" from the internal HDD saved on it.

    Then...
    I'd use Disk Utility to erase the internal HDD.

    At this point, there's a decision to make. I can't really make it for you, I can only speculate.

    Do you want the internal HDD to "completely reflect" the contents of the SSD, -OR-, do you just want a second bootable drive inside with its "own stuff on it"?

    What I'd do (speaking only for myself).

    I'd partition the HDD into two equally-sized partitions, roughly 250gb.

    NOW -- I'd use CarbonCopyCloner to clone the contents of the SSD onto the FIRST partition of the HDD. The result will be a bootable clone of the SSD on the HDD. It will boot, and appear, EXACTLY as does the SSD (after all, it's "a clone").
    This is an excellent way to have an immediately-accessible alternative boot source if you need one. And eventually YOU WILL NEED ONE.

    NEXT -- I'd start "picking through" the stuff on the external drive, and re-copy it back over to the SECOND partition on the HDD.
    I -WOULD NOT- copy over anything to do with the OS. That is taken care of by the bootable cloned backup on the first partition.
    The HDD can serve as "loose storage" for stuff that wouldn't fit on the internal SSD.
    It will take some thought, some picking and choosing.

    The end result:
    1. The SSD "as it was"
    2. A bootable cloned backup of the SSD on the first partition of the HDD
    3. "The rest of your stuff" on the second partition of the HDD.
    Note: The stuff on the second partition IS NOT SECURE UNLESS you back it up to another drive somewhere. ONE COPY of your stuff "is not enough".

    That's how I'd do it.
    Actually, a very simple process. Just takes a little time, that's all.

    IMPORTANT:
    If you don't already have it, CCC is FREE to download, and it's FREE to use for the first 30 days.
     
  13. RedFlag thread starter macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #13
    I could not access my data on the hdd, or else I would've copied it all and formatted the disk, already.
    I couldn't access my home folders, or any folder at all - the volume didn't mount and wasn't recognized in any way so I did not have access to my files in any way.

    Anyway, the problem was solved by "removing" the partition using gpt and re-adding it, assigning it the correct type (53746F72-6167-11AA-AA11-00306543ECAC) which had somehow gotten messed up during the Sierra installation, probably due to the unusual hybrid MBR on the disk.

    Should the need for any details arise, the solution was posted on Apple StackExchange; I won't link because I'm not sure about forum policy about this, but a simple search should suffice.

    Thank you all anyway for your answers.
     
  14. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #14
    Interesting. Glad you were able to solve your issue. I had not heard of this happening before. You can post the link to the article - I think that would be helpful for people who come across the same issue in these forums.
     
  15. RedFlag thread starter macrumors newbie

    RedFlag

    Joined:
    Jul 6, 2017
    #15
    I'm glad, too! Never been happier to wait on an old hdd's slow loading times... :D
    Also glad I found someone who is clearly an expert at fixing this sort of stuff in particular. Forums are wondrous things! :)

    Here is the question and its resolution, hope it will help someone in the same situation.

    Thanks again to you guys here, too.
     

Share This Page