Quadro K5000 and Windows 10 (Boot Camp)

jeffcorbets

macrumors member
Original poster
Oct 12, 2005
31
0
Hi everyone,

I recently swapped my original stock Radeon 5870 graphics graphics card for a Quadro K5000 (Mac Edition, NIB) on my cMP 5,1. After swapping the cards, I set up Windows 10 and Boot Camp (using the workarounds) with the ultimate goal of doing some SolidWorks CAD work with the machine. Unfortunately, when installing the Nvidia drivers (either the Windows Update version, the SolidWorks-recommended version, or the latest version), the screen immediately goes black and never recovers. The best I can do (sometimes) is reboot and get to a black screen with only a cursor. I end up having to use DDU in Safe Mode to revert to the base SVGA graphics driver.

Interestingly, the Nvidia drivers provided as part of Apple's Boot Camp 5.1 package do not support the card.

When released, Nvidia advertised full Boot Camp support (albeit under Windows 7 and 8.1)...

Has anyone had any success using the K5000 card under Windows 10? If so, what driver version are you running?

Thanks,

Jeff
 
Last edited:

startergo

macrumors 65816
Sep 20, 2018
1,216
452
is this Windows in EFI or legacy mode? What is the partition is it MBR or GPT. If it is GPT then you boot in EFI mode. I only can make Microsoft Basic adapter to work in EFI mode.
 

jeffcorbets

macrumors member
Original poster
Oct 12, 2005
31
0
This is Windows 10 in EFI mode (using a GPT partitioned disk). Like you, only the Microsoft Basic Adapter works.

I could grab another disk and see if legacy mode with an MBR-partitioned disk permits the Nvidia drivers to work correctly - are you able to get the Nvidia drivers to work in legacy mode?

How bad is the performance hit in legacy mode? I had seen comments that one core may get used fully for disk access in legacy mode...

Thanks,

Jeff


is this Windows in EFI or legacy mode? What is the partition is it MBR or GPT. If it is GPT then you boot in EFI mode. I only can make Microsoft Basic adapter to work in EFI mode.
 

startergo

macrumors 65816
Sep 20, 2018
1,216
452
Legacy works
[doublepost=1553368386][/doublepost]I haven't done much testing in Legacy but Windows 10 should not see big difference. Somebody else may chime in with more experience in Legacy