Radeon 5770 and 5870 Upgrade Kits Posted to Apple Store

Courthold

macrumors member
Apr 15, 2005
48
0
Hmm, the 5870 is only labelled as early 2009/late 2010 - is there any reason this won't work on a 2008 model (3,1) as well?

They're specifying the memory speed on that page (e.g. Early 2009 with 1066MHz DDR3 memory) - is that because this is a requirement of some sort, or just for identification purposes?
 

ventro

macrumors 6502a
Original poster
Sep 23, 2006
692
0
Note that the requirements for the 5770 are a 2010 mac pro or higher, and the requirements for the 5870 are a 2009 mac pro or higher. What's up with that? Are us 2008 owners out of luck?
 

iWolf00

macrumors member
Jul 7, 2010
99
0
I am really surprised since the ATI 5870 is not available for 2008 and disturbed since ATI 5770 is available for 2010; Does that mean Apple may stop supporting my 2009 MP's GPU next year?? I am sure there would angry 2008 model Mob.

Amazingly, the mac pro 2010 supports 2 ATI 5770; Is that sign that MP will support SLI or Crossfire in the future? :D
 

iWolf00

macrumors member
Jul 7, 2010
99
0
ATI HD 5870 not available yet

When will apple release the ATI HD 5870 upgrade? do you think its price is fair in comparison with one that work in Win?
 

bilbo--baggins

macrumors 6502a
Jan 6, 2006
705
5
UK
Before these went up people seemed certain they would work on the 2008 Mac Pros. Could this still be the case, despite the Apple Store saying only for 2009 and 2010 models?
 

smacman

macrumors 6502
Feb 7, 2006
452
2
Can't wait until the 5870 is actually available (showing unavailable in Hong Kong). Not that I want it, but I am confused as to why the 5770 is for the 2010 machines only. I thought the 2009 and 2010 were essentially identical with respect to PCI 2.0 bus and power supply.
 

nanofrog

macrumors G4
May 6, 2008
11,719
2
Before these went up people seemed certain they would work on the 2008 Mac Pros. Could this still be the case, despite the Apple Store saying only for 2009 and 2010 models?
Yes. It's happened before.

They claimed the GT120 only worked in the 2009 systems IIRC, when they did work in the 2008 (it uses EFI64), and the HD4870 was claimed it was incompatible with 2006/7 systems, when it worked in those as well (uses EBC).

We don't know for sure yet on the PCIe version of the 5770/5870, as it's not been tested. Someone will play guinea pig... err... test it out I expect. ;)
 

ventro

macrumors 6502a
Original poster
Sep 23, 2006
692
0
Does anyone know how Apple could prevent the card from being run on a '08? Aren't they all EFI64?
 

nanofrog

macrumors G4
May 6, 2008
11,719
2
Does anyone know how Apple could prevent the card from being run on a '08? Aren't they all EFI64?
'08 and newer MP's do use EFI64 firmware.

Graphics cards have a separate ROM on them however, and doesn't have to be EFI64 to function (EBC is an alternative, and it allows cards to run in either EFI32 or EFI64 systems). BIOS will not work under OS X (does under Windows or Linux).
 

bilbo--baggins

macrumors 6502a
Jan 6, 2006
705
5
UK
I will be selling mine when the 5870 is available and I bet a lot of others will be too.
Good point - I'll keep a look out. I guess a number 2009 owners will be upgrading. I'd rather get the 5870, but if they prove to be incompatible then a used 4870 seems like a good idea. I currently have the 8800GT which is fine though I gather that many of them failed. Have many of the 4870's failed?
 

iZac

macrumors 68020
Apr 28, 2003
2,031
1,111
Shanghai
*crosses fingers for my '06*


£370 for the 5870 is a more than i'd like, but as soon as someone confirms it to work with the '06 (wishful thinking perhaps) i'll be dusting off my credit card!
 

DesmoPilot

macrumors 65816
Feb 18, 2008
1,167
25
Hahah! Hilariously over priced for a 5770. Though overpriced, the 5870 isn't too much over.
 

MacsRgr8

macrumors 604
Sep 8, 2002
7,847
1,159
The Netherlands
Yes. It's happened before.

They claimed the GT120 only worked in the 2009 systems IIRC, when they did work in the 2008 (it uses EFI64), and the HD4870 was claimed it was incompatible with 2006/7 systems, when it worked in those as well (uses EBC).

We don't know for sure yet on the PCIe version of the 5770/5870, as it's not been tested. Someone will play guinea pig... err... test it out I expect. ;)
Keep a close eye on Barefeats
 

Similar threads

Replies
10
Views
752
  • Xenobius
20
Replies
20
Views
1K
Replies
2
Views
342
Replies
24
Views
2K
Replies
13
Views
2K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.