Random beachballing ever since installing High Sierra

Discussion in 'macOS High Sierra (10.13)' started by baryon, Jun 8, 2018.

  1. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #1
    • MacBook Pro Retina 15 inch 11.3 (Late 2013)
      • Intel i7, 2.3 GHz
      • 16 GB RAM
      • NVIDIA GeForce GT 750M 2048 MB
      • Intel Iris Pro 1536 MB
    • macOS High Sierra 10.13.5 (17F77)

    Ever since installing High Sierra (I converted to APFS), I've noticed seemingly random, frequent, but short bursts of beachballing. Often this will happen while typing something, usually at the beginning of the task, or when clicking something. These tend to happen a lot during simple basic tasks, not typically CPU intensive tasks. They happen several times a day, and usually last a few seconds during which the computer mostly stops responding (the mouse still moves and what I type during that time will appear once the beachballing is over).


    This never happened in any previous versions of macOS on this computer.


    Below is my EtreCheck report.


    It didn't report any serious issues, and the minor issues don't seem like anything out of the ordinary (some unsigned apps, 32 bit apps, aging battery, some apps crashed in the past 7 days, one orphaned file that I have since cleaned up).

    EtreCheck version: 4.3.2 (4D034)

    Report generated: 2018-06-08 13:22:30

    Download EtreCheck from https://etrecheck.com

    Runtime: 4:04

    Performance: Good


    Problem: Beachballing

    Description:

    The computer will often freeze and display a beachball seemingly randomly during simple tasks, such as typing into the Google search field or writing a comment on a forum. The beachballs last a couple of seconds and happen multiple times a day. This has only been the case since upgrading to High Sierra, and it had never happened before that.

    MacBook Pro 15”, Late 2013, i7, 16GB RAM, 500GB SSD.


    Major Issues: None


    Minor Issues:

    These issues do not need immediate attention but they may indicate future problems.


    High battery cycle count- Your battery may be losing capacity.

    Apps crashing- There have been numerous app crashes.

    Clean up- There are orphan files that could be removed.

    Unsigned files- There is unsigned software installed. They appear to be legitimate but should be reviewed.

    32-bit Apps- This machine has 32-bits apps that may have problems in the future.


    Hardware Information:

    MacBook Pro (Retina, 15-inch, Late 2013)

    MacBook Pro Model: MacBookPro11,3

    1 2.3 GHz Intel Core i7 (i7-4850HQ) CPU: 4-core

    16 GB RAM - Not upgradeable

    BANK 0/DIMM0 - 8 GB DDR3 1600 ok

    BANK 1/DIMM0 - 8 GB DDR3 1600 ok

    Battery: Health = Normal - Cycle count = 712


    Video Information:

    Intel Iris Pro - VRAM: 1536 MB

    Color LCD

    NVIDIA GeForce GT 750M - VRAM: 2048 MB


    Drives:

    disk0 - APPLE SSD SM0512F 500.28 GB (Solid State - TRIM: Yes)

    Internal PCI 5.0 GT/s x2 Serial ATA

    disk0s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

    disk0s2 500.07 GB

    disk1s1 - Macintosh HD (APFS) 500.07 GB (388.74 GB used)

    disk1s2 - Preboot (APFS) [APFS Preboot] 500.07 GB (22 MB used)

    disk1s3 - Recovery (APFS) [Recovery] 500.07 GB (518 MB used)

    disk1s4 - VM (APFS) [APFS VM] 500.07 GB (2.15 GB used)


    disk6 - Disk Image 24 MB (Disk Image)

    External Disk Image

    disk6s1 [Partition Map] 32 KB

    disk6s2 - Flash Player (HFS+) 24 MB


    Mounted Volumes:

    disk1s1 - Macintosh HD 500.07 GB (108.48 GB free)

    APFS

    Mount point: /

    Encrypted


    disk1s4 - VM [APFS VM] 500.07 GB (108.48 GB free)

    APFS

    Mount point: /private/var/vm


    Network:

    Interface en4: iPhone

    Interface en0: Wi-Fi

    802.11 a/b/g/n/ac

    One IPv4 address

    Interface en3: Bluetooth PAN

    Interface bridge0: Thunderbolt Bridge

    iCloud Quota: 3.10 GB available


    System Software:

    macOS High Sierra 10.13.5 (17F77)

    Time since boot: About 6 days

    System Load: 1.73 (1 min ago) 1.81 (5 min ago) 1.78 (15 min ago)


    Security:

    System Status
    Gatekeeper Mac App Store and identified developers
    System Integrity Protection Enabled

    Unsigned Files:

    Launchd: /Library/LaunchDaemons/com.nvidia.cuda.launcher.plist

    Executable: /Library/PreferencePanes/CUDA Preferences.prefPane/Contents/Resources/CUDAd.sh start

    Details: Exact match found in the whitelist - probably OK

    Launchd: ~/Library/LaunchAgents/com.valvesoftware.steamclean.plist

    Executable: /Users/***/Library/Application Support/Steam/SteamApps/steamclean

    Details: Exact match found in the whitelist - probably OK

    Launchd: /Library/LaunchDaemons/com.oracle.java.Helper-Tool.plist

    Executable: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/Helper-Tool

    Details: Exact match found in the whitelist - probably OK


    32-bit Applications:

    33 32-bit apps


    Kernel Extensions:

    /Library/Extensions

    [Not Loaded] FTDIKext.kext (Wacom Technology Corp., 1.0 - SDK 10.11)

    [Loaded] CUDA.kext (NVIDIA Corporation, 1.1.0)


    /System/Library/Extensions

    [Not Loaded] FTDIUSBSerialDriver.kext (2.2.14)

    [Not Loaded] Pen Tablet.kext (Wacom Technology Corp., Pen Tablet 5.3.6-6 - SDK 10.9)

    [Not Loaded] Wacom Tablet.kext (Wacom Technology Corp., Wacom Tablet 6.3.15-1 - SDK 10.11)

    [Not Loaded] SATSMARTDriver.kext (Kirill Luzanov, 0.8.1 - SDK 10.6)


    System Launch Agents:

    [Not Loaded] 8 Apple tasks
    [Loaded] 152 Apple tasks
    [Running] 132 Apple tasks
    [Other] One Apple task

    System Launch Daemons:

    [Not Loaded] 39 Apple tasks
    [Loaded] 167 Apple tasks
    [Running] 130 Apple tasks

    Launch Agents:

    [Running] com.wacom.pentablet.plist (Wacom Technology Corp. - installed 2014-12-23)
    [Loaded] com.adobe.AdobeCreativeCloud.plist (Adobe Systems, Inc. - installed 2018-06-02)
    [Not Loaded] com.teamviewer.teamviewer_desktop.plist (TeamViewer GmbH - installed 2017-05-23)
    [Loaded] org.macosforge.xquartz.startx.plist (Apple Inc. - XQuartz - installed 2016-10-26)
    [Running] com.wacom.wacomtablet.plist (Wacom Technology Corp. - installed 2015-10-05)
    [Not Loaded] com.adobe.GC.Invoker-1.0.plist (Adobe Systems, Inc. - installed 2018-05-31)
    [Other] com.nvidia.CUDASoftwareUpdate.plist (NVIDIA Corporation - installed 2017-12-20)

    Launch Daemons:

    [Other] com.easeus.dataprotectbackup.plist (? 12fff45e - installed 2017-11-07)
    [Not Loaded] com.teamviewer.teamviewer_service.plist (TeamViewer GmbH - installed 2017-05-23)
    [Loaded] com.apple.installer.osmessagetracing.plist (Apple - installed 2018-05-30)
    [Loaded] com.teamviewer.Helper.plist (TeamViewer GmbH - installed 2017-05-23)
    [Loaded] com.wacom.displayhelper.plist (Apple - installed 2018-05-30)
    [Running] com.adobe.acc.installer.plist (Adobe Systems, Inc. - installed 2018-06-02)
    [Loaded] com.adobe.fpsaud.plist (Adobe Systems, Inc. - installed 2018-06-02)
    [Loaded] com.oracle.java.Helper-Tool.plist (? e3fefdd2 - installed 2017-09-06)
    [Loaded] com.nvidia.cuda.launcher.plist (? 20f73770 - installed 2017-12-20)
    [Loaded] org.macosforge.xquartz.privileged_startx.plist (Apple Inc. - XQuartz - installed 2016-10-26)
    [Loaded] com.adobe.agsservice.plist (Adobe Systems, Inc. - installed 2018-05-31)
    [Running] com.adobe.agmservice.plist (Adobe Systems, Inc. - installed 2018-05-31)
    [Loaded] com.nvidia.cudad.plist (NVIDIA Corporation - installed 2017-12-20)

    User Launch Agents:

    [Loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2018-02-04)
    [Loaded] com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2018-04-13)
    [Loaded] com.valvesoftware.steamclean.plist (? 0 - installed 2018-03-17)
    [Not Loaded] com.adobe.GC.Invoker-1.0.plist (Adobe Systems, Inc. - installed 2018-05-31)
    [Not Loaded] com.adobe.AAM.Updater-1.0.plist (? 0 - installed 2016-12-14)

    User Login Items:

    iTunesHelper Application (Apple - installed 2018-05-30)

    (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

    Dropbox Application (Dropbox, Inc. - installed 2018-06-07)

    (/Applications/Dropbox.app)

    SpeechSynthesisServer Application (? - installed 2018-06-02)

    (/System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/SpeechSynthesis.framework/Versions/A/SpeechSynthesisServer.app)


    Internet Plug-ins:

    AdobeAAMDetect: 3.0.0.0 (installed 2018-06-02)

    FlashPlayer-10.6: 30.0.0.113 (installed 2018-06-07)

    QuickTime Plugin: 7.7.3 (installed 2018-06-02)

    Flash Player: 30.0.0.113 (installed 2018-06-07)

    Unity Web Player: UnityPlayer version 4.6.0f3 (installed 2014-11-30)

    WacomTabletPlugin: WacomTabletPlugin 2.1.0.6 (installed 2015-10-05)

    JavaAppletPlugin: Java 8 Update 151 build 12 (installed 2017-12-07)


    Safari Extensions:

    AdBlock.safariextz - BetaFish, Inc. - https://getadblock.com (installed 2017-11-15)
    Omnikey.safariextz - Mario Estrada - http://marioestrada.github.com/safari-omnikey/ (installed 2015-12-14)
    uBlock.safariextz - Chris Aljoudi - https://chrismatic.io/ (installed 2016-03-28)
    Reddit Enhancement Suite.safariextz - Steve Sobel - http://redditenhancementsuite.com/(installed 2016-06-22)

    3rd Party Preference Panes:

    CUDA Preferences (installed 2017-12-20)

    Flash Player (installed 2018-06-02)

    Java (installed 2017-12-07)

    Perian (installed 2011-07-23)

    WacomTablet (installed 2015-10-05)


    Time Machine:

    Skip System Files: No

    Mobile backups: Yes

    Auto backup: Yes

    Volumes being backed up:

    Macintosh HD: Disk size: 500.07 GB - Disk used: 391.59 GB

    Destinations:

    B********B [Local] (Last used)

    Total size: 3.00 TB

    Total number of backups: 18

    Oldest backup: 2017-12-01 19:26:06

    Last backup: 2018-06-02 13:27:06


    Top Processes by CPU:

    Process (count) Source % of CPU Location
    diskutil Apple 100
    WindowServer Apple 1
    kernel_task Apple 1
    Dock Apple 0
    sandboxd Apple 0

    Top Processes by Memory:

    Process (count) Source RAM usage Location
    kernel_task Apple 2.03 GB
    Safari Apple 1.26 GB
    com.apple.WebKit.WebContent (5) Apple 727 MB
    Mail Apple 259 MB
    mds_stores Apple 192 MB

    Top Processes by Network Use:

    Process Source Input Output Location
    mDNSResponder Apple 27 MB 1 MB
    Dropbox Dropbox, Inc. 3 MB 2 MB
    apsd Apple 82 KB 218 KB
    netbiosd Apple 153 KB 55 KB
    Mail Apple 79 KB 33 KB

    Top Processes by Energy Use:

    Process (count) Source Energy (0-100) Location
    diskutil (2) Apple 41
    WindowServer Apple 2
    nsurlstoraged (2) Apple 0
    com.apple.WebKit.Networking (2) Apple 0
    com.apple.WebKit.WebContent (5) Apple 0

    Virtual Memory Information:

    Available RAM 5.24 GB
    Free RAM 1.99 GB
    Used RAM 10.76 GB
    Cached files 3.25 GB
    Swap Used 539 MB

    Software Installs (past 30 days):

    Name Version Install Date
    Wave Agent Beta 2.9 2018-05-09
    Tag Editor Free 1.0.8 2018-05-12
    Shooter Suite 13.1.6 2018-05-19
    iTunes 12.7.5 2018-05-30
    Gatekeeper Configuration Data 140 2018-06-01
    Adobe Flash Player 30.0.0.113 2018-06-07

    Clean up:

    /Library/LaunchDaemons/com.easeus.dataprotectbackup.plist

    /Applications/EaseUS Data Recovery Wizard.app/Contents/MacOS/EaseUS Data Recovery Wizard.app/Contents/Resources/EUDataDaemon.app/Contents/MacOS/eudataback

    Executable not found


    Diagnostics Information (past 7 days):

    2018-06-07 22:24:10 Offload.app Crash

    /Applications/Offload.app

    terminating with unexpected exception of type boost::filesystem::filesystem_error: boost::filesystem::remove: Directory not empty: "/Users/***/Library/Application Support/Red Giant/Offload/Events/07_06_2018-1/fscache_thumb_cache"

    abort() called


    2018-06-07 15:49:31 Dropbox.app Crash (4 times)

    /Applications/Dropbox.app


    2018-06-07 14:53:06 Canon IJScanner6.app CPU

    /Library/Image Capture/Devices/Canon IJScanner6.app


    2018-06-02 16:37:57 WacomTouchDriver.app Crash

    /Library/Application Support/Tablet/WacomTabletDriver.app/Contents/Resources/WacomTouchDriver.app


    2018-06-01 23:17:53 Get Backup Pro 3.app Hang (2 times)

    /Applications/Get Backup Pro 3.app



    End of report
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    You have a lot of third party launch items there, and I'm wondering if one or more of those is incompatible with High Sierra. As a test, reboot while holding the shift key to boot to safe mode. That stops all those items from running. If that fixes it, then start removing those items until you find the culprit.
     
  3. nagual macrumors member

    Joined:
    Apr 4, 2012
    #3
    would Activity Monitor show any culprit offender, just curious?
     
  4. Horselover Fat macrumors regular

    Joined:
    Feb 2, 2012
    Location:
    Germany
    #4
    This sounds exactly like the symptoms I described here: https://forums.macrumors.com/threads/are-my-heatsink-retainers-broken-cmp-2009.2121963/

    My freezes occur once or twice a day without any significant CPU use. Sometimes the beachball even stops turning. And I'm never able to switch to Activity Monitor during the freeze.

    I'm still trying to find out whether it's a hardware or software failure. I only changed two major things before the freezes appeared: CPU upgrade to 2x5690 (it's a dual CPU MP 2009 flashed to 5,1) and upgrade to High Sierra. CPU swap is too long ago and I stress-tested them CPUs whithout any freezes. But I will boot into windows to clarify things. And I think a safe boot into macos is a good idea as well. Did your freezes start with 10.13.1 or later? I think it was later for me, but I'm not sure.

    As soon as I find out anything, I'll post here.
     
  5. bbnck macrumors 6502a

    Joined:
    Mar 19, 2009
    #5
    I take it "EaseUS Data Recovery" is a backup utility you use? Check if it's performing a full backup since your upgrade to macOS High Sierra. But as suggested, you could boot into Safe Mode and hopefully if the issue is frequent enough, you can see if it happens there. Another option is to check the CPU tab in Activity Monitor when you experience a spike in use (make sure the "% CPU" column is set in descending order). Keep Activity Monitor open so you can check quickly when you experience a spike in usage.
     
  6. baryon thread starter macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #6
    Actually I tried EaseUS Data Recovery once but deleted it while it was still on trial. Apparently that's garbage left on the system, but I have no idea where the file could be. It's not in Launch Deamons, and it's not showing up in a spotlight search so I have no idea how I could delete it!

    I'll try safe mode but I'd have to use the computer for a whole day to give it a chance. And in safe mode there isn't much useful work to do so I doubt I'll have a chance to try it out for long enough...

    I've read somewhere that disabling iCloud Drive helped someone, so I tried that and so far maybe it helped, need more time to make sure...
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    /Library/LaunchDaemons/com.easeus.dataprotectbackup.plist

    The Etrecheck report is showing it in LaunchDaemons. Sure you are looking in the main Library and not the users ~/Library folder.

    Here are folders where you can find some of these items listed in the report.

    ~/Library/LaunchAgents (~ is your users folder)
    /Library/LaunchAgents
    /Library/LaunchDaemons
    /Library/StartupItems
    /System/Library/Extensions/
     

Share This Page