Reseting PRAM. Mission: impossible.

Discussion in 'MacBook Pro' started by beth.null, Sep 17, 2017.

  1. beth.null macrumors newbie

    beth.null

    Joined:
    Sep 11, 2017
    #1
    Hi!

    I have a early 2011 macbook pro with a failed AMD GPU and I'm trying to fix it following the instructions of that MacRumors thread.

    However I'm in a dead end trying to resetting the PRAM. I need it in order to reset the startup disk and make the laptop boot from OSX which has been installed in the SSD using a macbook air.

    I can't reset the PRAM because a few years ago I set a firmware password. It seems that this is preventing the cmd + alt + p + r combo keys working. At the same time I can't boot into recovery or Sierra because it hangs while booting due to the faling gpu.

    Also I can't boot into single user mode because before pressing cmd + s I have to choose the startup disk with alt and to my knowledge and tries, pressing the cmd + s combo after clicking in the startup partition I want to boot from isn't working.

    Any idea or suggestion?

    Thanks in advance for your support.
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    "Any idea or suggestion?"

    This won't help now, but on THE NEXT Macbook you buy, DON'T set a firmware password. They can "get you" at the wrong moment -- as you've now discovered.

    Perhaps it's time to start shopping for a new MacBook.

    After you're up-and-running with the new one, open the 2011, remove the internal drive (it's an easy procedure), put it into a USB3 enclosure, and you have a good shot at getting the data off of it...
     
  3. beth.null thread starter macrumors newbie

    beth.null

    Joined:
    Sep 11, 2017
    #3
    Hi,

    Well, actually the internal hard drive has a clean Sierra installation, so I don really care too much in what is inside the hd.

    And yes, next time I won't set the firmware password, however I can't believe that there is no way to reset the PRAM in this situation. Installing Linux is another option however I don't want to give up.

    All this stuff is just to execute a nvram command in single user mode, but I can't find a method to boot in single user mode. Yesterday I tried to install OSX Lion but it also hangs and snow leopard seems not to work too, but I'm not very confident with the usb install that I tried, I must test it again. What I'm looking with this old versions is my guess that they're not going to use the secondary graphic chip and let me boot and execute the nvram command I need.

    Thanks for your answer.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    That firmware password is working as designed and blocking what you are trying to do. There is no way to remove that FW password yourself. Take it to the Apple store with proof of ownership and they can remove it for you.

    This explains how they do it.
     
  5. beth.null thread starter macrumors newbie

    beth.null

    Joined:
    Sep 11, 2017
    #5
    Hi guys!

    As incredible as it may sound I managed to fix the macbook.

    I've used an archlinux to boot the laptop and using a pen drive with a copy of gpu-switch I managed to execute it and force to use the integrated graphics card. I don't know why I wasn't able to execute the same commands that gpu-switch executes.

    Anyway after that, I was able to boot in recovery mode, disable there the firmware password, set the startup disk, and boot OSX Sierra.

    And that's all till the nvram setting maintains the AMD GPU disabled and I'll have to do the process again, at least I've a working computer.

    Again, thanks for being so supportive.

    All the best,
    beth.
     

Share This Page

4 September 17, 2017