AppleMacFinder

macrumors 6502a
Original poster
Dec 7, 2009
796
143
If you don't have time to read my story (which also describes some interesting technical approaches) just scroll down this thread until a "100% WORKING SOLUTION" text

Discrete AMD GPU of my 2011 MacBook Pro 8,2 has finally failed because of the reasons mentioned here ( http://logicboardmac.blogspot.ru/ ) and there ( https://www.macrumors.com/2015/02/19/2011-macbook-pro-repair-program-apple/ ) . It has been working perfectly for 6 years under quite a high load, even tried SETI@HOME mining at background! So I was confident that my MBP is not affected by bad solder / bad soldering quality and didn't want to bring it to Apple for a free repair program - partially because couldn't find the time to pause my important software projects, partially because I was afraid that Apple might give me a less reliable logic board or refuse a free repair because of the several unrelated repairs that I did manually by myself earlier to save money: changed thermal paste a few times, replaced the internal battery 2 times, replaced a keyboard with broken buttons, etc. But it finally broke down last week: laptop's screen image became distorted, it refused to boot OS X (always freezing half-way), and - Apple free repair program has already ended! I know there are affordable solutions like $50 BGA resoldering at unofficial local repair shop and that its possible to get a new replacement HD 6750M chip from AliExpress for $35 or cheaper ( http://www.aliexpress.com/item/DC-2...0028-216-0810028-BGA-Chipset/32764872143.html or https://www.aliexpress.com/item/DC-2015-New-216-0810001-216-0810001-Graphic-Chipset/32718112928.html , because don't know if this is true - https://www.rossmanngroup.com/board...0604-replace-216-0810005-gpu-with-216-0810028 ) to guarantee a successful repair, so the total price of repair would be either $50 or $50+$35=$85 - less than $100 in any case. But I don't like investing money to the old computers, so I have thought - what if there is some hack to force MBP to use integrated graphics ALL THE TIME, even while booting ? And then started to explore the possible solutions...

===

First of all, it is possible to successfully boot a MBP to OS X while still using the failed GPU, after you remove the AMD drivers by booting in command line mode (CMD+S) and entering these commands:
1) fsck -fy (to check a disk)
2) mount -uw / (mount a root filesystem with read/write permissions)
3) sudo mkdir /AMD_Kexts/ (make a directory to store the AMD drivers in case you'll need them in future)
4) sudo mv /System/Library/Extensions/AMD*.* /AMD_Kexts/ (move the AMD drivers)
5) sudo rm -rf /System/Library/Caches/com.apple.kext.caches/ (remove the AMD drivers cache)
6) sudo mkdir /System/Library/Caches/com.apple.kext.caches/ (just in case OS X will be dumb and will not recreate this directory, I am creating it for OS X)
7) sudo touch /System/Library/Extensions/ (to update the timestamps so that new driver caches - without AMD drivers - will be definitely rebuilt)
8) sudo umount / (umount a partition to guarantee that your changes are flushed to it)
9) sudo reboot

The degree of your inconvenience while doing these steps - strongly depends on how heavily a screen's image is distorted in your case. In my case it was even more difficult because the OS X partition became a "read-only" partition (because of too many emergency shutdowns I did while desperately trying to boot OS X with a failed GPU) so I had to remove a hard drive from MacBook Pro and (using a USB to SATA 2.5" adapter taken from my portable HDD) attached it to a computer with Linux, then followed these instructions:

https://superuser.com/questions/961401/mounting-hfs-partition-on-arch-linux (1st answer) - carefully executed a number of commands, calculated a sizelimit for my parition layout, and finally ran sudo mount -t hfsplus -o force,rw,sizelimit=YOURNUMBER /dev/sdb2 /mnt to mount this HFS+ partition to /mnt directory in read-write mode. Then I performed these "1)-7)" steps you see above, and also repaired a filesystem by running sudo fsck.hfsplus -f /dev/sdb2 before unmounting a partition with sudo umount /mnt and putting a hard drive back to MBP...

===

This gave me a MBP which could boot to OS X although STILL using a broken AMD GPU: so it screen's image is very distorted (could browse the Internet but quite inconvenient to read a text), Launchpad is super laggy, and you can't switch to Integrated GPU using gfxCardStatus because: without AMD drivers (which we had to remove to successfully boot to OS X) Macbook Pro thinks its' internal screen is External Display and gfxCardStatus tells it is impossible to switch because External Display is using AMD GPU. Somewhere I found a suggestion that it is possible to rebuild a gfxCardStatus from the source code - https://github.com/codykrieger/gfxCardStatus - with removed or commented out 156-166 lines in the ./gfxCardStatus/Classes/GSProcess.m to make it to ignore the external display:

// find out if an external monitor is forcing the discrete gpu on
CGDirectDisplayID displays[8];
CGDisplayCount displayCount = 0;
if (CGGetOnlineDisplayList(8, displays, &displayCount) == noErr) {
for (int i = 0; i < displayCount; i++) {
if ( ! CGDisplayIsBuiltin(displays))
[list addObject:[NSDictionary dictionaryWithObjectsAndKeys:
Str(@"External Display"), kTaskItemName,
@"", kTaskItemPID, nil]];
}
}


So I rebuilt a gfxCardStatus using the instructions from the last reply of this issue -
https://github.com/codykrieger/gfxCardStatus/issues/229
(also had to download a MacOSX10.11.sdk from here - https://github.com/phracker/MacOSX-SDKs/releases - unpack and copy it to XCode's /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk - because of the Apple's stupidity the latest XCode for El Capitan does not include SDK for El Capitan!) However, it still didn't work - gfxCardStatus only pretended that it has switched to Integrated GPU, while in reality OS X did not let it switch! Even after I edited ./gfxCardStatus/Classes/GSGPU.m file to enable the mysterious "Nuke it from orbit switching" option, it still couldn't switch...

===

Then I discovered this interesting repository - https://github.com/0xbb/gpu-switch - which is partially similar by its' source code to gfxCardStatus but also has the "Login Hooks" (install_hooks.sh) to "automate the switching process for login/logout". Sadly it didn't work for me... However, there is a very interesting gpu-switch text file right at the root of this repository, which describes the EFI variables!

https://github.com/0xbb/gpu-switch/blob/master/gpu-switch

After studying it and also reading this issue's comments - https://github.com/0xbb/gpu-switch/issues/11 - I became confident to try this solution, but found out that my MacBook Pro 2011 8,2 with OS X El Capitan 10.11.6 is in a VERY problematic situation:

1) rEFInd is not installed, and to install it - must disable SIP protection. But I cannot boot to Recovery mode (Command+Option+R) or to OS X Installation DVD/USB (hold Option), (to disable SIP), because they freeze while booting! - although I removed AMD kexts from my system, of course these recovery tools are using AMD kexts integrated to their design. Also cannot use Rootfool hack ( https://github.com/gdbinit/rootfool ) to disable SIP during runtime, because it works only at OS X version older than 10.11.4

2) Tried overheating my Macbook Pro on purpose (forcing CPU usage to 100% and putting it to a tightly closed bag) to force it to shutdown from overheating and then quickly reboot so that Integrated graphics will be enabled during the boot time - making it possible to boot to Recovery. But because of the wonderful high end thermal paste I have applied not so long ago - cannot overheat it even after waiting for a long time! At this point I thought that could either: a) remove AMD kexts from Installation media, or b) to connect MBP's hard drive to a Linux machine again and run a bunch of chmods to remove the SIP flags from the directories mentioned here ( http://apple.stackexchange.com/questions/193368/what-is-the-rootless-feature-in-el-capitan-really ) which could potentially make a system unbootable, or c) to try installing rEFInd to HFS+ partition directly from a Linux machine with root rights because it will bypass SIP --- but have not explored these options, although some of them might have worked...

3) Wanted to boot a Linux LiveCD to edit the EFI variables from there, but no matter what I did: tried booting straight without GRUB option modifications, tried editing GRUB boot options (with "e" key) to add nomodeset / remove quiet splash / or both in every combination , or like suggested in this article ( https://wiki.archlinux.org/index.php/MacBookPro8,1/8,2/8,3_(2011) ) also add i915.modeset=0 radeon.modeset=0 or radeon.modeset=0 i915.modeset=1 i915.lvds_channel_mode=2 ; and then pressed Fn+F10 or Shift+Ctrl+Fn+F10 to boot with these options: but the Linux boot process always failed at different boot stages, no matter what popular user-friendly Linux distribution or what version of it I am trying: tried many releases of Ubuntu / Lubuntu / Fedora , even the old "AMD64 Mac" and "Alternate AMD64 Mac" images, but they always failed - either at the very beginning of boot process (black screen, or a black screen with a blinking or stuck _ character at the left upper corner) or failed at the very end of it - right before it is supposed to show a graphical desktop environment...

Later, totoe_84 wrote that he was able to boot Ubuntu in graphical mode using the following setup for GRUB:
  • To disable the AMD graphics card I added the following lines after set gfxpayload=keep
outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0
  • Next I added the following after quiet splash
    i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0
(based on https://ubuntuforums.org/showthread.php?t=2157775 )

===

Then I remembered that there are not-mainstream Linux distributions for advanced users, which have a LiveCD without any graphical interface: you are dropped to a pure console and you are supposed to install the system along with only those graphical interfaces and software packages / groups of packages which you explicitly select. For example: Arch Linux (https://www.archlinux.org/) and Gentoo Linux (https://gentoo.org/) . Because their LiveCD does not have a graphical interface, they could be booted without a problem to a pure Linux console and there you could edit the EFI variables ! So here is a...

===
=== 100% WORKING SOLUTION
===
=== Force your MBP to ALWAYS use Intel integrated GPU (EFI variable fix)
===
=== to make it great again ! ;)
===


1) Create the Arch Linux LiveCD/LiveUSB :

You need a working computer for that and a spare CD/DVD/USB drive. After downloading archlinux-2017.03.01-dual.iso (see the links below) you have to check the integrity of the .ISO file to see if it is not corrupted (avoid I/O error, printf: not found, chattr: not found, etc). After checking the integrity of archlinux-2017.03.01-dual.iso and everything is OK, then you can generate an ArchLinux boot disk.

archlinux-2017.03.01-dual.iso

MD5:
1d25235e7cebe45f93452fbc05a0fb66 archlinux-2017.03.01-dual.iso

SHA1
f426866ca632a35a3eeae8e4080cff25ec8da614 archlinux-2017.03.01-dual.iso

Official website ArchLinux (only Torrent) - See MD5 and SHA1 hash numbers:

https://www.archlinux.org/releng/releases/2017.03.01/

The MD5 and SHA1 of the official ArchLinux website are the same as the mirrors Virtapi.org and Belnet.be. The archlinux-2017.03.01-dual.iso on Virtapi.org and Belnet.be are legitimate.

Virtapi.org:

http://archive.virtapi.org/iso/2017.03.01/

http://archive.virtapi.org/iso/2017.03.01/archlinux-2017.03.01-dual.iso

http://archive.virtapi.org/iso/2017.03.01/md5sums.txt

http://archive.virtapi.org/iso/2017.03.01/sha1sums.txt

Belnet:

http://ftp.belnet.be/pub/archlinux.org/iso/2017.03.01/

http://ftp.belnet.be/pub/archlinux.org/iso/2017.03.01/archlinux-2017.03.01-dual.iso

http://ftp.belnet.be/pub/archlinux.org/iso/2017.03.01/md5sums.txt

http://ftp.belnet.be/pub/archlinux.org/iso/2017.03.01/sha1sums.txt

Check for archlinux-2017.03.01-dual.iso integrity (Mac OS):

Boot in Safe Mode (press SHIFT key at boot) -> no freeze Mac OS -> El Capitan or Sierra.

HighSierra maybe freeze at boot time (Safe Mode). There were changes in the HighSierra in relation to the AMD kexts loaded during the Safe Mode. More tests are needed.

File downloaded -> /Users/Your_User/Downloads/archlinux-2017.03.01-dual.iso

Finder -> Applications -> Utilities -> Terminal:

MD5:
Code:
cd Downloads/

md5 archlinux-2017.03.01-dual.iso
MD5 (archlinux-2017.03.01-dual.iso) = 1d25235e7cebe45f93452fbc05a0fb66
SHA1:
Code:
cd Downloads/

shasum archlinux-2017.03.01-dual.iso
f426866ca632a35a3eeae8e4080cff25ec8da614  archlinux-2017.03.01-dual.iso
Or try the simplest way - No needed ArchLinux - Only MacOS:

1 - Boot Single User (press Command + S) at boot (If you have MacOS installed on your hard drive).

2 - If you have a blank HD, then use the USB stick/Pendrive with the MacOS installer (El Capitan, Sierra or HighSierra).

2.1 - Press Option key at boot, Position the mouse on the MacOS installer icon.

2.2 - Press Command + S and keep holding these two keys.

2.3 - Click the MacOS installer icon -> continue holding the Command + S keys until you finish the MacOS installer Single User boot .

Enter these commands (change gpu-power-prefs to Intel GPU and boot verbose):

Code:
nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

nvram boot-args="-v"

reboot
If you've chosen the Arch Linux route, please continue reading:

Then you could either simply burn this ISO to CD/DVD (which later could be either inserted to MBP's SuperDrive or External DVD Drive connected to MBP by two USB cables) or create a bootable USB: use the great detailed instructions from this page, https://wiki.archlinux.org/index.php/USB_flash_installation_media

2) Boot to it: insert this CD/DVD/USB to Macbook Pro, hold Option key while booting, choose "EFI boot" (that is your bootable installation media), press "e" key to edit the GRUB options of the Arch Linux archiso x86_64 UEFI CD menu entry while it is selected at the main screen, add nomodeset to the end of this line and press Enter. If everything is done correctly, you will find yourself at the Linux console!

3) Edit EFI vars: looks like efivarfs filesystem is mounted by default! So you can already cd /sys/firmware/efi/efivars and ls to explore this directory and see if there is a "gpu-power-prefs-..." variable (where ... is UUID of this variable). If there is such a variable, its better to remove it with rm. In my case the efivarfs has been mounted by default with read/write permissions, but if you are getting the "operation not permitted" message while attempting to rm, it means that in your case efivarfs has been mounted as read-only and you need to remount it with read-write permissions and try again (credits to totoe_84 for this valuable addition) :
*) cd /
*) umount /sys/firmware/efi/efivars/
*) mount -t efivarfs rw /sys/firmware/efi/efivars/
*) cd /sys/firmware/efi/efivars/

If your screen is so distorted that it is difficult to see the letters, just start typing the rm gpu-power-pre and then press TAB key for autocompletion. In my case there were not such a EFI variable, only "gpu-active-..." and maybe somehow related "gfx-saved-config-restore-status-..." . Then I looked again at that gpu-switch text file (mentioned above, https://github.com/0xbb/gpu-switch/blob/master/gpu-switch),
and entered THESE COMMANDS:

*) chattr -i "/sys/firmware/efi/efivars/" <----- skip this command

Actually a gpu-switch script had "${sysfs_efi_vars}/${efi_gpu}" but I didnt have a "gpu-power-prefs-..." variable - so, partially by mistake, I didn't add that efi_gpu suffix and entered this incomplete path accidentally

*)
printf "\x07\x00\x00\x00\x01\x00\x00\x00" > /sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9

Did not have a EFI "gpu-power-prefs-" variable so I thought that it will be OK to create a new one with a random UUID - in this case, taken directly from a gpu-switch script

*) chattr +i "/sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9"

http://www.tecmint.com/chattr-command-examples/ - chattr (Change Attribute) is a command line Linux utility that is used to set/unset certain attributes to a file in Linux system to secure accidental deletion or modification of important files and folders, even though you are logged in as a root user.
...
Syntax of chattr ---> chattr [operator] [flags] [filename]
...
A file is set with ‘i‘ attribute (+i as you see in this command) ---> cannot be modified (immutable). Means no renaming, no symbolic link creation, no execution, no writable, only superuser can unset the attribute.
...
Operator
  1. + : Adds the attribute to the existing attribute of the files.
  2. : Removes the attribute to the existing attribute of the files.
  3. = : Keep the existing attributes that the files have.
This chattr command is supposed to lock a file to make it accessible only by "superuser" - and so that, while booting, your EFI will have no chance to screw up your gpu-power-prefs-... variable under any circumstances

*) cd /

Could not unmount efivars if you are inside this directory, so change to the root directory

*) umount /sys/firmware/efi/efivars/

Guarantees that your EFI variables are flushed to efivarfs filesystem, please unmount it safely before rebooting)

*) reboot

===> IF YOU DID EVERYTHING CORRECTLY, MOST LIKELY THAT YOUR MACBOOK PRO IS NOW USING INTEGRATED GRAPHICS WHILE BOOTING, AFTER BOOTING, AND IS WORKING GREAT AGAIN ! ;)

In the future maybe you could need to re-apply this solution if you would have to reset your PRAM / NVRAM / SMC because of some other problems, so remember this solution somewhere... Funny thing: now you can't switch to Discrete GPU even using gfxCardStatus, it is forever stuck at Integrated

I spent two working days to discover this solution, and really hope that it will work flawlessly for every MBP owner with a broken discrete GPU. Good luck!

=== NEWS ! YOU COULD ALSO FOLLOW THESE GUIDES FOR THE EXTRA IMPROVEMENTS : ===

Follow the MikeyN Guide - page 35 - #875 - to move the AMDRadeonX3000.kext from the /System/Library/Extensions directory and do not freeze Macbook Pro (at 75% progress bar or "IOConsoleUsers: gIOScreenLockState 3" message).

Rename old AMDRadeonX3000.kext and move new AMDRadeonX3000.kext after update - Page 57 - #1425

Shutdown or Restart Macbook Pro - avoid black screen freeze - Update 2 - Page 57 - #1425

Close the Lid - Sleep - Waking - Page 43 #1066 - Page 50 #1243
 
Last edited:

ZapNZs

macrumors 68020
Jan 23, 2017
2,310
1,155
Holy crap thank you for your work. I have written Apple BEGGING them to do something like this involving changing the EFI's default to dGPU on boot, but no go with them thus far.

I am going to give this a go.
 

AppleMacFinder

macrumors 6502a
Original poster
Dec 7, 2009
796
143
Holy crap thank you for your work. I have written Apple BEGGING them to do something like this involving changing the EFI's default to dGPU on boot, but no go with them thus far.

I am going to give this a go.
Thank you for the kind words, ZapNZs, hopefully you make your Mac great again by this instruction ;)
 

slapple

macrumors 6502
Jul 25, 2008
442
13
AppleMacFinder, would your solution also let someone boot into Windows using the integrated GPU? I heard with Boot Camp, the MBP will always use the discrete GPU in Windows.
 
  • Like
Reactions: AppleMacFinder

AppleMacFinder

macrumors 6502a
Original poster
Dec 7, 2009
796
143
AppleMacFinder, would your solution also let someone boot into Windows using the integrated GPU? I heard with Boot Camp, the MBP will always use the discrete GPU in Windows.
Hi slapple,

1) This purely software fix is at EFI BIOS level. In theory it should work with ANY operating system in existence, that is:
*) compatible with Macbook Pro hardware (x86_64 aka AMD64 CPU architecture - https://en.wikipedia.org/wiki/X86-64 )
*) compatible with MBP's version of EFI firmware (ancient OS without EFI support will not work straight out of the box, although there should be a way to launch them in some compatibility mode, also some weird OS could be incompatible with Apple's version of EFI)

Actually this EFI variables fix could bring a great benefit to those MBP 2011 users who would like to dual boot their OS X with Linux: because of Apple's highly specific method of connecting two GPUs in this machine, sometimes it was difficult to setup even the popular Linux distributions. Don't blame AMD, it was the first Apple's laptop with AMD in dual graphics so probably Apple didn't have the time to develop a good dual graphics implementation. With dual graphics disabled, now it should be much easier to setup any Linux, just have not tested it yet...

2) Even without this EFI variable fix it should be somehow possible to switch to Intel GPU in Windows, if both GPUs are visible to Windows through PCI (if EFI does not cut out the PCI access to it for operating systems running under BootCamp), although it could require some messing with the drivers. Also I completely agree with ah- :
It should work, if you boot in EFI mode. Only recent MBPs (11,3 and up I think) disable the intel GPU in Windows, and there are workarounds: https://github.com/0xbb/gpu-switch
It is possible to keep several OS (including Windows) on a Mac without any Bootcamp, just using a rEFInd - http://www.rodsbooks.com/refind/

BTW why not run Windows in a virtual machine? For example: several years ago I made some benchmarks of native OS X performance vs Windows inside a Parallels Desktop, and while the graphic performance hit was somewhere around 35%, the CPU performance was just about 2% slower. Right now the difference should be much smaller, because "several years" is a big time for any software to improve, especially for a popular virtualization software. If you don't like to pay or to pirate, try some freeware virtualization tools like VirtualBox and QEMU. Maybe even Wine could be suitable for your needs
 
Last edited:

magicaltrevor70

macrumors newbie
Mar 19, 2017
4
4
Thanks for providing this, but unfortunately it does not work for me.

When trying to rm the "gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9" file, I get:

Cannot remove 'gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9' Operation not permitted

When attempting to do the printf command, I get:

zsh: operation not permitted: /sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9

Even though I am logged in as root, it seems that cannot change that file
 
  • Like
Reactions: AppleMacFinder

AppleMacFinder

macrumors 6502a
Original poster
Dec 7, 2009
796
143
1) Cannot remove 'gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9' Operation not permitted

2) zsh: operation not permitted: /sys/firmware/efi/efivars/gpu-power-prefs-fa4ce28d-b62f-4c99-9cc3-6815686e30f9
Are you doing it from Arch Linux LiveCD ? If you are trying it from OS X or OS X recovery, SIP protection wouldn't let you to allow that. Try with Arch Linux LiveCD and it should work for you
 

CarefreeCanadian

macrumors newbie
Mar 18, 2017
2
2
Are you doing it from Arch Linux LiveCD ? If you are trying it from OS X or OS X recovery, SIP protection wouldn't let you to allow that. Try with Arch Linux LiveCD and it should work for you
I am having the same issue of not being able to modify efivars. I'm doing it from an Archlinux Live USB with SIP disabled. I've tried remounting efivars r/w but I am still getting "operation not permitted."

Has anyone found a solution to this?
 
  • Like
Reactions: AppleMacFinder

totoe_84

macrumors newbie
Mar 19, 2017
3
19
Varese, Italy
I am having the same issue of not being able to modify efivars. I'm doing it from an Archlinux Live USB with SIP disabled. I've tried remounting efivars r/w but I am still getting "operation not permitted."

Has anyone found a solution to this?
First of all thank you @AppleMacFinder for your work! Today I was able to use again my macbook pro early 2011 with the integrated gpu.

@CarefreeCanadian I esperienced the same problem using an Ubuntu Live 16.10 distribution and I solved the issue with the following steps:

To remove “gpu-power-prefs-..." variable it is necessary first of all to unmount efivars:

*) umount /sys/firmware/efi/efivars/

then mount efivars in read/write mode:

*) mount –t efivarfs rw /sys/firmware/efi/efivars/

*) chattr -i /sys/firmware/efi/efivars/gpu-power-prefs-[press TAB to autocomplete]

*) rm /sys/firmware/efi/efivars/gpu-power-prefs-[press TAB to autocomplete]

after this additional steps you can follow the @AppleMacFinder guide

I hope this can help someone else.
 

AppleMacFinder

macrumors 6502a
Original poster
Dec 7, 2009
796
143
I am having the same issue of not being able to modify efivars. I'm doing it from an Archlinux Live USB with SIP disabled. I've tried remounting efivars r/w but I am still getting "operation not permitted.
operation not permitted
First of all, whether SIP is enabled or disabled - should not matter because SIP is OS X feature and Linux ignores those SIP flags. Friends with "operation not permitted" problem, I need to know more about your hardware/software configuration, to understand - what is a negative difference between mine and yours configurations which prevents you from achieving the success. For example: are you booting to ArchLinux through rEFInd? Because I am not using rEFInd, booting straight from Mac's EFI by holding "Option" key. Also I don't know if it matters, but are you on macOS Sierra? Because my OS is El Capitan (10.11.6), and theoretically it could be that Sierra somehow locks the EFI variables... Also we should try searching this problem at the Internet, because this might be an issue not isolated to MBP...
EDIT: please read totoe_84 message above
[doublepost=1489960984][/doublepost]
I esperienced the same problem using an Ubuntu Live 16.10 distribution and I solved the issue with the following steps
totoe_84, I am surprised that you were able to boot Ubuntu, because this graphical issue should have prevented it from booting... In any case, well done! ;)
 

totoe_84

macrumors newbie
Mar 19, 2017
3
19
Varese, Italy
First of all, whether SIP is enabled or disabled - should not matter because SIP is OS X feature and Linux ignores those SIP flags. Friends with "operation not permitted" problem, I need to know more about your hardware/software configuration, to understand - what is a negative difference between mine and yours configurations which prevents you from achieving the success. For example: are you booting to ArchLinux through rEFInd? Because I am not using rEFInd, booting straight from Mac's EFI by holding "Option" key. Also I don't know if it matters, but are you on macOS Sierra? Because my OS is El Capitan (10.11.6), and theoretically it could be that Sierra somehow locks the EFI variables... Also we should try searching this problem at the Internet, because this might be an issue not isolated to MBP...
EDIT: please read totoe_84 message above
[doublepost=1489960984][/doublepost] totoe_84, I am surprised that you were able to boot Ubuntu, because this graphical issue should have prevented it from booting... In any case, well done! ;)
@AppleMacFinder I was able to boot Ubuntu in graphical mode using the following setup for GRUB:
  • To disable the AMD graphics card I added the following lines after set gfxpayload=keep:
outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0​
  • Next I added the following after “quiet splash”:
    i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0​
I found this procedure on https://ubuntuforums.org/showthread.php?t=2157775
 

CarefreeCanadian

macrumors newbie
Mar 18, 2017
2
2
@totoe_84, unmounting then remounting my efivars solved my issue with no requirement to disable SIP. Thank you.

Also, thank you @AppleMacFinder for posting this solution! You saved us all a lot of trial and error and have provided a great solution to the "failed macbook pro 2011" community :)
 
  • Like
Reactions: AppleMacFinder

muratura

macrumors member
Mar 20, 2017
40
29
Awesome post @AppleMacFinder !
I had the same problem and did some of your steps like 2 years ago, but I quit mid way :D, not as patient as you are.

I did manage to find a way to overheat the laptop pretty consistently. Mine was also cleaned and with the thermal paste replaced. I bundled it in a thermal blanket and in my ski jacket while covering the vents :). It got pretty hot you couldn't hold it in your hands and you had to restart it several times before it booted in igpu mode but it worked
 

ZapNZs

macrumors 68020
Jan 23, 2017
2,310
1,155
What is the easiest way to explore the gpu-power-pref variable?
If there is one, do I begin the statement with "rm"?
 
Last edited:
  • Like
Reactions: AppleMacFinder

roberthallin

macrumors member
Oct 25, 2009
89
25
Stockholm, Sweden
I'm totally new to this, but I get through totoe_84's instructions without any problems, then I change the directory to efivars. When I type the chattr-command from AppleMacFinder's instructions all that happens is that a sad smiley appears on the right side of the screen and the command line jumps down one step and it now says 1 root at the beginning. Am I missing something? I've typed the command in verbatim, several times.
 
Last edited:
  • Like
Reactions: AppleMacFinder

Altis

macrumors 68030
Sep 10, 2013
2,986
4,480
Wow, this is great stuff!

Wish Apple could be bothered to help people out like you've done here... it's one of the reasons I bought a 2010 17" instead of the better but risky 2011.
 
  • Like
Reactions: AppleMacFinder

prisstratton

macrumors 6502a
Dec 20, 2011
534
121
Winnipeg, Manitoba, Canada
YES, this is exactly what I was looking for, many thanks.

My system is still running fine, but I am not holding my breath on how long that it is going to remain this way.

It makes absolute sense that we should be able to switch to the integrated graphics to keep our systems going. Shame on Apple for not being proactive in this department, but what do you expect, they want you to buy a new Mac.

I will be bookmarking this page.

Thank You
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.