Safari and app store don't work

Discussion in 'macOS' started by 19nffc97, Feb 7, 2017.

  1. 19nffc97 macrumors newbie

    Joined:
    Jun 26, 2012
    Location:
    Nottingham, England
    #1
    Hi,

    I have a Macbook Pro Mid 2012 running Sierra. I turned it on today, got the usual chime and startup screen, entered my password to log in and then the screen went black with just the cursor showing. I tried several restarts, reset PRAM and SMCand nothing changed.

    I stumbled on a thread which said to enter single user mode by powering up and holding command and s. Wait for the command prompt (root#) and type '/sbin/fsck -fy'. This suggested the disk was ok.

    Then type '/sbin/mount -uw /' and then type 'rm /Library/Preferences/com.apple.loginwindow.plist'. I did this the typed reboot and this appeared to work, after I entered the password this tim it booted to my home screen.

    Now however I can't load safari or the app store. I know that I'm connected to wifi as I can get emails and stream music through Spotify. When I click the safari icon the screen comes up but nothing loads. If I type anything in the menu bar there is just the cross on the right hand side and no blue loading bar, it just does nothing.

    I have compared the system preferences>network settings tab with another identical machine that is working without any problems.

    Anyone have any ideas what I can try?
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    Have you restarted since? Any other problems?
     
  3. 19nffc97 thread starter macrumors newbie

    Joined:
    Jun 26, 2012
    Location:
    Nottingham, England
    #3
    I chatted with Apple support, they said they weren't quite sure what went wrong but a reinstall o the OS did the trick.
     
  4. hkptom macrumors newbie

    Joined:
    Apr 26, 2015
    Location:
    UK
    #4
    I've got the same issue on Sierra on a 2016 2TB 13" Retina MacBook Pro. Other browsers work, but Safari and the Mac App Store won't connect.

    I've deleted the Safari Cache, History etc and still no joy.
     

Share This Page