Safari passwords inconsistent

Discussion in 'iPad' started by DA23Gam, Apr 15, 2018.

  1. DA23Gam macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #1
    Hi
    On some websites requiring log in Safari asks if I want to save the password etc, on other websites it doesn't ask and doesn't remember. Also, on some websites when log in details are recorded and shown in the Settings - App & Website passwords, Safari doesn't log me in.
    Why is this and can I make it more consistent?
     
  2. MacInTO macrumors 65816

    MacInTO

    Joined:
    Apr 25, 2005
    Location:
    Canada, eh!
    #2
    At some point when safari asked you if you want to remember the user ID and password for that particular website you probably selected never. I'm not sure where that preference is stored on the iPad though.

    However, you can add the user ID and password manually in Settings > Accounts & Passwords
     
  3. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #3
    I don't remember ever selecting 'never' & also I have added several ID/Passwords manually in Settings but it makes no difference - still won't log me in. Seems there's some websites with which it just doesn't work.
     
  4. MacInTO macrumors 65816

    MacInTO

    Joined:
    Apr 25, 2005
    Location:
    Canada, eh!
    #4
    Maybe some websites have specific settings for not saving passwords, however, that would seem stranded because it is a browser setting. Seems strange as I access banking websites with my pre-filled ID/password.

    Maybe iCloud has settings that override settings on your iPad.

    Clearing the cache and/or a full iPad reset might solve your problem.
     
  5. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #5
    Mmm. It seems odd because on a PC using Lastpass there isn't a problem with the particular websites.
    Of course installing the Lastpass app on the iPad is kind of a solution although slightly more convoluted to use.
    Twas just a query really, inconsistency bug me.
    Thanks anyway
    (BTW I tried clearing the cache & I don't use iCloud)
     
  6. mattguy10 macrumors 6502a

    mattguy10

    Joined:
    Aug 18, 2010
    #6
    If you’re on iOS 11.3, Safari no longer automatically fills in your username & password just by visiting the login page of a website. You need to tap on the username or password field and then as long as you have a username/password stored for that website in “Accounts & Passwords,” you’ll see “password for this website” with your username listed below above the keyboard. Tap that and then the username/password fields will be automatically filled in.
     
  7. DA23Gam, Apr 17, 2018
    Last edited: Apr 17, 2018

    DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #7
    I am on iOS 11.3 & that's not the case.
    However, I've tried on a few other websites and after tapping on the login box an odd symbol appears above the keyboard - a square with a thick outline on the top and right. Tapping on this fills the usename box with gobbledegook, tapping on the password fills the box with the row of dots but not the correct number for the password length. I did check the entry in the Settings/Passwords - that is correct but is not what is entered in the login boxes.
    On other websites (listed in Settings) the unexplained symbol above the keyboard is grayed out.
    Progress but not there yet.
     
  8. mattguy10 macrumors 6502a

    mattguy10

    Joined:
    Aug 18, 2010
    #8
    So when doing the steps in my last post and you try to login, what happens?
     
  9. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #9
    See my earlier post.
     
  10. mattguy10 macrumors 6502a

    mattguy10

    Joined:
    Aug 18, 2010
    #10
    Can you post a screenshot of the “unexplained symbol?”
     
  11. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #11
    8A4B8156-42EF-4984-B6E4-B34CABB909C8.jpeg
    Here it is, 3rd from left
    --- Post Merged, Apr 17, 2018 ---
    I've been trying a few more. In Settings/Apps & Website passwords/Add Password I add a new entry.
    Now when I visit the website, tap on Username, tap on symbol above keyboard, in the Username box Safari enters the password! Have checked back in Settings & all is as it should be.
    Strange!
     
  12. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #12
    OK, I'm a complete idiot - that's Paste.
    So, if I tap on a login field nothing appears anywhere on the keyboard regarding passwords.
    Have I got something switched off in Settings?
     
  13. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
  14. MacInTO macrumors 65816

    MacInTO

    Joined:
    Apr 25, 2005
    Location:
    Canada, eh!
    #14
    Settings > Safari > Autofill

    Turn on names and passwords
     
  15. DA23Gam thread starter macrumors newbie

    DA23Gam

    Joined:
    Mar 23, 2018
    Location:
    Gamlingay
    #15
    Yup, Settings/Safari/Autofill/Names and passwords, that’s set to On
    I’ll give up at this point and use LastPass instead - it works.
    Thanks all.
     
  16. MacInTO macrumors 65816

    MacInTO

    Joined:
    Apr 25, 2005
    Location:
    Canada, eh!
    #16
    Sounds strange. You should do a reset of your iPad or open a ticket with Apple.
     
  17. Richard8655, Apr 18, 2018
    Last edited: Apr 18, 2018

    Richard8655 macrumors 6502a

    Richard8655

    Joined:
    Mar 11, 2009
    Location:
    Chicago
    #17
    Try turning on iCloud Keychain. I think for this to work properly, iCloud needs to be enabled along with this setting.
     

Share This Page