Screen flicker when watching video fullscreen on Safari after updating to 10.14.6

Discussion in 'macOS Mojave (10.14)' started by dreadlord, Jul 23, 2019.

  1. dreadlord macrumors regular

    dreadlord

    Joined:
    Sep 15, 2016
    Location:
    Istanbul
    #1
    I have updated my Early 2015 13" MacBook Pro to macOS Mojave 10.14.6 last night. After updating my Mac, I see a flicker on my screen a white box appeared on the center of the screen for a second. Then, I watched videos or movies on YouTube/Netflix using Safari, there is a weird flickering on my screen. It just looks like screen brightness goes up and down continuously. Exiting and re-entering to fullscreen fixes the problem.

    Is there anyone who also experience this issue after updating to macOS Mojave 10.14.6?
     
  2. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Haven't experience this issue in 10.14.6. Just tested few videos with different players, browsers.

    No flickering or artifacts in both window and full screen mode.

    P.S. hardware as per my signature
     
  3. dreadlord thread starter macrumors regular

    dreadlord

    Joined:
    Sep 15, 2016
    Location:
    Istanbul
    #3

    Well, this issue does not happen immediately after I enter the fullscreen. This happens after few minutes. Moreover, it is very likely that this is because of buggy graphics driver so this should only be experienced on Intel Iris Graphics 6100 or something.
     
  4. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    I see, then need some Iris 6100 users to help the test. I don't have that.

    But I can play more videos (and play longer) to see if I can hit any bug.
     
  5. whg macrumors regular

    whg

    Joined:
    Aug 2, 2012
    Location:
    Switzerland
    #5
    I don't have the issue on my 2015 MacBook Pro 15" without dGPU (model 11,4). My System Information lists my graphics card as Iris Pro.
     
  6. adamofoz, Aug 14, 2019
    Last edited: Aug 14, 2019

    adamofoz macrumors newbie

    Joined:
    Aug 14, 2019
    #6
    2015 13" mbp same flickering during full screen videos, sometime a pink line too. started with 10.14.6 as well, in safari, not tried another browser. (with intel iris 6100)
    --- Post Merged, Aug 14, 2019 ---
    Actually, i think it might be related to screen brightness auto changing as it happened quite reliably for a while as i walked between the laptop and a window.
     
  7. EternalSynergy macrumors newbie

    EternalSynergy

    Joined:
    Jun 14, 2019
    #7
    Same problem on my Macbook Pro 13 2015. Flickering screen on fullscreen youtube in Safari. I have red flickering vertical line more on the left side of screen. No issues on fullscreen videos in Chrome and Firefox. Issue appeared after updating to MacOS 10.14.6.
     
  8. glitch626 macrumors newbie

    Joined:
    Sunday
    #8
    Just started experiencing this on my 2015 21.5 Retina 4K iMac (with Intel Iris Pro Graphics 6200) today. Seems to be a problem with every browser/website/player. I've tested for it in QuickTime, Safari (Youtube), Chrome, and iTunes. Almost looks like the display is trying to enter sleep mode, repeatedly. Vertical video in QuickTime does appear to work properly in full screen, though.

    Thanks for the tip about exiting and re-entering.
     
  9. cigz macrumors newbie

    Joined:
    Nov 7, 2016
    #9
    In my case when i watch youtube videos and i stop moving the mouse, the colours are changing and they look warmer but when i watch Netflix and i stop moving the mouse, the quality of the videos is going down and i can see the artifacts when there's dark scene. If i start moving the mouse, it's back to good quality, no artifacts and so on. I had that in 10.14.4, it was fixed in 10.14.5 and now it's back again.
     
  10. dreadlord thread starter macrumors regular

    dreadlord

    Joined:
    Sep 15, 2016
    Location:
    Istanbul
    #10
    Reported this bug to Apple last week, haven't heard a response yet.
     
  11. Lion_Mini_Yosemite_rMBP macrumors newbie

    Lion_Mini_Yosemite_rMBP

    Joined:
    Jan 5, 2018
    Location:
    Chicago, IL
    #11
    I encounter this issue, with both Netflix and Youtube as you stated, but only when I have "Night Shift" enabled, otherwise it operates normally. Are you having this issue when Night Shift is off?
     
  12. dreadlord thread starter macrumors regular

    dreadlord

    Joined:
    Sep 15, 2016
    Location:
    Istanbul
    #12
    Yes. It happens wether Night Shift is on or off.
     

Share This Page

11 July 23, 2019