Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

foxfire_pt

macrumors newbie
Original poster
Mar 17, 2016
4
0
Portugal
Hello
today my dad installed "Security Update 2020-001 Catalina" on my old Mackbook retina 15 ( 2012 ) and it broke his A1016 Apple Wireless Keyboard ( it is the old transparent white one ).
First i thought it was his macbook, so i tried the usual SMC, PROM , delete Bluetooth files and resetting bluetooth. Nothing worked.
I tried it on my Mackbook 16 and the keyboard worked like a charm. But i notices that the patch was not yet installed. So i installed it and to my NOT suprise the keyboard had the same problem.
You can pair it and it will work ok for about 3-5 seconds then it will disconnect and reconnects and disconnects again in 3-5 seconds and so on. Basicly useless.
Anyone else having problems with bluetooth devices ?

cheers
JC
 

foxfire_pt

macrumors newbie
Original poster
Mar 17, 2016
4
0
Portugal
Unfortuntly no, my fix was connecting an USB keyboard i had laying around.
I did leave feedback of the problem on the apple website.
Hoping for a fix in the next patch, but not holding my breath.
 

AVR2

macrumors 6502
Jan 16, 2006
425
10
Just to add, my A1314 Bluetooth keyboard, which has worked perfectly for years, has gone to hell since I replaced my 2009 Mac mini with a late 2012 running Catalina which already had the security update installed.

My Bluetooth mouse still works fine.

I *need* a wireless keyboard for that machine, so I've had to order one with a USB receiver.
 

EchoSierra

macrumors member
Mar 29, 2015
44
8
Boston, MA
I'm typing this on my A1016 bluetooth keyboard on a 16" MBP running Catalina with all of the updates installed. No problems here, so if it's the update that is the issue, it might just be something affecting older Macs.
 

OxyT

macrumors newbie
Apr 17, 2021
1
0
Running a 2020 iMac27 with Catalina and all the updates installed. Just bought an A1016 and it was giving me the same issue. Especially just after booting into MacOS. (Bootcamp Windows seems to work without a hitch-didn't even have to pair the keyboard with Windows) Once the keyboard is working, it seems to be fine (I'm typing on it now), but there's definitely a "hit and miss" aspect to it. I can't seem to log in from boot, nor does it work to select the boot device.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.