Sierra disabled password requirement on DiskImages ?

Discussion in 'macOS Sierra (10.12)' started by droplink, Apr 14, 2017.

  1. droplink macrumors member

    Joined:
    Dec 7, 2014
    #1
    Hi!

    In the last round of updates, it seems Apple has decided I no longer need to enter a password to open my encrypted (dmg) disk images.
    I can now open them without having to enter my password!
    How did this happen ?!

    I use encrypted disk images as an extra layer of security, but that seems to now have gone out the window.
    I have tried to disable Keychain (never use that) but that has not helped.

    What on Earth happened and how do I get my password requirement back ?

    Dammit Apple, that is my LIFE you are messing with!
     
  2. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #2
    I cannot reproduce this problem.

    A.
     
  3. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #3
    You probably saved the password in your keychain. What do you mean by "tried to disable Keychain?" macOS always uses a keychain and disabling iCloud keychain won't prevent you from saving passwords in the keychain tied to your local account. Open Keychain Access from the Utilities folder and look for the disk image's password there.
    Disk image password behavior works just the same in Sierra as in older versions of OS X.
     

Share This Page