SMB Woes with Windows 10 Pro fileshare

Discussion in 'OS X El Capitan (10.11)' started by andyask, Mar 8, 2016.

  1. andyask macrumors newbie

    andyask

    Joined:
    Mar 8, 2016
    Location:
    Slough, UK
    #1
    Hi All
    I have a client with 3 El Capitan iMacs in a serviced office environment and a newly built Windows 10 Pro physical machine which acts as a file server. I have a share set up with shared access under the main Admin Account on the machine. The same account is used to authenticate on the Macs.
    Very simply the 3 Mac's connect to this machine via mapped drives. It all worked reasonably well under Windows 7 Pro in their previous office with the occasional "Read Only" error when users connected (once per week on average but they lived with it) At this time we have only 1 El Capitan machine in the office. This was fixed by a resave or server reboot. After upgrading to a new Windows 10 server with the same data copied into a new fileshare, users now get the following problems when trying to save files in Excel:

    -Save Not Completed - File Rename Failed. Retry?
    -Grant File Access - Additional permissions are required to access the following file.
    -Alert! Your changes could not be saved to March.xlsx but were saved to a temporary document.

    Screen Shot 2016-03-09 at 01.22.44.png

    Screen Shot 2016-03-09 at 01.23.01.png

    Screen Shot 2016-03-09 at 01.23.18.png


    It usually happens within 60 minutes of the user logging on, opening files etc. It works for a while then suddenly refuses to save the file.

    What I have tried:

    Checked hardware and swapped out cables etc.
    Resaved Excel file in .xls format
    Copied .xlsx to Mac then copied back to server
    Removed/Readded permissions on the Win10 Pro machine
    Enabled Excel fileshare function
    Copied data from existing Excel sheets to new one manually.
    Tried from three different iMacs, all El Capitan. Same issue
    Fully rebuilt 1 iMac to ensure not upgrade issues present.
    Updated to Office 2016 after clean 2011 removal. No joy.
    Tested in Word - unable to delete a newly created file by same user.
    Moved entire shared folder to new location with folder freshly created and correctly shared.
    No specific errors on the Win10 event log.
    Excluded the share from Windows 10 File History backups
    Excluded the share from Windows Defender protection
    Created new 2nd server in identical configuration using Win 10 Pro laptop - same issue!

    For now I have moved the core files to an iMac and shared from there but I would really like to be able to use my new 4TB drive on the Win10 Pro machine to share files as intended. I have read about SMB2 and SMB3 support and wonder whether this is fully interoperable and compatible with Windows 10 - is there any Apple support statement for example?

    Before I do this is there anything else I can try - surely I am not the only person struggling with this?
    Have spent about 10 hours on this of late and getting many grey hairs.

    I am now thinking of a Netgear ReadyNas for better Apple support in file sharing as we have on other client sites with no issues at all.

    Any help greatly appreciated!
    Andrew
     
  2. MrNomNoms macrumors 65816

    MrNomNoms

    Joined:
    Jan 25, 2011
    Location:
    Wellington, New Zealand
    #2
    Is it an absolute requirement to run Windows 10 on the server? the reason why I ask is that it might be best to possibly look at maybe setting up a Linux or *BSD as a server; Netatalk for AFP and SAMBA for SMB or maybe even NFS which requires a little work but worth it in. If all you're going to use it for is a file server and you have three users then maybe the Drobo 5N which has Netatalk for AFP sharing. I've owned my Drobo 5D for almost 2 years without any problems.
     
  3. andyask thread starter macrumors newbie

    andyask

    Joined:
    Mar 8, 2016
    Location:
    Slough, UK
    #3
    Hi MrNomNoms
    Thanks for the suggestion. The Win10 PC in question is also used as a normal Desktop once per week for a half-day. It needs to be a familiar operating system that the users on site can understand and recognise. As we have other clients using Netgear ReadyNAS without issue (it supports SMB and AFP) I am looking at this as a solution. It does seem, through the lack of replies, that no-one really uses Windows as a fileserver for a Mac environment.

    Andrew
     

Share This Page