Resolved SSD not working internally (mid-2012, Crucial MX500)

Discussion in 'Mac Basics and Help' started by timnye111, Oct 26, 2018.

  1. timnye111 macrumors newbie

    Joined:
    Oct 26, 2018
    #1
    Hi,

    I have just bought an SSD (Crucial MX500). After many attempts and various problems along the way I have FINALLY managed to clone successfully using Carbon Copy Cloner. My drive is now bootable from a USB-SATA cable by starting up with option key. So clearly the drive is ok.

    However, when I install the drive into my mid-2012 Macbook Pro (running Mojave 10.14, 16GB RAM), it won't start. I get a grey screen with alternating Apple logo, question mark folder and no entry sign.

    I have tried resetting PRAM. When selecting startup disk in recovery mode, I can find and select my new SSD even when it's internal, but it just won't start. I have also tried using a bootable USB to install Mojave on the drive and also downloading it via Internet Recovery but I get the error message 'an internal error occurred while preflighting your volume for APFS conversion'. Restoring from Time Machine or from the old drive mounted externally gives me OSstatus error 1 or 22.

    I have read dozens of other threads on this and the SATA cable seems to be the most common cause. But going against this for me is the fact that (1) the cable works when I put my old HDD in (i.e. no problems starting up) and (2) I replaced it two weeks ago (this is what got me believing I was competent enough to upgrade the SSD!).

    I am reluctant to try other cloning methods as I feel I'm at the last hurdle and would love to avoid re-erasing the drive and starting again - having a bootable drive feels like I'm so close to problem solved! Any suggestions greatly appreciated.

    Thanks so much in advance!
     
  2. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    The issue is the SATA cable. The 13" mid-2012s have a very high failure rate for this. At one point Apple had a silent repair program for it.

    Just to also reassure you - you've gone through all the troubleshooting steps to confirm this. A new cable shouldn't cost much and will be really quick to fit. Make sure you get a decent one rather than an eBay one or a refurb though. Best of luck! :)

    EDIT: I've just read you already put a new cable in. Can you link me to the one you bought please?
     
  3. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    OP:

    Just to be clear... what happens when you do the following?
    1. Power down, all the way off
    2. Press the power on button
    3. Immediately hold down the option key and KEEP HOLDING IT DOWN until the startup manager appears

    Do you see the SSD in the startup manager?
    What happens if you click on it with the pointer and then hit return?
     
  4. timnye111 thread starter macrumors newbie

    Joined:
    Oct 26, 2018
    #4
    Thanks, I did find the SSD in option but the problem happened when I selected it. All resolved now!
    --- Post Merged, Oct 26, 2018 ---
    Thanks, I'd ordered a new one already with the last replacement because they were so cheap - and I fitted the new new one this afternoon and it worked! Slightly surprised the old one failed so quickly but I'll send it back to the seller. Thanks for your help. Hope this thread will be useful for future people with the same problem!

    https://www.ebay.co.uk/itm/HDD-Appl...e=STRK:MEBIDX:IT&_trksid=p2057872.m2749.l2649
     
  5. MSastre macrumors 6502

    MSastre

    Joined:
    Aug 18, 2014
    #5
    I have several Crucial MX500's in different computers here. Good SSD drives.
     

Share This Page

4 October 26, 2018