Strange Mac Mini 2012 Fusion Drive Boot/Formatting Problem

Discussion in 'Mac mini' started by rootsmaneuver, Jan 7, 2016.

  1. rootsmaneuver macrumors member

    Joined:
    Mar 22, 2006
    Location:
    Wisco
    #1
    I'm wondering if anyone else has had this type of thing happen to them and hoping for some enlightenment before I reformat...

    I have a 2012 Mac Mini quad i7, 16 GB RAM, and a fusion drive (240GB OWC SSD and 1.5TB HDD)

    I sat down at the machine yesterday morning to do a short simple task and shortly after waking the system i got the spinning beach ball and the system was unresponsive. After waiting five minutes or so, I force-shut-down the machine. On reboot, I get the Apple logo and progress bar but progress halts at about 50%. After several more attempts, the problem remained. Tried repairing the disk from the recovery partition. No problems found.

    Started up from another disk and was able to move any recent files and work from the machine to another disk. I check the system with Apple Hardware Test/Diagnostics and everything checks out fine (long test). I decide to reformat the internal fusion drive. Upon attempting this, the screen goes black and the machine simply restarts mid-process. Apparently it didn't get very far because the system still sees the drive just as before. Several more attempts and the same thing happens.

    The only logical next step I can think of is to remove the drives and format/test individually. I'm assuming one is failing but it's strange to me that the system doesn't recognize a problem in Disk Utility.

    Have any of you reading this ever experienced something like this? Any ideas to try before I open this damn machine up? I think I may be done with fusion drives...

    Thank in advance
     
  2. Negritude macrumors 6502

    Joined:
    Jul 14, 2011
    #2
    "I think I may be done with fusion drives..."

    You mean "done" as in making your own. Haven't heard of this problem with Apple provided fusion setups. Maybe there's something to the quality of the drives you're using or their features that is resulting in these problems. Maybe things might work differently if you created a fusion drive using the same parts that Apple does. Maybe the size of the drives has something to do with it, which are not the sizes Apple uses. Just thinking out loud.
     
  3. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #3
    You don't need to remove the drives in order to re-initialize and test them "individually".

    All you need is to "split apart" the fusion drive by removing CORE storage and creating two "standalone" drives.

    I don't know whether this is possible using the recovery partition. I believe (as a default) the recovery partition will try to "re-create" the fusion drive from the SSD and HDD (RP "sees" that two drives are installed and "assumes" that they are supposed to be "fused"). I'm not sure if this can be manually overridden.

    You -CAN- do this by "booting externally" from an external drive.

    You'll need to know the proper terminal commands to use. I've never actually worked with a fusion drive in terminal, you'll have to do the research on which commands to use and how to use them.
    Perhaps others will jump in with the answer.

    There are pages "out on the web" with the necessary information.
     
  4. rootsmaneuver thread starter macrumors member

    Joined:
    Mar 22, 2006
    Location:
    Wisco
    #4
    Thanks for the reply. Yeah, I actually hadn't intended to create a fusion drive when I installed the drives. When I initially installed the extra drive (SSD) they were both already formatted and the system saw them as two drives. Then at some point I had to reinstall the system for a reason I cannot now recall, and the Mac Mini's disk utility app would ONLY allow me to make a fusion drive. It's worked relatively fine up till now but I don't like that I cannot check each disk individually for problems.
    --- Post Merged, Jan 8, 2016 ---
    Thank you for your input as well. I'll start looking.
     

Share This Page