Things 10.5.1 still hasn't fixed

Discussion in 'macOS' started by kolax, Nov 16, 2007.

  1. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #1
    Airport Disks still don't always show up in the Sidebar under the Router name. I still have to restart in order to get full access to both my Airport Disks.

    When opening folders through the Finder, I still have to click off the folder then double click back on to continue surfing through the folder. If I don't, then no matter how much I double click on the folder, file or whatever, it doesn't open. I have to click off it, then double click again. In general, double clicking just isn't very responsive at all.

    Ejecting connected external hard drives, I still cannot eject certain things, such as my Time Machine hard drive.

    Still no Bluetooth support in Address Book.

    That's things just off the top of my head. There is a few other problems I can't remember.
     
  2. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #2
    - Haven't fixed Time Machine over NAS
    - WoW has a serious issue where FPS drops to about 9 FPS for about 2 minutes every 15 minutes or so. Needless to say, its unbelievable annoying. This isn't a WoW issue. This does happen when its not running, but you don't notice it. (Unless you are watching video, or streaming to an AppleTV or something)
    - Mail.app stops receiving new mail every once in a while, forcing you to restart.
    - Flash is still unstable
    - Shutdown takes a long arse time compared to Tiger.
    - Airport still isn't totally stable, its better though.
    - My keychain got corrupted again. There seems to be some issues importing and using x509 .p12 certs. (I haven't tried PEM or DER format)
    - NAS mounts (SMB and AFP) get stuck when they connection drops, and you can't eject it. (Sometimes, this blocks remounting the share)

    This is just off the top of my head.
     
  3. JayLenochiniMac macrumors G5

    Joined:
    Nov 7, 2007
    Location:
    New Sanfrakota
    #3
    -Sharing still doesn't work (Leopard sees the other computer's icon, but displays empty content and rejects registrated users due to invalid username/password)
    -Right clicking doesn't work in dashboard
     
  4. squeeks macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #4
    -macbook/macbook pro screens still turn off after 30 seconds regardless of setting (unless set to never)
     
  5. jepaz macrumors regular

    Joined:
    Oct 1, 2007
    Location:
    USA
    #5
    Repair Disk Permission is still slow though the progress bar has been fixed.

    When I run RDP after applying the 10.5.1 patch, initially it reported less than a minute to complete then changes to 59 minutes...what the hell?

    No more SUID warning.
     
  6. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #6
    SUID issues under Disk Utility.

    com.apple.dyld throttling -- which is more serious since it can chew up cycles.

    ---

    Both of which are likely tied to installer problems, which isn't good.

    I saw both after the 10.5.1 update, but reran a couple things that happen during the install and saw that most of both went away (back down to one apple remote access issue.)
     
  7. petvas macrumors 601

    petvas

    Joined:
    Jul 20, 2006
    Location:
    Mannheim, Germany
    #7
    The SUID issues will go away if you apply the full installer.
     
  8. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #8
    Repair permissions takes about a minute or so and it's not a big deal since it's not something needed even on a weekly basis.
     
  9. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
    #9
    I have the same FPS drop with WC3....
     
  10. kolax thread starter macrumors G3

    Joined:
    Mar 20, 2007
    #10
    Just to enhance upon this double clicking issue I'm having (anyone else experience it?) - it happens with anything, sometimes it just doesn't open things unless I click off the item I'm clicking on (stacks, links in Safari etc) then click again.

    Repairing disk permissions does take a while for me too.
     
  11. odinsride macrumors 65816

    odinsride

    Joined:
    Apr 11, 2007
    #11
    Finder doesn't always seem to remember Folder View settings
    Screen Capture has a Memory Leak
    Expose forgets Hotkey settings
    MBP Screen Backlight turns off regardless of energy saver settings.
     
  12. jepaz macrumors regular

    Joined:
    Oct 1, 2007
    Location:
    USA
    #12
    I disagree, I applied the patch via software update and no SUID warning anymore.
     
  13. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #13
    Another 2 things they haven't fixed which *REALLY* drive me nuts.

    - You can't paste WPA keys into the dialog box that requests them, Apple seems to think I enjoy typing out 40 character keys. (I have found the only work around is to drag the text into the box)
    - You can't paste into the dialog box that requests the password used in your private SSH key. I use an application called data guardian which allows me to store my passwords with 448 bit blowfish encryption, I can then look up accounts and copy the password. Then I paste it into those dialog boxes. A number of people I work with are bad shoulder surfers and this has prevented it. The drag trick doesn't work here. I can't even begin to understand why Apple did this, it makes no sense. Before you say it, no ... storing my password in the keychain doesn't solve the problem and totally removes the reason why I put a password on my private SSH key in the first place!
     
  14. dr_lha macrumors 68000

    Joined:
    Oct 8, 2003
    #14
    I think people need to send out a patch to people's brains to stop them doing all this pointless "Repair Permissions" all the time. Folks, its not 2002 any more. ;)
     
  15. Veri macrumors 6502a

    Joined:
    Sep 23, 2007
    #15
    IIRC NSSecureTextField, assuming it's used, prevents copying out by design, but can't recall about pasting in.

    I imagine the argument goes along the lines that a password is something you're expected to remember, and that you're using the wrong authentication mechanism if you start meddling with copying and pasting them. Moreover, I imagine the system clipboard is not regarded as secure for moving passwords around, whereas I'd hope that e.g. the WPA password remains in non-privileged memory for little to no time.

    A password doesn't have to be a string of meaningless characters to be secure, just sufficiently long - a^b increases faster with b than with a; so "eating slowly, he swims across the cyan ravine!" is easy to remember and very unlikely to be obtained in a dictionary attack.
     
  16. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #16
    Sure, copying from makes sense ... that would be rather silly to allow.

    Sure, the clipboard isn't the more secure thing in the world. (Unless maybe if you enable secure virtual memory which I don't) I have DG set to erase the clipboard after x minutes. This seems to only happen after I grab a password from the database.

    I supposed I could understand your argument on why they would prevent passwords from being pasted into the dialog for SSH private keys (Which is a totally new feature with Leopard, Tiger didn't do this crap).

    However, preventing pasting into the WPA dialog is by far the dumbest thing I have ever seen. It seriously encourages people to have weaker easier to type in passwords. Why type a 40 character very random password, when you can type a 4 digit number.

    Its only creating a false sense of security, it really isn't preventing anything.
     
  17. djellison macrumors 68020

    Joined:
    Feb 2, 2007
    Location:
    Pasadena CA
    #17
    Other machines in shares tab of finder not showing at all, or showing when the machine in question is actually turned off. Networking is just broken with Leopard for me. Tiger..never a problem. Leopard...broken.

    Doug
     
  18. Blubbert macrumors 6502

    Joined:
    Nov 1, 2006
    #18
    Really? I havent noticed that behavior at all, if anything, WoW got faster with Leopard, and even faster with the WoW 2.3 update.
     
  19. Ron21 macrumors 6502a

    Joined:
    Sep 6, 2007
    #19
    Don't forget the annoying popping sound when external speakers are plugged in! (SR MB)
     
  20. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #20
    I'm not having any problems with Leopard, even after updated to 10.5.1. The only problem i thought I was having was repair permissions, it took over 5 minutes to start, hdd didn't make any sounds like it was running or that. It was messed up. But I let it run and it ran.

    What did you guys do to your systems? I have had really no problems with Leopard.
     
  21. PupnTaco macrumors regular

    PupnTaco

    Joined:
    May 29, 2007
    #21
    • Time Machine induces a kernel panic (G5 dual DDR, 3GB RAM, backing up to 1TB external FireWire 800)

    • Sleep induces a kernel panic

    • iCal events no longer sync to iPhone and vice-versa
     
  22. /dev/toaster macrumors 68020

    /dev/toaster

    Joined:
    Feb 23, 2006
    Location:
    San Francisco, CA
    #22
    Hmmm, thats interesting. I have not had any trouble with sleeping my machine. Also, iCal syncs up with my iPhone no problem. Its something I use very heavily.
     
  23. PupnTaco macrumors regular

    PupnTaco

    Joined:
    May 29, 2007
    #23
    I've dug through the Discussions at Apple Support and there are a few others with this same problem and no fix.

    Also:

    • A "System/Library/Caches/com.apple.bootstamps/EE82FB2A-063F-3AF8-8B2C-CE849050D6D6" folder is created on my 2nd internal hard drive every time at startup

    • On Shut Down or Restart, the "there are other users logged in who may lose changes" etc. message won't take my Admin user & pass, even though I'm the only Admin on the machine, it takes that pass to log me in or install apps. Permissions have been verified & repaired multiple times. The only way around it is to switch over to the other users and manually log them each out.
     
  24. pkoch1 macrumors 6502a

    pkoch1

    Joined:
    Oct 3, 2007
    Location:
    Boston
    #24
    You think so? I work in apple tech support and permissions get messed up all the time and need to be fixed. A permissions repair is all that it needs a lot of the time.


     
  25. Mindcrime macrumors regular

    Mindcrime

    Joined:
    Oct 24, 2003
    Location:
    Houston, Texas
    #25
    Stacks are still ******.

    But I don't expect this to ever get fixed, at least not until 10.6 when the restored folder/dock functionality becomes a "new feature."
     

Share This Page