Triple boot accident (Help needed)

Discussion in 'Windows, Linux & Others on the Mac' started by Tonic76, May 11, 2017.

  1. Tonic76 macrumors newbie

    Tonic76

    Joined:
    May 11, 2017
    #1
    I need some help with possible triple booting jam that I created.

    1) I had succesfully installed Boot Camp and Windows 10 to my Macbook Pro.

    THEN

    When I was logged to OSX
    2) I tried to create bootable LINUX (Ubuntu-16.04.2) USB stick as I had done before using the Unetbootin tool

    Because the destination to write the boot files is a little confusing in Unetbootin tool I accidentally created the Linux boot files to my Windows NTFS partition (It was detected as USB stick, dev/disk0s4 in Unetbootin...)

    Now I am afraid to try to boot to Windows because Linux is also on the same partition. I heard Linux and Windows don't really like being on same partition.

    Should I have any worries or how to correct the situation? Did Linux Ubuntu install overwrite any critical files that would stop me booting to Windows? Do you think I can boot to Linux now?

    So many questions. I hope the community can provide some insight, thanks.
     
  2. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #2
    Was disk0s4 the basic data partition for windows (the largest partition)?

    What does the partition look like in Disk Utility now?

    For future reference depending on the system if it supports UEFI just mount the OS image and copy the files directly onto the USB. UEFI is smart enough to boot from that without the need for unetbootin, lili, etc etc.
     
  3. Tonic76 thread starter macrumors newbie

    Tonic76

    Joined:
    May 11, 2017
    #3
    Actually the OSX spotlight became unresponsive so I rebooted and when get back to the computer, it had booted into Windows. So at least windows seem to load OK. :)

    I have two partitions now in my SSD, 194G Machintosh HD and 55,77G BOOTCAMP

    All seems to be good, maybe only setback now is some Ubuntu files taking up disk space in the BOOTCAMP (NTFS) partition. I better not delete any of those before know what they are.

    I think I will anyway try to make another USB stick still with unetbootin and take a look what files it puts to clean USB stick.

    I don't know if my MBP PRO MID 2014 support UEFI or not?
     
  4. Fancuku macrumors 6502a

    Fancuku

    Joined:
    Oct 8, 2015
    Location:
    PA, USA
    #4
    I am surprised that Unetbootin let you write on the disk. For me, if I didn't select the right disk (usb stick) it wouldn't procede with the installation.
     
  5. Dweez macrumors 65816

    Dweez

    Joined:
    Jun 13, 2011
    Location:
    Down by the river
    #5
    If it were me I'd delete the current boot camp config & start fresh.
     
  6. Tonic76 thread starter macrumors newbie

    Tonic76

    Joined:
    May 11, 2017
    #6
    Maybe it is because I have Paragon NTFS for Mac installed?
    --- Post Merged, May 13, 2017 ---
    So much trouble... I think just to find out what files unnetbootin wrote to my NTFS partition and delete those will do the trick...
     
  7. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #7
    Mount the image and look at the files. They are likely in a folder no?

    However I actually find it kind of unlikely those files made it from Unetbootin running in MacOS (HFS+) to the Windows partition (NTFS). I could be wrong because I've never tried it (you are probably treading new ground for most) but it seems odd you could have done it in the first place, although I'm not sure what Unetbootin is capable of exactly. EDIT: Just saw you said Paragon, so its probably possible...?

    Regardless try looking up some key files from Ubuntu boot disk. Probably see folders like boot, casper, pool, preseed, EFI, dists, isolinux, etc. A file md5sum.txt is a dead give away too. If all those are in one place its safe to delete. If you find them scattered around you might want to just leave them.

    I'll edit this in a minute with a screen shot of bootable Linux USB main folder.

    bootusb.png
    Thats is Ubuntu gnome 17.04 but the folders will be the same. If you can't find them I would just pretend this never happened....lol
     
  8. Tonic76 thread starter macrumors newbie

    Tonic76

    Joined:
    May 11, 2017
    #8
    Thanks for your awesome reply. I can see all those files in my BOOTCAMP root (except one "System Volume Information). Going to delete those now.
     

Share This Page