Unable to remove Windows Boot Camp partition

Discussion in 'macOS' started by ourcore, May 4, 2018.

  1. ourcore macrumors regular

    ourcore

    Joined:
    Aug 4, 2012
    #1
    About a year ago, I installed Windows 10 via Boot Camp, which I now want to remove, but it doesn't seem to be done causing issues... When I go into the Boot Camp assistant, I get this message:
    [​IMG]

    My Disk Utility looks like this:
    [​IMG]
    diskutil list gives me:
    /dev/disk0 (internal):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme 1.0 TB disk0
    1: EFI EFI 314.6 MB disk0s1
    2: Apple_APFS Container disk1 912.4 GB disk0s2
    3: Microsoft Basic Data Windows 78.8 GB disk0s3
    4: Windows Recovery 480.2 MB disk0s4

    /dev/disk1 (synthesized):
    #: TYPE NAME SIZE IDENTIFIER
    0: APFS Container Scheme - +912.4 GB disk1
    Physical Store disk0s2
    1: APFS Volume Macintosh HD 474.7 GB disk1s1
    2: APFS Volume Preboot 20.5 MB disk1s2
    3: APFS Volume Recovery 517.8 MB disk1s3
    4: APFS Volume VM 2.1 GB disk1s4

    /dev/disk2 (external, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *8.0 TB disk2
    1: EFI EFI 209.7 MB disk2s1
    2: Microsoft Basic Data Seagate 02 8.0 TB disk2s2

    /dev/disk3 (external, physical):
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *8.0 TB disk3
    1: EFI EFI 209.7 MB disk3s1
    2: Microsoft Basic Data Seagate 01 8.0 TB disk3s2

    What's the safest way to completely remove the partition/Windows? I'm just scared of messing something up. Thanks in advance!
     
  2. Rodan52 macrumors regular

    Rodan52

    Joined:
    Sep 21, 2013
    Location:
    Melbourne, Australia and Bali, Indonesia
    #2
    I have the same problem and have been working on finding an answer for weeks. The bottom line here is that Boot Camp Assistant does not seem capable of recognizing macOSX High Sierra APFS (the new Apple filing system). You may notice in the dialogue box you sent that BCA suggests that the Macintosh HD must be formatted as Mac OS Extended (Journalled).
    So, I have arrived at a solution but I have not had time to try it yet.
    Create a USB bootable installer for macOSX High Sierra. Use it to boot your device, erase the HD (thus removing the Windows Partition) and reinstall a new copy of High Sierra (Clean Install).
    Restore all of my data from a Carbon Copy Cloner backup by reverse cloning.
    Hopefully the Macintosh HD will retain the APFS despite the CCC clone being on a HFS+ EHD.
     
  3. mattguy10 macrumors 6502a

    mattguy10

    Joined:
    Aug 18, 2010
    #3
    What’s causing the error message in Boot Camp Assistant is Windows Recovery (disk0s4) which is shown above in your “diskutil list.”

    Open terminal and run this command:

    sudo diskutil eraseVolume "Free Space" %noformat% /dev/disk0s4

    Enter your admin password if prompted to do so.

    If that command is successful (an error message will appear if it isn’t) run this command next. Even if it isn’t successful, run this command anyway.

    diskutil apfs resizeContainer disk0s2 0

    Now go back and open Boot Camp Assistant again and you should be able to move forward with removing Windows.
     
  4. Rodan52 macrumors regular

    Rodan52

    Joined:
    Sep 21, 2013
    Location:
    Melbourne, Australia and Bali, Indonesia
    #4
    Well, i solved my issue in an unexpected and simple way. I had a Bootable High Sierra USB installer which I used to boot my MBP and out of curiosity I opened Disk Utility from the Installer window and realised I could erase the Windows partition from the Partition Tab. I really didnt expect this to be successful but as I was intending to erase the Macintosh HD anyway I thought what the heck. To my great surprise I got a dialogue box informing me that the partition would be erased, reformatted as APFS and returned to the Mac HD as free space.
    I had a current clone of my HD and I wouldnt advise anyone to try this method without a backup. I could have used the Recovery partition on my clone to boot and perform the same process which might be more reliable but the USB installer worked for me.
     

Share This Page